Project

General

Profile

Feature #14447

Replace UUI with Win32 Disk Imager

Added by anonym about 1 year ago. Updated 8 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
Start date:
08/24/2017
Due date:
% Done:

0%

QA Check:
Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

https://sourceforge.net/projects/win32diskimager/

It's a dd for Windows with a simple GUI. In other words, it should keep working as long as our dd instructions work.

Win32 Disk Imager.png View (48.3 KB) sajolida, 02/04/2018 05:07 PM


Related issues

Related to Tails - Feature #10984: Test Rufus Rejected 01/22/2016
Related to Tails - Bug #11348: Test Etcher, a multiplatform USB stick burner Resolved 04/14/2016
Related to Tails - Bug #13206: Install by cloning sometimes silently fails from a stick installed with UUI Rejected 09/29/2017
Related to Tails - Bug #14959: Test UEFI boot with a Tails installed with UUI Resolved 11/11/2017

History

#1 Updated by sajolida about 1 year ago

#2 Updated by sajolida about 1 year ago

  • Related to Bug #11348: Test Etcher, a multiplatform USB stick burner added

#3 Updated by intrigeri about 1 year ago

Does UUI work for UEFI boot? If it does, then this proposal brings a serious regression.

#4 Updated by anonym about 1 year ago

  • Status changed from New to Confirmed

intrigeri wrote:

Does UUI work for UEFI boot? If it does, then this proposal brings a serious regression.

For the record, dd-type installation doesn't work with UEFI in our automated test suite. I verified with:

  Scenario: bla
    Given a computer
    And the computer is set to boot in UEFI mode
    Given I temporarily create a 4 GiB disk named "isohybrid" 
    And I write the Tails ISO image to disk "isohybrid" 
    When I start Tails from USB drive "isohybrid" with network unplugged and I login

(last step fails at UEFI boot menu)

#5 Updated by sajolida about 1 year ago

  • Assignee changed from sajolida to anonym

I don't have access to a UEFI computer so I cannot test UUI on UEFI.

anonym: Can you do that?

#6 Updated by intrigeri about 1 year ago

  • Target version changed from Tails_3.2 to Tails_3.5

#7 Updated by sajolida 12 months ago

  • Related to Bug #13206: Install by cloning sometimes silently fails from a stick installed with UUI added

#8 Updated by intrigeri 11 months ago

  • Related to Bug #14959: Test UEFI boot with a Tails installed with UUI added

#9 Updated by intrigeri 11 months ago

  • Assignee changed from anonym to sajolida

sajolida wrote:

I don't have access to a UEFI computer so I cannot test UUI on UEFI.

anonym: Can you do that?

Moved this to #14959: it's somewhat off-topic here, and it makes little sense to me to block on this test before sajolida can make progress here.

#10 Updated by anonym 8 months ago

  • Target version changed from Tails_3.5 to Tails_3.6

#11 Updated by sajolida 8 months ago

#12 Updated by sajolida 8 months ago

  • Status changed from Confirmed to Rejected
  • Assignee deleted (sajolida)

Tested on https://tails.boum.org/blueprint/usb_install_and_upgrade/usb_bootable_disk_image/#win32-disk-imager.

I'm rejecting this ticket because:

  • Win32 is extremelly slow and has other UX glitches.
  • ISO images installed using dd (or similar tools) fail to boot on UEFI while UUI works on some (despite having an MBR partition table).

So switching from UUI to Win32 Disk Images would be at least a regression on quite a few UEFI laptops.

Also available in: Atom PDF