Project

General

Profile

Feature #14476

Feature #14468: Add VeraCrypt support to Tails

Write user documentation for VeraCrypt support in Tails

Added by segfault about 1 year ago. Updated 16 days ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
10/08/2017
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
feature/14481-TCRYPT-support-beta
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

This is "A.7 Write user documentation".

This will replace the documentation we have on opening TrueCrypt volumes using cryptsetup on the command line. We might also work upstream with GNOME for some of this work.

VeraCrypt Documentation.png View - Buggy navigation bar in (82.5 KB) segfault, 07/24/2018 10:13 PM

VeraCrypt Documentation in Tor Browser.png View - Buggy navigation bar in Tor Browser (99.1 KB) segfault, 07/24/2018 10:15 PM


Related issues

Blocks Tails - Feature #14477: User testing and community feedback for VeraCrypt support In Progress 12/10/2017
Blocked by Tails - Feature #15043: Iteration 4: Create VeraCrypt Mounter application Resolved 08/14/2018

Associated revisions

Revision ddcc62d5
Added by intrigeri about 1 month ago

Merge remote-tracking branch 'origin/feature/14481-TCRYPT-support-beta' into testing (Fix-committed: #14476).

History

#1 Updated by sajolida about 1 year ago

  • Target version changed from Tails_3.9 to Tails_3.8

Ideally, I need that done for the user testing.

#2 Updated by intrigeri 12 months ago

  • Description updated (diff)

#3 Updated by intrigeri 12 months ago

  • Blocks Feature #14477: User testing and community feedback for VeraCrypt support added

#4 Updated by intrigeri 12 months ago

  • Blocked by Feature #11684: Add support for VeraCrypt volumes in GNOME Disks added

#5 Updated by intrigeri 12 months ago

  • Blocked by Feature #14464: Add VeraCrypt support to GNOME Files added

#6 Updated by intrigeri 4 months ago

Enough of #11684 is done to do this so I'll drop the relationship with that ticket.

#7 Updated by intrigeri 4 months ago

  • Blocked by deleted (Feature #11684: Add support for VeraCrypt volumes in GNOME Disks)

#8 Updated by intrigeri 4 months ago

  • Blocked by deleted (Feature #14464: Add VeraCrypt support to GNOME Files)

#9 Updated by sajolida 3 months ago

  • Status changed from Confirmed to In Progress
  • Feature Branch set to doc/14476-veracrypt

I pushed a draft on doc/14476-veracrypt.

It includes the fix for #15051 and disabling automount (#15628) because I'm going to use the ISO based on this branch for the user testing.

#10 Updated by intrigeri 3 months ago

  • Blocked by Feature #15043: Iteration 4: Create VeraCrypt Mounter application added

#11 Updated by sajolida 3 months ago

  • Target version changed from Tails_3.8 to Tails_3.9

#12 Updated by sajolida 3 months ago

  • Assignee changed from sajolida to intrigeri
  • QA Check set to Ready for QA

I'm done writing the documentation. I asked Cody if he wanted to review it but I'd also like either intrigeri or segfault to have a look because you would spot different issues.

#13 Updated by intrigeri 3 months ago

  • Assignee changed from intrigeri to segfault

but I'd also like either intrigeri or segfault to have a look because you would spot different issues.

I'll be happy to take a look but I'd rather do this after segfault has.

#14 Updated by sajolida 2 months ago

  • Assignee changed from segfault to cbrownstein

#15 Updated by sajolida 2 months ago

I reassigned this to Cody so it's more visible to him. Cody, reassign this to me once your done with your review.

#16 Updated by cbrownstein 2 months ago

  • Assignee changed from cbrownstein to sajolida

Please review the changes I've pushed to my branch:

https://0xacab.org/cbrownstein/tails/commits/doc/14476-veracrypt

#17 Updated by segfault about 2 months ago

I finally reviewed this (commit f32a3a93edbe24b3579902b1aed85a238c53e343). It's great work!

My comments:

In the site's navigation bar, there are 7 arrows to the left, each titled "Create and use LUKS encrypted volumes". Opening the url in Tor Browser shows that there is one link for each language (see screenshots).

<tr><td>Encrypted file containers ¹</td><td class="cross">No</td><td class="check">Yes</td></t

File containers can also be created with LUKS. I don't know of anyone who does that, but a quick search turns out there are people who do: https://duckduckgo.com/?q=luks+file+containers

<p>Usually USB sticks and hard disks have a single partition of their
52 entire size but they can also be split into several partitions.

Nitpick: I think usually USB sticks don't have a partition table at all, but are just one single device (i.e. the filesystem is on /dev/sda, not /dev/sda1).

- Hidden volume: if you want to open the hidden volume inside the
<span class="application">VeraCrypt</span> volume.

Did you leave out the "system volume" option here on purpose?

If your partition is on an internal hard disk, refer to [[Unlocking a
partition (or entire disk) with keyfiles|veracrypt#partition-disks]]
instead.

VeraCrypt Mounter also shows partitions of internal drives. Did you encounter any issues with this?

#18 Updated by intrigeri about 2 months ago

Nitpick: I think usually USB sticks don't have a partition table at all, but are just one single device (i.e. the filesystem is on /dev/sda, not /dev/sda1).

Not in my experience (both with new sticks and used ones).

#19 Updated by segfault about 2 months ago

intrigeri wrote:

Nitpick: I think usually USB sticks don't have a partition table at all, but are just one single device (i.e. the filesystem is on /dev/sda, not /dev/sda1).

Not in my experience (both with new sticks and used ones).

Okay, then ignore this. The stick I have here does not have a partition table, but maybe I formatted it this way.

#20 Updated by sajolida about 2 months ago

I finally reviewed this (commit f32a3a93edbe24b3579902b1aed85a238c53e343). It's great work!

Thanks! :)

In the site's navigation bar, there are 7 arrows to the left, each titled "Create and use LUKS encrypted volumes". Opening the url in Tor Browser shows that there is one link for each language (see screenshots).

This is a glitch that sometimes happen on local builds of the website.
It's not specific to this work.

File containers can also be created with LUKS. I don't know of anyone who does that, but a quick search turns out there are people who do: https://duckduckgo.com/?q=luks+file+containers

Good point! So I changed "No / Yes" into "Complicated / Easy" and
pointed to people who do that with LUKS. See 298a73b10d.

- Hidden volume: if you want to open the hidden volume inside the
<span class="application">VeraCrypt</span> volume.

Did you leave out the "system volume" option here on purpose?

Indeed, I added that with bf6bdb4216.

If your partition is on an internal hard disk, refer to [[Unlocking a
partition (or entire disk) with keyfiles|veracrypt#partition-disks]]
instead.

VeraCrypt Mounter also shows partitions of internal drives. Did you encounter any issues with this?

I didn't test that and thought it was impossible. I fixed that in
a9912c9024.

Thanks for the careful review. I could fix 3 important issues!!!

#21 Updated by sajolida about 2 months ago

  • QA Check changed from Ready for QA to Dev Needed

The next step is for me to finish updating the doc to VeraCrypt Mounter. See #15043.

#22 Updated by intrigeri about 1 month ago

I wanted to merge this branch into feature/14481-TCRYPT-support-beta but there's a merge conflict. Can you please fix this?

Also, apparently you've rewritten the history of this branch after it was merged in there already. Please don't do that in the future :)

#23 Updated by intrigeri about 1 month ago

  • Priority changed from Normal to High

(Blocks merging feature/14481-TCRYPT-support-beta into devel.)

#24 Updated by sajolida about 1 month ago

I solved the conflict.

#25 Updated by intrigeri about 1 month ago

  • Feature Branch changed from doc/14476-veracrypt to feature/14481-TCRYPT-support-beta

At this point of the dev/release cycle, I think the cost of working on the doc in a dedicated branch greatly outweights its benefits.

#26 Updated by sajolida about 1 month ago

Ok! To remember that I deleted my dedicated branch both locally and remotely.

#27 Updated by sajolida about 1 month ago

The only work remaining on my doc is to update the screenshot of VeraCrypt Mounter. Given the issues we're having regarding trademark on #15680, I'm not going to work on this before everything is crystal clear between VeraCrypt and us (likely after the freeze).

#28 Updated by sajolida about 1 month ago

  • Assignee changed from sajolida to intrigeri
  • QA Check changed from Dev Needed to Ready for QA

Done now in b617ab98d6 as we'll probably stick with the current state of things as our final solution.

Assigning to intrigeri as the RM for 3.9.

#29 Updated by intrigeri about 1 month ago

  • Status changed from In Progress to Fix committed
  • QA Check changed from Ready for QA to Pass

#30 Updated by intrigeri about 1 month ago

  • Assignee deleted (intrigeri)

#31 Updated by intrigeri 16 days ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF