Project

General

Profile

Feature #14580

Support Video Acceleration API (VA-API)

Added by intrigeri about 1 year ago. Updated 6 months ago.

Status:
In Progress
Priority:
Low
Assignee:
-
Category:
Hardware support
Target version:
Start date:
08/31/2017
Due date:
% Done:

10%

QA Check:
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

va-driver-all pulls in all libraries/drivers needed for Video Acceleration API (VA-API), that provide accelerated video playback and video post-processing for a great number of supported graphics cards. gstreamer1.0-vaapi links them with GStreamer and thus Totem. Installing these packages would improve video playback performance on very common hardware, hence improving UX UX and possibly lowering the amount of (recurring) requests for another video player than Totem. Installing them on Tails 3.1 downloads 2 MiB of packages.

Next step is to verify that VA-API is used (in practice) in Totem with this change applied.


Related issues

Related to Tails - Bug #15433: Cannot open GNOME Settings menu on some computers since Tails 3.6 Resolved 03/21/2018
Blocked by Tails - Bug #15132: devel branch FTBFS since aufs-dkms 4.14 is in sid Resolved 12/29/2017

Associated revisions

Revision de15ff9b (diff)
Added by intrigeri 9 months ago

Install packages needed to support Video Acceleration API (VA-API) (refs: #14580)

Revision 1bee812d
Added by bertagaz 8 months ago

Merge remote-tracking branch 'origin/feature/14580-va-api' into devel

Fix-committed: #14580

History

#1 Updated by intrigeri 9 months ago

  • Target version changed from Tails_3.7 to Tails_3.6

#2 Updated by intrigeri 9 months ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Feature Branch set to feature/14580-va-api

#3 Updated by intrigeri 9 months ago

  • Assignee changed from intrigeri to bertagaz
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA
  • MacBook Pro 8,1 13-inch: reads video with VA-API enabled
  • ThinkPad X200: reads video without VA-API (apparently no driver support)
  • QEMU VM with virtio graphics: reads video without VA-API (apparently no driver support); sluggish, but not more than on Tails 3.3

#4 Updated by intrigeri 9 months ago

  • Blocked by Bug #15132: devel branch FTBFS since aufs-dkms 4.14 is in sid added

#5 Updated by bertagaz 9 months ago

  • Assignee changed from bertagaz to intrigeri
  • QA Check changed from Ready for QA to Info Needed

Did you push that branch? I can not find it in the main repo. Also, how did you test to see if totem is using this driver?

#6 Updated by intrigeri 9 months ago

  • Assignee changed from intrigeri to bertagaz
  • QA Check changed from Info Needed to Ready for QA

Did you push that branch?

Ooops, I forgot. Now I did.

Also, how did you test to see if totem is using this driver?

Yes: #14580#note-3 was a reply to "Next step is to verify that VA-API is used (in practice) in Totem with this change applied", sorry I've not been clear enough!

#7 Updated by bertagaz 8 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (bertagaz)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

intrigeri wrote:

Also, how did you test to see if totem is using this driver?

Yes: #14580#note-3 was a reply to "Next step is to verify that VA-API is used (in practice) in Totem with this change applied", sorry I've not been clear enough!

Maybe I wasn't too, I was asking for the procedure to follow to test if that VA-API thing was used or not while playing a video. Nevermind, I found it myself. Anyway, from my testing it seems to work well on supported harware, and does not seem to break the playing on the other kind of hardwares, so it's now merged, congrats!

#8 Updated by intrigeri 8 months ago

Also, how did you test to see if totem is using this driver?

Yes: #14580#note-3 was a reply to "Next step is to verify that VA-API is used (in practice) in Totem with this change applied", sorry I've not been clear enough!

Maybe I wasn't too, I was asking for the procedure to follow to test if that VA-API thing was used or not while playing a video.

Oops, I had missed the "how" word in your question, which explains my stupid reply.

#9 Updated by bertagaz 6 months ago

  • Status changed from Fix committed to Resolved

#10 Updated by intrigeri 6 months ago

  • Related to Bug #15433: Cannot open GNOME Settings menu on some computers since Tails 3.6 added

#11 Updated by intrigeri 6 months ago

  • Status changed from Resolved to In Progress
  • Target version changed from Tails_3.6 to Tails_4.0
  • % Done changed from 100 to 10
  • QA Check deleted (Pass)
  • Feature Branch deleted (feature/14580-va-api)

This broke some things on some hardware (#15433). Let's give it another try around 4.0~betaN, when lots of people will test our stuff and then hopefully someone will notice before a final release if we regress.

Also available in: Atom PDF