Project

General

Profile

Feature #14595

Feature #14568: Additional Software Packages

Feature #14594: Code & integration into Tails: Additional Software Packages GUI

Code for Additional Software Packages GUI: Persistence Setup

Added by u 11 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Persistence
Target version:
Start date:
12/11/2013
Due date:
% Done:

100%

QA Check:
Feature Branch:
perl5lib:feature/14594-asp-gui, iuk:feature/14594-asp-gui, persistence-setup:feature/14594-asp-gui, feature/14594-asp-gui
Type of work:
Code
Starter:
Affected tool:
Additional Software Packages

Description

Perl code & consulting for the GUI. (B4)
Preliminary release date for the BETA: April 15th 2018.

The order of priority between these tasks is:

  1. implement the API needed by tails-additional-software apt-post so that Alan can keep working on his side:
    1. create persistent volume with ASP enabled
    2. enable ASP
    3. display config
    4. return 0 iff. success
  2. fix graphics bug: rectangle filled with black where the list of settings was, after configuring persistence, in the "Finished" window
  3. #15259: Add button in tails-persistence-setup to open the configuration interface of Additional Software
  4. #6485: Support multiple persistent paths per preset in the persistent volume assistant
  5. #15314: Replace custom widget button in persistent wizard with standard GNOME switches
  6. #15280: Reorder persistence features
  7. #15313: Apply changes to persistent features without the need for a Save button

Subtasks

Feature #6485: Support multiple persistent paths per preset in the persistent volume assistantResolvedintrigeri

Feature #15259: Add button in tails-persistence-setup to open the configuration interface of Additional SoftwareResolvedintrigeri

Bug #15275: Remove the GNOME Keyring persistent featureResolved

Feature #15280: Reorder persistence featuresResolvedintrigeri

Feature #15314: Replace custom widget button in persistent wizard with standard GNOME switchesResolvedintrigeri

Feature #15544: Use title capitalization consistently in persistence configurationResolved

Bug #15550: Attempting to delete an unlocked persistent volume does not tell the user anything usefulResolved


Related issues

Related to Tails - Bug #15378: Re-enable USE_LAST_RELEASE_AS_OLD_ISO on Jenkins after Tails 3.9 is released Confirmed 03/05/2018
Blocked by Tails - Feature #14574: Design GUI for Additional Software packages Resolved 01/29/2018

Associated revisions

Revision f720cdbb (diff)
Added by intrigeri 5 months ago

Import current tails-persistence-setup and tails-perl5lib for ASP GUI (refs: #14595)

- tails-perl5lib:feature/14594-asp-gui at commit
5c40ec86a62579573e3ec28e9c651ee1d649295e
- tails-persistence-setup:feature/14594-asp-gui at commit
07378a2ba5ed1821f8788adc50937aa14c1fdd67

Revision ff95e1de (diff)
Added by intrigeri 5 months ago

Import tails-perl5lib for ASP GUI at commit 9f0f2aee07bd407bb58b2819936ec539b8a84879 (refs: #14595)

Revision cde36bcc (diff)
Added by intrigeri 5 months ago

Import tails-persistence-setup at commit 7e2829fb5dae16c695098a17c930ac97571b2bb3 (refs: #14595)

Revision 3ba1893b (diff)
Added by intrigeri 4 months ago

Fix build failure by breaking cyclic dependency (refs: #14595)

This reverts commit e0b24a215182fe386ce2940639b115039cdfadaa
and ensures we remove python3-setuptools later on.

Otherwise there's a cyclic dependency situation: to install tailslib in
config/chroot_local-hooks/00-install-tailslib we need to install
python3-setuptools, which triggers the APT hook for ASP, which depends on
tailslib to be available already.

Revision 28932e34 (diff)
Added by alant 3 months ago

ASP: import LIVE_USERNAME from tailslib

Refs: #14595

Revision a627b4c3 (diff)
Added by alant 3 months ago

ASP: ensure safer access rights for ASP configuration

Refs: #14595

History

#2 Updated by u 11 months ago

  • Related to Feature #14594: Code & integration into Tails: Additional Software Packages GUI added

#3 Updated by u 11 months ago

  • Target version set to Tails_3.7
  • Parent task set to #14568

#4 Updated by intrigeri 10 months ago

  • Related to deleted (Feature #14594: Code & integration into Tails: Additional Software Packages GUI)

#5 Updated by intrigeri 10 months ago

  • Subject changed from Code for Additional Software Packages GUI to Code for Additional Software Packages GUI: Persistence Setup
  • Parent task changed from #14568 to #14594

#6 Updated by intrigeri 10 months ago

  • Blocked by Feature #14574: Design GUI for Additional Software packages added

#7 Updated by u 6 months ago

  • Related to Feature #5386: Persistence: fix aufs related io error added

#8 Updated by sajolida 6 months ago

  • Related to Feature #6485: Support multiple persistent paths per preset in the persistent volume assistant added

#9 Updated by alant 6 months ago

  • Blueprint set to https://tails.boum.org/blueprint/additional_software_packages/gui#index6h2

#10 Updated by sajolida 5 months ago

  • Description updated (diff)

#11 Updated by intrigeri 5 months ago

  • Description updated (diff)

Added as the top priority the main task that was part of this ticket when we designed this project (and that justified the time budget I requested): it won't magically happen for free :)

#12 Updated by intrigeri 5 months ago

  • Assignee changed from intrigeri to sajolida
  • QA Check set to Info Needed
  • Affected tool deleted (Additional Software Packages)

intrigeri wrote:

Added as the top priority the main task that was part of this ticket when we designed this project (and that justified the time budget I requested): it won't magically happen for free :)

Actually I don't know how you rank #6485 since you did not put it on the list, it has no "Deliverable for" and it's not marked as a blocker of this ticket. I'll start working on this ticket tomorrow so it's kinda urgent that you tell me. In doubt, if I don't get an answer by then, I'll start working on #15259 which is a must anyway.

#13 Updated by intrigeri 5 months ago

  • Related to deleted (Feature #5386: Persistence: fix aufs related io error)

#14 Updated by sajolida 5 months ago

  • Description updated (diff)
  • Assignee changed from sajolida to intrigeri
  • QA Check deleted (Info Needed)

Adding #6485 to the dance: We need this to display only one feature "Additional Software" and remove "APT Packages" and "APT Lists".

#15 Updated by intrigeri 5 months ago

  • Description updated (diff)

#16 Updated by intrigeri 5 months ago

  • Feature Branch set to persistence-setup:feature/14594-asp-gui, feature/14594-asp-gui

#17 Updated by intrigeri 5 months ago

  • Feature Branch changed from persistence-setup:feature/14594-asp-gui, feature/14594-asp-gui to perl5lib:feature/14594-asp-gui, persistence-setup:feature/14594-asp-gui, feature/14594-asp-gui

#18 Updated by intrigeri 5 months ago

  • Description updated (diff)

#19 Updated by intrigeri 5 months ago

  • Status changed from Confirmed to In Progress

#20 Updated by intrigeri 5 months ago

  • Category set to Persistence
  • Affected tool set to Additional Software Packages

#21 Updated by intrigeri 5 months ago

  • Related to Bug #15378: Re-enable USE_LAST_RELEASE_AS_OLD_ISO on Jenkins after Tails 3.9 is released added

#22 Updated by intrigeri 5 months ago

  • Blocked by Feature #15379: Adjust test suite to Python tails-upgrade-frontend-wrapper added

#23 Updated by intrigeri 5 months ago

  • Feature Branch changed from perl5lib:feature/14594-asp-gui, persistence-setup:feature/14594-asp-gui, feature/14594-asp-gui to perl5lib:feature/14594-asp-gui, iuk:feature/14594-asp-gui, persistence-setup:feature/14594-asp-gui, feature/14594-asp-gui

#24 Updated by intrigeri 5 months ago

  • Description updated (diff)

#25 Updated by intrigeri 5 months ago

  • Description updated (diff)

#26 Updated by intrigeri 5 months ago

  • Description updated (diff)

#27 Updated by intrigeri 5 months ago

  • Description updated (diff)

#28 Updated by intrigeri 4 months ago

Status update:

  • Everything I had to do is done including all SHOULD items and all-but-one MAY items:
    • See the ticket description and subtasks for details.
    • As expected, the bonus #15313 won't fit into my time budget; it's way outside of the scope of what I've committed to do on this project anyway so no big deal.
    • Until I'm told what else I should do or fix (e.g. when my team-mates work on automated tests, code review, documentation and UX testing) I'll put this project on the back burner: mission^Witeration accomplished!
    • Alan will consult me regarding the design on a security boundary for the Additional Software config GUI.
  • Everything seems to work well when tested manually. I'm running the full automated test suite to ensure I did not introduce regressions elsewhere. We'll know more once automated tests specific to the new features are written.
  • I've notified segfault that he can start his code review (#14598).

#29 Updated by intrigeri 4 months ago

  • Blocks Bug #15275: Remove the GNOME Keyring persistent feature added

#30 Updated by intrigeri 4 months ago

intrigeri wrote:

I'm running the full automated test suite to ensure I did not introduce regressions elsewhere.

Done and the results look good: no unexpected failure in areas impacted by this branch :)

#31 Updated by intrigeri 4 months ago

  • Blocks deleted (Bug #15275: Remove the GNOME Keyring persistent feature)

#32 Updated by intrigeri 3 months ago

  • Blocked by deleted (Feature #15379: Adjust test suite to Python tails-upgrade-frontend-wrapper)

#33 Updated by intrigeri 3 months ago

  • Status changed from In Progress to Resolved

Given all the requested work was done + we have other tickets for the code review and follow-up fixes after user testing, I don't see any point in keeping this ticket open and I think we can call this completed in our next report to the sponsor.

Also available in: Atom PDF