Project

General

Profile

Bug #14599

Feature #14568: Additional Software Packages

Release BETA for Additional Software feature/GUI

Added by u 11 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
Due date:
04/15/2018
% Done:

100%

QA Check:
Dev Needed
Feature Branch:
Type of work:
Communicate
Blueprint:
Starter:
Affected tool:
Additional Software Packages

Description

On April 15th 2018, shortly before Tails 3.7
This ticket is here just to keep track of the BETA release.
The BETA won't be an official release, just a nightly or a branch.

Ensure there's a nightly built ISO that works well enough for writing doc & user testing. Once we have the doc drafted we can call for testing on testers@+Twitter & point to the draft doc.


Related issues

Blocks Tails - Feature #14589: Write user documentation for Additional Software feature In Progress 09/04/2017 05/01/2018

History

#1 Updated by sajolida 11 months ago

  • Due date set to 04/15/2018
  • Target version set to Tails_3.7
  • Start date deleted (09/04/2017)

#2 Updated by u 11 months ago

  • Description updated (diff)

#3 Updated by u 11 months ago

  • Due date changed from 04/15/2018 to 05/01/2018

#4 Updated by sajolida 10 months ago

On May 1st 2018 = Tails 3.6.

Maybe it's not clear what we meant by "BETA" when preparing the
proposal. The idea is to have the code ready to use in a nightly build
but not in an official release. We would send a call for testing of this
unofficial version and also use it to prepare the doc and do the user tests.

So the calendar of this beta doesn't have to be linked with the calendar
of our official release. Because the code for the BETA won't be in an
official release.

Actually, in terms of activity on the blog, rush hours on help desk,
etc. it might even be slightly better to publish our BETA during quiet
times between our official releases (like some weeks before a major
release).

That's why I initially proposed April 15 and not May 1.

#5 Updated by u 10 months ago

  • Description updated (diff)
  • Due date changed from 05/01/2018 to 04/15/2018

Thanks for making it clear.

#6 Updated by intrigeri 10 months ago

  • Blocks Feature #14591: Conduct User Testing of Additional Software packages GUI added

#7 Updated by u 5 months ago

  • Description updated (diff)

#8 Updated by u 5 months ago

  • Assignee changed from u to alant

link to https://nightly.tails.boum.org/build_Tails_ISO_feature-14594-asp-gui/lastSuccessful/archive/build-artifacts/ and write some testing instructions. Send test request to sajolida & testers. review: u.

#9 Updated by u 5 months ago

  • Description updated (diff)

#10 Updated by u 5 months ago

  • Blocks Feature #14589: Write user documentation for Additional Software feature added

#11 Updated by u 5 months ago

  • Assignee changed from alant to u

I'll do it and ask alan about details and when the nightly is ready to be tested.

#13 Updated by sajolida 2 months ago

  • Blocks deleted (Feature #14591: Conduct User Testing of Additional Software packages GUI)

#14 Updated by sajolida 2 months ago

Just in case there's a confusion: I think that u can put out the public beta any time now.

u: You'll have to send the URL of the ISO that you want to publish to intrigeri so he adds it to the rsync mirror.

#15 Updated by u 2 months ago

  • Assignee changed from u to intrigeri
  • QA Check set to Dev Needed

Hello intrigeri: can you please add this (https://nightly.tails.boum.org/build_Tails_ISO_feature-14594-asp-gui/builds/173/archive/build-artifacts/tails-amd64-feature_14594-asp-gui-3.9-20180502T2054Z-7eb6633424+devel@886427ce28.iso) ISO image to the rsync mirror as ASP Beta? Please reassign to me with the URL once this is done.

Will write & send a call for testing.

#16 Updated by intrigeri 2 months ago

  • Target version changed from Tails_3.7 to Tails_3.8

#17 Updated by intrigeri 2 months ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to u
  • % Done changed from 0 to 10

u wrote:

Hello intrigeri: can you please add this (https://nightly.tails.boum.org/build_Tails_ISO_feature-14594-asp-gui/builds/173/archive/build-artifacts/tails-amd64-feature_14594-asp-gui-3.9-20180502T2054Z-7eb6633424+devel@886427ce28.iso) ISO image to the rsync mirror as ASP Beta? Please reassign to me with the URL once this is done.

Done! It should appear on http://dl.amnesia.boum.org/tails/alpha/ within 2 hours or so, once the mirror network has been updated.

#18 Updated by u 2 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 10 to 100

Sent to testers, published here https://tails.boum.org/news/test_asp-beta/index.en.html and on Twitter. I consider this done.

Also available in: Atom PDF