Project

General

Profile

Feature #14611

Evaluate the global --old-iso kill switch for the test suite on Jenkins

Added by intrigeri 10 months ago. Updated 17 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Continuous Integration
Target version:
Start date:
09/07/2017
Due date:
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Discuss
Blueprint:
Starter:
Affected tool:

Description

9 months after #14609 and #14610 are done, look back, evaluate if it's good enough or if we need something more involved (e.g. a per-branch kill switched encoded in the branch itself).

The thing to look for is USE_LAST_RELEASE_AS_OLD_ISO in jenkins-jobs.git.


Related issues

Blocked by Tails - Bug #14609: Move the --old-iso kill switch from puppet-tails.git to jenkins-jobs.git Resolved 09/07/2017
Blocked by Tails - Feature #14610: Give anonym read-write access to jenkins-jobs.git Resolved 09/07/2017

History

#1 Updated by intrigeri 10 months ago

  • Blocked by Bug #14609: Move the --old-iso kill switch from puppet-tails.git to jenkins-jobs.git added

#2 Updated by intrigeri 10 months ago

  • Blocked by Feature #14610: Give anonym read-write access to jenkins-jobs.git added

#3 Updated by intrigeri 17 days ago

  • Description updated (diff)

#4 Updated by intrigeri 17 days ago

  • Status changed from Confirmed to Resolved
  • Target version changed from Tails_3.9 to Tails_3.8
  • % Done changed from 0 to 100

It's been used twice only and I don't recall cases when it hurt us to disable this globally, which suggests our current system is good enough and anything more complex would be overkill given our practical needs.

We don't have CI team meetings anymore and some of my infrastructure work is waiting for review by my team mates since 5-10 months, so I'll skip the discussion and review part. If anyone thinks differently, feel free to reopen and explain why :)

Also available in: Atom PDF