Project

General

Profile

Bug #14650

Package new upstream version of tails-installer -> bpo

Added by u about 1 year ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
09/13/2017
Due date:
% Done:

80%

QA Check:
Feature Branch:
Type of work:
Debian
Blueprint:
Starter:
Affected tool:
Installer

Description

and upload to Debian & Ubuntu


Related issues

Related to Tails - Bug #15533: Clarify the status of Tails Installer for Jessie Resolved 04/14/2018
Related to Tails - Bug #15183: Prepare tails-installer release for Ubuntu Bionic Beaver Resolved 01/17/2018
Blocked by Tails - Feature #8859: Get rid of the splash screen of Tails Installer Resolved 02/04/2015
Blocks Tails - Bug #14646: Core work 2018Q1 → 2018Q2: Debian Resolved 01/17/2018
Blocks Tails - Feature #14677: Update doc to new Tails Installer without splash screen (in Debian) Resolved 09/17/2017

History

#1 Updated by u about 1 year ago

  • Subject changed from tails-installer to Package new upstream version of tails-installer
  • Description updated (diff)

#2 Updated by u about 1 year ago

  • Blocked by Feature #8859: Get rid of the splash screen of Tails Installer added

#3 Updated by u about 1 year ago

  • Target version set to Tails_3.3

#4 Updated by sajolida about 1 year ago

  • Blocked by Feature #14677: Update doc to new Tails Installer without splash screen (in Debian) added

#5 Updated by sajolida about 1 year ago

  • QA Check set to Info Needed

Would it make sense for you to specify the version number in the title of such tickets?

I guess you are referring here to Tails Installer 4.4.19 which solves #8859.

Then I'd like to coordinate with you so that the documentation is updated at the same time as the new package lands in Debian and Ubuntu (+/- 1/2 days). For that to work, would it be possible for you to send me the new package so I can test it in Debian and update the documentation accordingly? And then only push it to Debian and merge my doc?

#6 Updated by intrigeri about 1 year ago

I guess you are referring here to Tails Installer 4.4.19 which solves #8859.

Hold on by the way, 4.4.19 is not ready to go into Debian as-is.

#7 Updated by intrigeri about 1 year ago

For that to work, would it be possible for you to send me the new package so I can test it in Debian

You could fetch it from our custom APT repo already :)

#8 Updated by u about 1 year ago

sajolida wrote:

Would it make sense for you to specify the version number in the title of such tickets?

Maybe sometimes but in this particular case I did not look it up yet and will do so only once the ticket is done.

Then I'd like to coordinate with you so that the documentation is updated at the same time as the new package lands in Debian and Ubuntu (+/- 1/2 days). For that to work, would it be possible for you to send me the new package so I can test it in Debian and update the documentation accordingly? And then only push it to Debian and merge my doc?

As migrating from Debian unstable -> testing & backports takes at least five days, I don't think it's necessary that I wait for you before pushing.

#9 Updated by u about 1 year ago

  • QA Check deleted (Info Needed)

#10 Updated by intrigeri about 1 year ago

  • Parent task deleted (#14646)

#11 Updated by intrigeri about 1 year ago

  • Blocks Bug #14646: Core work 2018Q1 → 2018Q2: Debian added

#12 Updated by anonym 11 months ago

  • Target version changed from Tails_3.3 to Tails_3.5

#13 Updated by u 10 months ago

  • Status changed from Confirmed to Fix committed
  • % Done changed from 0 to 100

Uploaded to Debian.

#14 Updated by u 10 months ago

And all relevant Ubuntu releases, i.e. LTS 16.04 XenialXerus, 17.04 ZestyZapus and 17.10 ArtfulAardvark. People using non LTS versions of Ubuntu, like Yakkety cannot profit from the package as Ubuntu restricts updating packages for these releases.

#15 Updated by intrigeri 9 months ago

  • Status changed from Fix committed to In Progress
  • % Done changed from 100 to 80
  • Affected tool set to Installer

The package is not in stretch-backports yet (IIRC it was rejected once because it was uploaded before the corresponding version migrated to testing, and a second time because of some "already seen signature" handling or similar protection against upload replay) so I think this ticket should not be "Fix committed" yet.

#16 Updated by u 8 months ago

  • Target version changed from Tails_3.5 to Tails_3.6

Still missing the backport, I have to rebuild it.

#17 Updated by u 8 months ago

  • Blocked by deleted (Feature #14677: Update doc to new Tails Installer without splash screen (in Debian))

#18 Updated by u 8 months ago

  • Related to Feature #14677: Update doc to new Tails Installer without splash screen (in Debian) added

#19 Updated by u 8 months ago

  • Subject changed from Package new upstream version of tails-installer to Package new upstream version of tails-installer -> bpo

#20 Updated by sajolida 7 months ago

  • Related to deleted (Feature #14677: Update doc to new Tails Installer without splash screen (in Debian))

#21 Updated by sajolida 7 months ago

  • Blocks Feature #14677: Update doc to new Tails Installer without splash screen (in Debian) added

#22 Updated by intrigeri 7 months ago

Our end-user doc says we support Tails Installer on Jessie as well but we haven't uploaded a new installer there for 2 years. I don't think we can upload a new package to jessie-backports since it's not in Stretch, so that would have to go into jessie-sloppy-backports I think. But that will require an update of our installation assistant. Unless… perhaps it's time to drop support for Jessie?

#23 Updated by bertagaz 7 months ago

  • Target version changed from Tails_3.6 to Tails_3.7

#24 Updated by u 6 months ago

Uploaded new version to unstable today. Will prepare backport next week + Ubuntu PPA versions and version for Ubuntu Bionic.

#25 Updated by intrigeri 6 months ago

  • Related to Bug #15533: Clarify the status of Tails Installer for Jessie added

#26 Updated by intrigeri 6 months ago

intrigeri wrote:

Our end-user doc says we support Tails Installer on Jessie as well but we haven't uploaded a new installer there for 2 years. I don't think we can upload a new package to jessie-backports since it's not in Stretch, so that would have to go into jessie-sloppy-backports I think. But that will require an update of our installation assistant. Unless… perhaps it's time to drop support for Jessie?

I think it's too confusing to handle this problem on this ticket and there's no reason it blocks the upload to stretch-backports, so I've filed a dedicated ticket: #15533.

#27 Updated by u 5 months ago

  • Related to Bug #15183: Prepare tails-installer release for Ubuntu Bionic Beaver added

#28 Updated by u 5 months ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF