Project

General

Profile

Feature #14683

Write release notes for 3.9

Added by sajolida about 1 year ago. Updated 16 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
05/02/2018
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
web/14683-3.9-release-notes
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Subtasks

Feature #15561: Prepare snippet about ASP for the Tails 3.9 release notesResolved


Related issues

Blocks Tails - Feature #15411: Core work 2018Q2 → 2018Q3: Technical writing Confirmed 03/14/2018

Associated revisions

Revision 63ff10cf (diff)
Added by intrigeri 17 days ago

Fix Debian Buster version number (refs: #14683).

Revision 85fd0924 (diff)
Added by intrigeri 17 days ago

Drop erroneous claim (refs: #14683).

I'd love to tell that but that's not what I've measured in Tails.

Revision bb06f9a2 (diff)
Added by intrigeri 17 days ago

Fix tor version (refs: #14683).

Revision da87f4dd (diff)
Added by intrigeri 17 days ago

Drop obsolete claim (refs: #14683).

We had to revert the NVIDIA-specific changes that caused more trouble than good.

History

#1 Updated by u 8 months ago

  • Priority changed from Elevated to Normal

#2 Updated by sajolida 8 months ago

  • Target version changed from Tails_3.10 to Tails_3.9

#3 Updated by intrigeri about 1 month ago

FYI no big user-visible changes are planned for 3.9 on top of what we have in 3.9~rc1 already. However, the versions for Tor Browser, Thunderbird and Linux will change.

#4 Updated by intrigeri about 1 month ago

  • Blocks Feature #15411: Core work 2018Q2 → 2018Q3: Technical writing added

#5 Updated by sajolida 19 days ago

  • Assignee changed from sajolida to intrigeri
  • QA Check set to Ready for QA

#6 Updated by sajolida 19 days ago

  • Feature Branch set to web/14683-3.9-release-notes

#7 Updated by intrigeri 19 days ago

Thanks a lot!

#8 Updated by intrigeri 17 days ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to sajolida
  • QA Check changed from Ready for QA to Dev Needed

I've prepared the changelog on the testing branch => please make another pass :)

#9 Updated by intrigeri 17 days ago

I took a quick look and merged the current state into web/release-3.9 (which you can now push your stuff directly to until the 3.9 release):

  • wiki/src/doc/encryption_and_privacy/veracrypt/unlock-veracrypt-volumes-with-partition.png is outdated (#15849)
  • pushed a few fixes to web/release-3.9, please merge that branch before working on this further
  • I think #15796 would be worth mentioning to avoid giving the impression that we don't care about such things (I know that was not merged yet when you wrote the initial draft :)
  • I'm surprised that the revamp of the interface of "Configure Persistent Volume" is not mentioned since it was deemed to be a UX blocker for our ASP work. Now, I can get priorities and all, just mentioning this in case that's an oversight.
  • FWIW automatic upgrades are also available from 3.9~rc1

#10 Updated by sajolida 17 days ago

  • Assignee changed from sajolida to intrigeri
  • QA Check changed from Dev Needed to Ready for QA

Thanks for the detailed review! I did all that in web/release-3.9 and pushed.

I think I missed mentioning the updated persistent storage configuration (though I didn't mention the changes to WhisperBack on purpose). I added them now, with a screenshot and all :)

#11 Updated by intrigeri 16 days ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

Note that somehow you've pushed commit b74eda32cae217b88b0f8af0a83d4129250d87b4 to web/release-3.9. That's a mistake, we don't want that branch to be based on devel but on testing.

Fixed that + one typo. We're done here, great!

#12 Updated by intrigeri 16 days ago

  • Status changed from In Progress to Fix committed

#13 Updated by intrigeri 16 days ago

  • Status changed from Fix committed to In Progress

#14 Updated by intrigeri 16 days ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF