Project

General

Profile

Bug #14689

Document Cherry Trails Atom computers issues in the Known Issues List

Added by goupille 3 months ago. Updated about 1 month ago.

Status:
Confirmed
Priority:
Normal
Assignee:
Category:
Hardware support
Target version:
Start date:
09/19/2017
Due date:
% Done:

90%

QA Check:
Dev Needed
Feature Branch:
doc/14689-cherry-trail-tablet
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

Even if installing Tails on a Cherry Trails Atom computer (like Asus Vivostick TS10) works, some of the hardware is still not supported by any linux distribution so it is expected that the sound and the wireless does not work. The easiest workaround seems to use USB dongles.

cheers.


Related issues

Related to Tails - Feature #14709: Remove known issue about Atom Cherry Trail Confirmed 09/23/2017
Blocks Tails - Feature #14758: Core work 2017Q4: Technical writing Confirmed 10/02/2017

Associated revisions

Revision b89140ec (diff)
Added by sajolida 3 months ago

Document limitation on Intel Atom Cherry Trail tablets (Will-fix: #14689)

History

#1 Updated by sajolida 3 months ago

  • Category set to Hardware support
  • Target version set to Tails_3.2

#2 Updated by sajolida 3 months ago

  • Assignee changed from sajolida to intrigeri
  • QA Check set to Ready for QA
  • Feature Branch set to doc/14689-cherry-trail-tablet

Here is a branch. Reassigning to the Foundations team so they can check that I'm not saying silly things (trying to learn what this 'Cherry Trail' is all about...).

#3 Updated by sajolida 3 months ago

#4 Updated by sajolida 3 months ago

  • Status changed from Confirmed to In Progress

#5 Updated by intrigeri 3 months ago

  • Assignee changed from intrigeri to sajolida
  • % Done changed from 0 to 90
  • QA Check changed from Ready for QA to Pass

I've tried to understand if the Cherry Trail SoC includes its own sound and Wi-Fi controllers (otherwise, support depends on what sound/Wi-Fi hardware the computer vendor has added). At least it seems to embed a sound controller, for which we're shipping the firmware in Tails 3.1. Wrt. kernel drivers I see lots of improvements in Cherry Trail support are coming in Linux 4.13 and 4.14, which we'll likely ship in our January 2018 release. So the proposed doc seems OK, but it will probably be quickly outdated => perhaps file a ticket to update it in time for our January release, depending on what kernel version we ship? Ideally we would have a contact address of someone who can test then and confirm that stuff improves.

With this in mind, feel free to merge :)

#6 Updated by sajolida 3 months ago

  • Related to Feature #14709: Remove known issue about Atom Cherry Trail added

#7 Updated by sajolida 3 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Pass)

Created #14709 and merged.

NB: I also didn't know about whether the chip included its own sound and Wi-Fi controllers but thought that this should have been investigated before handing this to me (so I didn't look that hard). I searched online to understand what this "Cherry Trail" was all about because the initial formulation sounded very obscure to me but I didn't verify the technical correctness of the initial claim.

#8 Updated by intrigeri 3 months ago

NB: I also didn't know about whether the chip included its own sound and Wi-Fi
controllers but thought that this should have been investigated before handing this
to me (so I didn't look that hard). I searched online to understand what this "Cherry
Trail" was all about because the initial formulation sounded very obscure to me but
I didn't verify the technical correctness of the initial claim.

OK. Looks like the new process was not used here (i.e. such things should go through Foundations Team instead of being assigned to you directly). I don't think it's been really announced / documented yet so no big surprise :)

#9 Updated by goupille 2 months ago

  • Status changed from Resolved to Confirmed
  • Assignee set to sajolida
  • Target version changed from Tails_3.2 to Tails_3.3

sorry for the assigning mess...

I just saw that the known-issues entry is talking about "tablets", however I specificaly used the word computer, since some of the hardware equiped with cherry trails (like the Asus Vivostick TS10) are a kind of pocket-size PC that you plug in the hdmi port of a TV (http://store.asus.com/us/item/201604AM200000016/ASUS+VivoStick+TS10-B017D+Intel+Atom+2GB+32GB+eMMC+Stick+PC).

since this kind of computers are also affected I feel this should be corrected, so I reopen this ticket

#10 Updated by sajolida 2 months ago

  • QA Check set to Dev Needed

I didn't know that, thanks!

#11 Updated by sajolida 2 months ago

  • Blocks deleted (Feature #13423: Core work 2017Q3: Technical writing)

#12 Updated by sajolida 2 months ago

#13 Updated by sajolida about 1 month ago

  • Target version changed from Tails_3.3 to Tails_3.5

Also available in: Atom PDF