Project

General

Profile

Feature #14721

Feature #9005: Improve Tails Installer UX: phase 1

Tails Installer's on_radio_changed method is much less generic than its name suggests

Added by anonym 3 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
Start date:
09/25/2017
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
tails:bugfix/14755-installer-consistent-drive-plugging-state
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Installer

Description

From #8860#note-40:

The on_radio_changed method is much less generic than its name suggests. Let's give it a name that matches better what it does.

Associated revisions

Revision 1b276dbc (diff)
Added by anonym about 1 month ago

Enable APT overlay installing a Tails Installer 5.0.2.

Note that I also remove an APT overlay because it contains a now
obsolete Tails Installer (5.0.2 has the fix for #14809).

Will-fix: #14721, #14722, #14723, #14755

Revision ddc95fba
Added by intrigeri about 1 month ago

Merge branch 'bugfix/14755-installer-consistent-drive-plugging-state' into stable (Fix-committed: #14755, #14721, #14722, #14723)

History

#1 Updated by kurono 3 months ago

  • QA Check set to Ready for QA
  • Feature Branch set to feature/9005-Improve-tails-installer

I will start with this one that is easier.

#2 Updated by intrigeri about 1 month ago

  • Assignee changed from anonym to intrigeri

#3 Updated by intrigeri about 1 month ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 50
  • QA Check changed from Ready for QA to Pass

Looks good to me. I'll see once I've reviewed the rest of this branch what's the next step.

#4 Updated by intrigeri about 1 month ago

  • Assignee changed from intrigeri to anonym

#5 Updated by anonym about 1 month ago

  • Assignee changed from anonym to intrigeri
  • QA Check changed from Pass to Ready for QA
  • Feature Branch changed from feature/9005-Improve-tails-installer to tails:bugfix/14755-installer-consistent-drive-plugging-state

See #14755?#note-17.

#6 Updated by intrigeri about 1 month ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 50 to 100

#7 Updated by intrigeri about 1 month ago

  • QA Check changed from Ready for QA to Pass

#8 Updated by intrigeri about 1 month ago

  • Assignee deleted (intrigeri)

#9 Updated by anonym about 1 month ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF