Project

General

Profile

Bug #14722

Feature #9005: Improve Tails Installer UX: phase 1

Tails Installer's is_ISO_selected method is not a predicate

Added by anonym about 2 months ago. Updated 4 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
Start date:
09/25/2017
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
tails:bugfix/14755-installer-consistent-drive-plugging-state
Type of work:
Code
Blueprint:
Easy:
Affected tool:
Installer

Description

From #8860#note-40:

The is_ISO_selected name suggests it's a simple predicate but this method 1. checks if we need an ISO in the first place (which the name doesn't convey); 2. has side effects (while a predicate must not). I think some refactoring is in order. From a caller's PoV I would do:

if self.need_ISO() and not self.is_ISO_selected():
    self.warn_ISO_not_selected()

… i.e. two predicates and a third method that does the side-effect.

Associated revisions

Revision 1b276dbc (diff)
Added by anonym 9 days ago

Enable APT overlay installing a Tails Installer 5.0.2.

Note that I also remove an APT overlay because it contains a now
obsolete Tails Installer (5.0.2 has the fix for #14809).

Will-fix: #14721, #14722, #14723, #14755

Revision ddc95fba
Added by intrigeri 8 days ago

Merge branch 'bugfix/14755-installer-consistent-drive-plugging-state' into stable (Fix-committed: #14755, #14721, #14722, #14723)

History

#1 Updated by intrigeri about 2 months ago

  • Tracker changed from Feature to Bug
  • Subject changed from Tails Installer's is_ISO_elected method is not a predicate to Tails Installer's is_ISO_selected method is not a predicate

#2 Updated by kurono about 2 months ago

  • QA Check set to Ready for QA
  • Feature Branch set to feature/9005-Improve-tails-installer

#3 Updated by intrigeri 13 days ago

  • Assignee changed from anonym to intrigeri

#4 Updated by intrigeri 11 days ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 50
  • QA Check changed from Ready for QA to Pass

Looks good to me. I'll see once I've reviewed the rest of this branch what's the next step.

#5 Updated by intrigeri 9 days ago

  • Assignee changed from intrigeri to anonym

#6 Updated by anonym 9 days ago

  • Assignee changed from anonym to intrigeri
  • QA Check changed from Pass to Ready for QA
  • Feature Branch changed from feature/9005-Improve-tails-installer to tails:bugfix/14755-installer-consistent-drive-plugging-state

See #14755?#note-17.

#7 Updated by intrigeri 8 days ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 50 to 100

#8 Updated by intrigeri 8 days ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

#9 Updated by anonym 4 days ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF