Project

General

Profile

Feature #14756

Feature #5630: Reproducible builds

Drop update-ca-certificates.service

Added by intrigeri 11 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
10/02/2017
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
bugfix/14756-drop-obsolete-update-ca-certificates
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

It seems the reason why we did that is obsolete, see dbc479a8022142318efbe7c7fe47caacc7db5fc0.

Associated revisions

Revision 311845d2 (diff)
Added by intrigeri 8 months ago

Drop our custom update-ca-certificates.service (refs: #14756)

It was meant to re-create /etc/ssl/certs/java/cacerts at boot time since we used
to remove it at build time to make the build deterministic. We don't ship
ca-certificates-java anymore, so we don't delete /etc/ssl/certs/java/cacerts
anymore, so we don't need to re-create it.

Revision a92e406e
Added by bertagaz 7 months ago

Merge remote-tracking branch 'origin/bugfix/14756-drop-obsolete-update-ca-certificates' into devel

Fix-committed: #14756

History

#1 Updated by intrigeri 11 months ago

Next step: drop that service and see if it breaks anything.

#2 Updated by intrigeri 8 months ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/14756-drop-obsolete-update-ca-certificates

#3 Updated by intrigeri 8 months ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA

Only unrelated failures on Jenkins.

#4 Updated by intrigeri 8 months ago

  • Assignee changed from anonym to bertagaz

#5 Updated by bertagaz 7 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (bertagaz)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

intrigeri wrote:

Only unrelated failures on Jenkins.

Seems to build and passes a full test suite run. Change makes sense, so it's now merged in devel, congrats!

#6 Updated by bertagaz 5 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF