Project

General

Profile

Feature #14768

Feature #14540: Survey platform

Estimate cost of sysadmin work for a 1-time use survey platform

Added by intrigeri 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
10/03/2017
Due date:
% Done:

50%

QA Check:
Feature Branch:
Type of work:
Sysadmin

Description

This is about the "Report on survey platforms" thread on -sysadmins@.

History

#2 Updated by intrigeri 2 months ago

  • Assignee changed from intrigeri to sajolida
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA

Proposed something, see the email thread.

#3 Updated by intrigeri 2 months ago

  • Status changed from Confirmed to In Progress

#4 Updated by sajolida 2 months ago

  • Assignee changed from sajolida to intrigeri
  • Feature Branch set to https://tails.boum.org/blueprint/survey_platform

I pushed draft requirements on https://tails.boum.org/blueprint/survey_platform/#limesurvey-requirements.

Please tell me if it's more or less what you expected. And maybe if we have these ones public you could use it for future reference when other "clients" as you for a service as an example; because coming from sysadmin paradigm where people running services are root or nothing; it's hard for me to know what you need to know and what you don't.

#5 Updated by intrigeri 2 months ago

  • Feature Branch deleted (https://tails.boum.org/blueprint/survey_platform)
  • Blueprint set to https://tails.boum.org/blueprint/survey_platform

#6 Updated by intrigeri 2 months ago

  • Assignee changed from intrigeri to sajolida
  • Blueprint changed from https://tails.boum.org/blueprint/survey_platform to https://tails.boum.org/blueprint/survey_platform/#limesurvey-requirements

What do you usually do to monitor web applications?

Nothing more than "I can create a test survey and you could monitor that https://survey.tails.boum.org/index.php/$SURVEYID returns 2xx" usually.

Be able to send emails to the outside world; though I might not send any as a start.

We have an email system but I don't know if it's configured well enough for random email servers out there to accept our email. We'll see.

Other than that, looks good to me.

BTW in the general section (off-topic, yes): why "non-commercial"? (This seems too vague and the way I understand it, LimeSurvey would not qualify.)

#7 Updated by sajolida 2 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Ready for QA)

The estimation of costs was done and integrated in the budget.

#8 Updated by sajolida about 2 months ago

  • Parent task changed from #14474 to #14540

Also available in: Atom PDF