Project

General

Profile

Bug #14771

Bug #10288: Fix newly identified issues to make our test suite more robust and faster

Retrying mechanism for the "I open the address" step is buggy in the Unsafe Browser

Added by intrigeri 10 months ago. Updated 11 days ago.

Status:
In Progress
Priority:
Normal
Assignee:
Category:
Test suite
Target version:
Start date:
10/04/2017
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
feature/15023-tor-browser-8
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Unsafe Browser

Description

    When I successfully start the Unsafe Browser                                                   # features/step_definitions/browser.rb:9
02:15:15.336157969: calling as root: . /usr/local/lib/tails-shell-library/tor-browser.sh && echo ${TBB_INSTALL}/firefox
02:15:15.544600665: call returned: [0, "/usr/local/lib/tor-browser/firefox\n", ""]
02:15:16.484769323: [log] CLICK on L(243,80)@S(0)[0,0 1024x768]
02:15:17.284026264: calling as root: . /usr/local/lib/tails-shell-library/tor-browser.sh && echo ${TBB_INSTALL}/firefox
02:15:17.802127293: call returned: [0, "/usr/local/lib/tor-browser/firefox\n", ""]
02:15:18.592541657: [log] CLICK on L(147,114)@S(0)[0,0 1024x768]
02:15:23.592553473: calling as amnesia: echo -n 'https://tails.boum.org' | xsel --input --clipboard
02:15:23.772854397: call returned: [0, "", ""]
02:15:23.880371021: [log] ( Ctrl )  TYPE "v" 
[log]  TYPE "#ENTER." 
02:17:23.974624891: Operation failed (Try 1 of 10) with:
FindFailed: can not find BrowserReloadButton.png in S(0)[0,0 1024x768]
02:17:24.016760770: [log]  TYPE "#ESC." 
    And I open Tails homepage in the Unsafe Browser                                                # features/step_definitions/browser.rb:201
      FindFailed: can not find BrowserAddressBar.png in S(0)[0,0 1024x768]
        Line 2171, in file Region.java
       (RuntimeError)
      features/tor_enforcement.feature:19:in `And I open Tails homepage in the Unsafe Browser'
    And Tails homepage loads in the Unsafe Browser                                                 # features/step_definitions/browser.rb:210
    Then the firewall leak detector has detected leaks                                             # features/step_definitions/firewall_leaks.rb:1
      Scenario failed at time 02:17:30

I think that the reload button is not found due to the different background color, which is one first bug that should be trivial to fix. And then apparently (didn't look at the code) we have another fallback mechanism (BrowserAddressBar.png) that fails too, which might be a second (probably less important) bug.

I'm going to flag the affected tests as fragile. They are already fragile anyway, except "Scenario: Anti test: Detecting TCP leaks from the Unsafe Browser with the firewall leak detector".


Related issues

Blocked by Tails - Feature #15023: Upgrade to Tor Browser based on Firefox ESR60 In Progress 08/30/2017 08/09/2018

Associated revisions

Revision 9d4ddd21 (diff)
Added by intrigeri 10 months ago

Test suite: flag tests that use "I open the address" in the Unsafe Browser as fragile (refs: #14771).

… except those who only open about:* pages, since they are not affected
by this bug.

Revision ef12bcf0 (diff)
Added by intrigeri 12 days ago

Revert "Test suite: flag tests that use "I open the address" in the Unsafe Browser as fragile (refs: #14771)."

I think I've fixed #14771 with c5a7b28e3cc4ca0910f102695814b5930c0aca63.

This reverts commit 9d4ddd21ae8749666fa1b1fd2429a85dd03a38ac.

History

#1 Updated by intrigeri 10 months ago

  • Status changed from Confirmed to In Progress

#2 Updated by intrigeri 10 months ago

  • Status changed from In Progress to Confirmed
  • Assignee deleted (intrigeri)

#3 Updated by intrigeri 12 days ago

  • Description updated (diff)

#4 Updated by intrigeri 12 days ago

  • Status changed from Confirmed to In Progress
  • Assignee set to intrigeri
  • Target version set to Tails_3.9
  • % Done changed from 0 to 100
  • Feature Branch set to feature/15023-tor-browser-8

Fixed on that topic branch.

#5 Updated by intrigeri 12 days ago

  • Blocked by Feature #15023: Upgrade to Tor Browser based on Firefox ESR60 added

#6 Updated by intrigeri 12 days ago

  • Status changed from In Progress to Resolved

#7 Updated by intrigeri 12 days ago

  • Status changed from Resolved to In Progress

#8 Updated by intrigeri 11 days ago

  • QA Check set to Pass

Also available in: Atom PDF