Project

General

Profile

Bug #14792

Ship only one version of Python 3 in Tails/Buster

Added by intrigeri 9 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
10/06/2017
Due date:
% Done:

100%

QA Check:
Feature Branch:
feature/buster
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

In Tails 3.2 we ship python3.5. Currently feature/buster has both 3.5 and 3.6.

History

#1 Updated by intrigeri 9 months ago

Right now tons of packages transitively depend on python3.5, and only pitivi (transitively) depends on python3.6. Let's not bother and come back to it later.

#2 Updated by intrigeri 5 months ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

Current feature/buster only has Python 3.6. Let's assume the review of the .packages diff we'll do before releasing Tails 4.0 will make us notice if a similar problem comes back.

Also available in: Atom PDF