Project

General

Profile

Bug #14962

Tor Browser >= 7.0.8 fails to render local pages correctly

Added by anonym 11 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
11/16/2017
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
feature/15023-tor-browser-8
Type of work:
Communicate
Blueprint:
Starter:
Affected tool:
Browser

Description

See: https://trac.torproject.org/projects/tor/ticket/24243

It certainly will not be fixed in time for Tails 3.3: https://lists.torproject.org/pipermail/tor-qa/2017-November/000929.html

Note that this also affects the Unsafe Browser (in fact, anything using Firefox).


Subtasks

Bug #14971: Remove translations of translations (sic) on unsafe browser warningResolvedintrigeri


Related issues

Related to Tails - Bug #14940: Upgrade Tor Browser to 7.0.10 Resolved 11/09/2017
Related to Tails - Feature #7409: Browse the offline documentation using Yelp Rejected 01/05/2014
Related to Tails - Bug #6570: Yelp freezes while searching the offline Tails documentation Rejected 01/05/2014
Related to Tails - Feature #6569: Make the Tails documentation searchable offline Confirmed 01/05/2014
Related to Tails - Bug #15234: Make Tails Installer point to the offline website when running inside Tails Rejected 01/23/2018
Related to Tails - Bug #15195: Document how to view a local build of the website in Tails 3.3 and later Resolved 01/18/2018
Related to Tails - Bug #15195: Document how to view a local build of the website in Tails 3.3 and later Resolved 01/18/2018
Related to Tails - Bug #15575: Point to /doc instead of /getting_started from "Tails documentation" desktop launcher Resolved 05/05/2018
Related to Tails - Bug #15461: The homepage of the Unsafe Browser cannot be translated Resolved 03/27/2018
Blocks Tails - Feature #15392: Core work 2018Q2 → 2018Q3: User experience Confirmed 03/09/2018
Blocked by Tails - Feature #15023: Upgrade to Tor Browser based on Firefox ESR60 Resolved 08/30/2017 08/09/2018
Blocks Tails - Feature #15334: Core work 2018Q3: Foundations Team Fix committed 02/20/2018

Associated revisions

Revision 74536c6a (diff)
Added by anonym 11 months ago

tails-documentation: rewrite in Python + use WebKit for display.

... instead of using the Tor Browser: since version 7.0.8 it fails to
render local pages (like our docs) due to #14962.

Refs: #14962

Revision da835375
Added by anonym 11 months ago

Merge branch 'feature/14940-torbrowser-7.0.10' into stable

This includes the workaround for refs: #14962.

Fix-committed: #14940

Revision 08259afa (diff)
Added by anonym 11 months ago

Replace the Unsafe Browser's warning pages with static, pure-HTML versions.

This is truly a temporary workaround for refs: #14962.

Revision a02aafef (diff)
Added by anonym 11 months ago

Prevent Ikiwiki from formatting the Unsafe Browser warning pages.

This is a follow-up on 08259afa449f3dcd916fe03db5775f3652f5a7e8.

Due to #14962 we really only want the simple text-only HTML page
without all the Ikiwiki formatting added. I'm very ignorant of
Ikiwiki, so this hack is the best I could come up with so I can
quickly rebuild Tails 3.3. I'm also sloppy: I verified my assumption
that those .html pages would be left unprocessed...

Refs: #14962

Revision 47df1d7f (diff)
Added by anonym 8 months ago

Test suite: use Dogtail instead of image.

This image was invalidated during our Donation campaign was running,
and then by a Tor Browser bug (#14962). Bumping images is boring so
let's rely on Dogtail instead.

To make this scenario more robust we also switch to something else
than the start page, and restart the browser between save/open in
order to prevent Dogtail e.g. finding the old page that we just saved
instead of the saved version we just opened.

Refs: #14935, #14962

History

#1 Updated by anonym 11 months ago

  • Related to Bug #14940: Upgrade Tor Browser to 7.0.10 added

#2 Updated by anonym 11 months ago

#3 Updated by anonym 11 months ago

  • Status changed from Confirmed to In Progress

#4 Updated by anonym 11 months ago

These are the commits implementing workarounds for this bug in Tails 3.3:

We definitely want to have 08259afa reverted once upstream is fixed, but we might want to consider keeping 74536c6a & co.

#5 Updated by anonym 11 months ago

Actually, 7d9be782a175ab3a3d583590422f4cebf307f03a and friends should probably be "ported" back into the Greeter.

#6 Updated by sajolida 11 months ago

In Tails 3.3, the Python version doesn't have our sidebar and no "Back" button which makes the thing barely usable. So if Tor:#24243 can be fixed I'd rather go this way...

#7 Updated by anonym 11 months ago

  • Assignee changed from anonym to sajolida
  • QA Check set to Info Needed

sajolida wrote:

In Tails 3.3, the Python version doesn't have our sidebar

That is intentional. The new doc viewer uses the same code as the Greeter's help veiwer, and there we deliberately disable the sidebar, and I think we do that for good reasons that apply equally in this context. Hiding the sidebar is a great way to cheaply convert our website into something that is more like offline docs: the side bar otherwise distracts and confuses by showing things like

  • "Install Tails", which they clearly already have done
  • "News", which might be outdated
  • "Contribute", which is for a very small set of users: if we want to expose this, we could provide a separate launcher somewhere

As long as you use the correct entry-point you'll find what you need without the sidebar:

  • "Report an Error" launcher ⇒ "Support", which shows just what you need about the subject, not more
  • "Tails documentation" ⇒ "Getting started...", which links to the all things of the sidebar which are relevant for users

To me it seems like the sidebar mostly is helpful if you want to reach some part of the documentation from the wrong entry-point. I suppose that isn't bad, since it is more forgiving, but I don't find it a "must have", and I certainly think the removal of the sidebar's distractions is more important.

Am I missing something? I thought I for once got UX a bit, but apparently it just lead us to controversy! :P just to be clear: I'm not defensive, just a wee bit disappointed that I apparently failed. ¯\_(ツ)_/¯

and no "Back" button which makes the thing barely usable.

Huh. Either you just missed that there is one in the header bar (but only if there actually is history to go back to), or you found a bug. Can you provide steps to reproduce if the latter?

No "Forward" button is provided, but I thought adding one would just add bloat: if your history is "site A -> site B", and you click "back" then you end up at the place of site A that linked to site B, so going forward again is just a matter of clicking the same link again.

#8 Updated by segfault 11 months ago

I agree with anonym on the sidebar, I don't think it is needed and would actually only add distraction to the doc viewer.
And the back button works for me.

I really like the new doc viewer, primarily because it's so friggin fast :) So I'm in favor of keeping it even after Tor:#24243 is fixed.

#9 Updated by intrigeri 10 months ago

#10 Updated by intrigeri 10 months ago

#11 Updated by sajolida 9 months ago

  • Assignee changed from sajolida to anonym
  • QA Check changed from Info Needed to Dev Needed

Indeed, I missed the "Back" button when I first looked for it. The same might happen to others.

Something else I thought about is that we sometimes give file:/// URLs in our doc and code for people to visit and that's not possible to copy and paste in GNOME Help.

If speed of opening is the only argument in favor of GNOME Help, then I'm still pretty much against it. I think that being in the familiar environment of a browser is more important than speed of opening. Especially since people most likely already have a browser open or will open one later on.

But this ticket is about fixing the display of local pages in Tor Browser which is something we want to do independently from my opinion on GNOME Help, right?

#12 Updated by intrigeri 9 months ago

  • Assignee changed from anonym to sajolida
  • QA Check deleted (Dev Needed)
  • Type of work changed from Wait to User interface design

I see no indication that this regression will be fixed any time soon so IMO we should move on, acknowledge this bug and decide what's the best workaround to it.

I don't see it mentioned here, so here we go: we still have the option to point to online URLs instead of file:/// ones, as I suggested back when we discovered this Tor Browser regression. Of course it would not work offline but at least it would work reliably online, we don't have to discover and fix bugs like #15160 along the way, the corresponding test suite regression is fixed, and sajolida's point about UX is addressed. I don't know what's best but I think this should be sajolida's call.

#13 Updated by anonym 9 months ago

  • Target version changed from Tails_3.5 to Tails_3.6

#14 Updated by sajolida 9 months ago

  • Related to Feature #7409: Browse the offline documentation using Yelp added

#15 Updated by sajolida 9 months ago

  • Assignee changed from sajolida to anonym
  • QA Check set to Info Needed

How crazy would it be to open the doc online if Tor is ready and in the help browser if Tor is not ready?

Otherwise, it will be hard for me to decide between:

  • Having something that works offline but with a degraded UX (in my opinion).
  • Having something that only works online but in the familiar environment of a browser.

But I can always toss a coin :)

#16 Updated by sajolida 9 months ago

  • Related to Bug #6570: Yelp freezes while searching the offline Tails documentation added

#17 Updated by sajolida 9 months ago

  • Related to Feature #6569: Make the Tails documentation searchable offline added

#18 Updated by sajolida 9 months ago

  • Related to Bug #15234: Make Tails Installer point to the offline website when running inside Tails added

#19 Updated by anonym 9 months ago

sajolida wrote:

How crazy would it be to open the doc online if Tor is ready and in the help browser if Tor is not ready?

It is ~trivial:

--- a/config/chroot_local-includes/usr/local/bin/tails-documentation
+++ b/config/chroot_local-includes/usr/local/bin/tails-documentation
@@ -86,6 +86,12 @@ try:
     page = sys.argv[1]
 except IndexError:
     page = 'getting_started'
+
+# If possible, let's hand-off to our website, which should be the most
+# up-to-date option.
+if os.system('/usr/local/sbin/tor-has-bootstrapped') == 0:
+    os.execv(['/usr/local/bin/tor-browser', 'https://tails.boum.org/' + page])
+
 wiki_path = '/usr/share/doc/tails/website'
 lang_code = os.getenv('LANG', 'en')[0:2]
 trials = [

My only issue is that tor-has-bootstrapped != "tor is working", but this is a problem we have all over Tails, so => not a blocker.

#20 Updated by anonym 9 months ago

  • Assignee changed from anonym to sajolida

The implicit question was: "With the change from #14962#note-19 our workaround is acceptable?"

(The real fix for this ticket will be when upstream fixes whatever bug is causing this.)

#21 Updated by sajolida 8 months ago

  • Assignee changed from sajolida to anonym
  • QA Check changed from Info Needed to Dev Needed

I don't like being asked if something is acceptable or not because it's not "0" or "1".

But I like #14962#note-19 and we should probably keep this code even after Tor Browser can read local files again :)

#22 Updated by intrigeri 8 months ago

  • Assignee changed from anonym to sajolida
  • QA Check changed from Dev Needed to Info Needed

Hi sajolida!

sajolida wrote:

But I like #14962#note-19

Me too!

and we should probably keep this code even after Tor Browser can read local files again :)

I've re-read this ticket and while you've been given the technical info you've requested, I don't see a clear conclusion from you about what we should do. My understanding is:

  • As I said last month, "IMO we should move on, acknowledge this bug and decide what's the best workaround to it".
  • We now know that we can open a different doc browser depending on whether we're online or not.
  • It seems we agree that when we're online we should open the online version of the doc, regardless of whether this Tor Browser bug about local pages is fixed or not (hint: I doubt it will be fixed); right?
  • I don't understand what you prefer us to do when we're offline but likely you lack some information. What we are shipping right now is a Tails-specific restricted local browser called Tails Documentation; it's unclear if we should improve it or drop it. OTOH above I see you discussing GNOME Help (aka. Yelp) and we still have #7409 opened. So I'm confused. But wait, I don't think we should spend time on this right now, see below.

I propose we:

  1. in order to solve the immediate UX regresion: create a dedicated ticket about opening the online version of the doc when we're online i.e. the patch anonym proposed above; this could go into Tails 3.6
  2. assess how urgent the next steps are and postpone this ticket accordingly (IMO once the immediate regression is fixed, there's no strong reason why we should direct resources here urgently; we have plenty of other UX improvements we may want to do and lack budget for)
  3. regarding the Unsafe Browser homepage that can't be translated anymore if I get this right (08259afa449f3dcd916fe03db5775f3652f5a7e8, the truly temporary workaround): create a new ticket on the Foundations Team's plate; I think this should be tackled in 3.7 or 3.8
  4. regarding browsing the doc offline:
    1. retitle this ticket "Decide what to do about browsing the documentation offline in Tails"
    2. mark this ticket as blocking #7409
    3. evaluate what we would have to do in order to make the Tails Documentation app a suitable long-term thing, both in terms of UI (is the UI good enough or do is it something we have to improve now instead of working on other UX improvements that require design+code work?) and in terms of code (IIRC currently it duplicates code that we had in the Greeter, and more generally I understand this was written as a temporary workaround so if we want to keep it we may need to take a step back)
    4. evaluate the Yelp option (a few years ago it had plenty of bugs that made it not ideal for us, to say the least): some exploratory testing + testing the bugs we had identified back then

anonym, sajolida: what do you think about this proposed course of action?

#23 Updated by anonym 8 months ago

sajolida wrote:

I don't like being asked if something is acceptable or not because it's not "0" or "1".

Ok. How should I ask your opinion, then?

(Clarification: I was not asking your opinion on the code, just if the "crazy" change you asked for actually was something you want implemented.

But I like #14962#note-19 and we should probably keep this code even after Tor Browser can read local files again :)

Cool! I've opened #15332 to track this.

#24 Updated by anonym 8 months ago

intrigeri wrote:

anonym, sajolida: what do you think about this proposed course of action?

I like it, and it was in fact the direction I already had started moving (with #15332). sajolida?

#25 Updated by sajolida 8 months ago

  • Related to Bug #15195: Document how to view a local build of the website in Tails 3.3 and later added

#26 Updated by sajolida 8 months ago

  • Related to Bug #15195: Document how to view a local build of the website in Tails 3.3 and later added

#27 Updated by sajolida 7 months ago

  • Target version changed from Tails_3.6 to Tails_3.7

#28 Updated by sajolida 7 months ago

  • Assignee deleted (sajolida)
  • Target version deleted (Tails_3.7)
  • QA Check deleted (Info Needed)

From Tails 3.6:

  • When online the documention opens in Tor Browser (#15332).
  • When offline the documention opens in Yelp. I don't see what you mean by "the Tails Documentation app".

So the course of action that you are describing seems obsolete now.

Still:

  • I created a ticket to translate the homepage of the Unsafe Browser → #15461.
  • I pinged Tor regarding their plans on Tor:#24243.

Also note that this ticket as such is also important because it breaks the workflow of contributors working on our website from Tails (mostly me and translators). So I'm not renaming it but I'm removing the target version.

#29 Updated by sajolida 7 months ago

  • Type of work changed from User interface design to Wait

Marking as wait because we won't be able to fix this ourselves as it's a bug in Tor Browser.

#30 Updated by intrigeri 7 months ago

  • Assignee set to sajolida
  • Target version set to Tails_3.7
  • QA Check set to Info Needed

From Tails 3.6:

  • When online the documention opens in Tor Browser (#15332).

Right.

  • When offline the documention opens in Yelp. I don't see what you mean by "the Tails Documentation app".

I'm curious what made you draw this conclusion. I did not try on 3.6 but on Tails 3.6.1 after double-clicking the "Tails documentation" icon I see:

amnesia@amnesia:~$ ps aux | grep yelp
amnesia   7078  0.0  0.0  12724   952 pts/0    S+   15:36   0:00 grep --color=auto yelp
amnesia@amnesia:~$ ps aux | grep tails-documentation
amnesia   6683  9.5  3.2 2193712 95400 tty2    Sl+  15:36   0:02 python3 /usr/local/bin/tails-documentation getting_started
amnesia   7199  0.0  0.0  12724   980 pts/0    S+   15:36   0:00 grep --color=auto tails-documentation

So the course of action that you are describing seems obsolete now.

I don't think so => I'd still like to know what you think about it => resetting metadata to the state before you erroneously concluded my proposal was obsolete :)

  • I created a ticket to translate the homepage of the Unsafe Browser → #15461.
  • I pinged Tor regarding their plans on Tor:#24243.

Thanks!

#31 Updated by intrigeri 7 months ago

#32 Updated by intrigeri 7 months ago

#33 Updated by sajolida 6 months ago

  • Blocks Feature #15392: Core work 2018Q2 → 2018Q3: User experience added

#34 Updated by sajolida 6 months ago

Something else against the dumb browser: it has no tab. Using many tabs is very common amongst millenials: https://www.nngroup.com/articles/multi-tab-page-parking/.

#35 Updated by emmapeel 6 months ago

  • Blocks Bug #15461: The homepage of the Unsafe Browser cannot be translated added

#36 Updated by sajolida 6 months ago

  • Related to Feature #15576: Add back the sidebar on the offline documentation browser added

#37 Updated by sajolida 6 months ago

  • Related to Feature #15577: Have tabs in the offline documentation browser added

#38 Updated by sajolida 6 months ago

And here you go! Two days after I wrote #14962#note-35 I saw two millenials trying to open tabs in the offline documentation browser and failed → #15577.

#39 Updated by sajolida 6 months ago

  • Target version changed from Tails_3.7 to Tails_3.8

#40 Updated by sajolida 5 months ago

  • Related to Bug #15575: Point to /doc instead of /getting_started from "Tails documentation" desktop launcher added

#41 Updated by sajolida 5 months ago

  • Assignee changed from sajolida to intrigeri

Following up on intrigeri's summary from #14962#note-22:

  • I created #15612 to improve the "Tails documentation" browser and make it as consistent as possible with the online doc.
  • I created subtickets for #15612 to fix each of the usability issues that I identified during the user testing of the Additional Software feature: missing sidebar and tabs.
  • I asked for clarification on why Yelp would be better than the "Tails documentation" browser in #7409#note-9.

I think we should keep the title of this ticket because this bug affects other aspects of Tails than our offline documentation: at least the Unsafe Browser and the workflow of many contributors. But if people prefer a different Redmine semantics, I really don't mind.

#42 Updated by intrigeri 5 months ago

  • QA Check deleted (Info Needed)

#43 Updated by intrigeri 5 months ago

#44 Updated by intrigeri 5 months ago

Following up on intrigeri's summary from #14962#note-22:

  • I created #15612 to improve the "Tails documentation" browser and make it as consistent as possible with the online doc.
  • I created subtickets for #15612 to fix each of the usability issues that I identified during the user testing of the Additional Software feature: missing sidebar and tabs.
  • I asked for clarification on why Yelp would be better than the "Tails documentation" browser in #7409#note-9.

OK, so it seems you've decided that improving our custom "Tails documentation" is better than using the Unsafe Browser for browsing the doc offline. Fine by me. Thanks!

I think we should keep the title of this ticket because this bug affects other aspects of Tails than our offline documentation: at least the Unsafe Browser and the workflow of many contributors.

Makes sense to me!

#45 Updated by intrigeri 5 months ago

  • Target version changed from Tails_3.8 to Tails_3.10
  • Type of work changed from Wait to Communicate

(There's nothing we can expect poking Tor Browser people so that they poke Mozilla people.)

#46 Updated by intrigeri 5 months ago

#47 Updated by sajolida 5 months ago

OK, so it seems you've decided that improving our custom "Tails documentation" is better than using the Unsafe Browser for browsing the doc offline. Fine by me. Thanks!

I don't understand this comment of yours... I didn't think that using
the Unsafe Browser to browse the doc offline was an option because:

  • Searching for "Unsafe" on this ticket doesn't make this clear.
  • The description of this tickets says that the Unsafe Browser is
    affected by the same bug: it can't render local pages correctly.

Did I miss something?

#48 Updated by intrigeri 5 months ago

Did I miss something?

No, I was confused. Sorry for wasting your time!

#49 Updated by sajolida 4 months ago

GeKo said on Tor#24243 that it should be fixed in Tor Browser 8.0a9.

When will this land in Tails?

#51 Updated by intrigeri 4 months ago

GeKo said on Tor#24243 that it should be fixed in Tor Browser 8.0a9.

Great!

When will this land in Tails?

When we get Tor Browser 8.0, in Tails 3.9.

#52 Updated by intrigeri 4 months ago

  • Blocked by Feature #15023: Upgrade to Tor Browser based on Firefox ESR60 added

#53 Updated by intrigeri 4 months ago

  • Blocks deleted (Bug #15461: The homepage of the Unsafe Browser cannot be translated)

#54 Updated by intrigeri 4 months ago

  • Related to Bug #15461: The homepage of the Unsafe Browser cannot be translated added

#55 Updated by intrigeri 4 months ago

  • Target version changed from Tails_3.10 to Tails_3.9

I confirm this is fixed with Tor Browser 8.0a9 :)

#56 Updated by intrigeri 4 months ago

#57 Updated by intrigeri 4 months ago

#58 Updated by intrigeri 4 months ago

  • Feature Branch set to feature/15023-tor-browser-8

#59 Updated by intrigeri 3 months ago

  • QA Check set to Pass

#60 Updated by intrigeri 2 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)

#61 Updated by intrigeri about 1 month ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF