Project

General

Profile

Bug #14968

ublock origin inaccessible in Tails 3.3

Added by Anonymous 5 months ago. Updated 4 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
11/16/2017
Due date:
% Done:

0%

QA Check:
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Browser

Description

i don't know how you guys do it but you somehow manage to add a little annoyance with every release
first the persistence lock out disaster then the inability to set a persistent search engine other than the default and now ublocks inaccessibility (no icon no nothing) and literally half the web that wants you to turn it off is now broken if you don't want to restart every time
guess this will be reviewed new years eve the soonest until then tails is unusable for me, that is great. anybody know at least the settings url of ublock to set whitelists?

good thing is it is now possible for me to brew a coffee on boot time and even finish it :)

excuse my slight rant but this kind of stuff should be noticed before it gets rolled out

ublock.patch View (565 Bytes) cacahuatl, 11/21/2017 12:50 AM


Related issues

Duplicates Tails - Bug #14993: uBlock is broken in Tails 3.3 Resolved 11/19/2017

Associated revisions

Revision df6c6f16 (diff)
Added by intrigeri 4 months ago

Add a manual test for uBlock (refs: #14968)

History

#1 Updated by Anonymous 5 months ago

going to chrome://ublock0/content/dashboard.html does not work either same goes for reinstalling it
it is hard to tell if it is even working most likely not and yet it breaks half the web that block ublock and using adblock killer list is not possible too because well hard to do it with a broken ublock

#2 Updated by cacahuatl 5 months ago

I also experienced this, I also really hate ads.

I created a test stable build with some lines added to apt preferences to pin the source for xul-ext-ublock-origin to the newer version distributed with sid, which restores ublock functionality.

#3 Updated by mercedes508 5 months ago

  • Status changed from New to Duplicate

Duplicate of 14993

#4 Updated by intrigeri 5 months ago

  • Duplicates Bug #14993: uBlock is broken in Tails 3.3 added

#5 Updated by myriseupacc 4 months ago

Notice that when starting Tor Browser, that uBlock Origin's .xpi file is not present at /home/amnesia/.tor-browser/profile.default/extensions
Removing uBlock Origin an installing from the addons menu or installing any of the last 10 versions from https://addons.mozilla.org/en-US/firefox/addon/ublock-origin/versions/ works fine for me.

Also available in: Atom PDF