Project

General

Profile

Bug #14971

Bug #14962: Tor Browser >= 7.0.8 fails to render local pages correctly

Remove translations of translations (sic) on unsafe browser warning

Added by sajolida 26 days ago. Updated 4 days ago.

Status:
Resolved
Priority:
Elevated
Assignee:
Category:
-
Target version:
Start date:
11/16/2017
Due date:
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Website
Blueprint:
Starter:
Affected tool:
Unsafe Browser

Description

Doing ls -1 misc/unsafe_browser_warning.* produces:

misc/unsafe_browser_warning.de.de.po
misc/unsafe_browser_warning.de.fa.po
misc/unsafe_browser_warning.de.fr.po
misc/unsafe_browser_warning.de.html
misc/unsafe_browser_warning.de.it.po
misc/unsafe_browser_warning.de.pt.po
misc/unsafe_browser_warning.en.de.po
misc/unsafe_browser_warning.en.fa.po
misc/unsafe_browser_warning.en.fr.po
misc/unsafe_browser_warning.en.html
misc/unsafe_browser_warning.en.it.po
misc/unsafe_browser_warning.en.pt.po
misc/unsafe_browser_warning.fa.de.po
misc/unsafe_browser_warning.fa.fa.po
misc/unsafe_browser_warning.fa.fr.po
misc/unsafe_browser_warning.fa.html
misc/unsafe_browser_warning.fa.it.po
misc/unsafe_browser_warning.fa.pt.po
misc/unsafe_browser_warning.fr.de.po
misc/unsafe_browser_warning.fr.fa.po
misc/unsafe_browser_warning.fr.fr.po
misc/unsafe_browser_warning.fr.html
misc/unsafe_browser_warning.fr.it.po
misc/unsafe_browser_warning.fr.pt.po
misc/unsafe_browser_warning.it.de.po
misc/unsafe_browser_warning.it.fa.po
misc/unsafe_browser_warning.it.fr.po
misc/unsafe_browser_warning.it.html
misc/unsafe_browser_warning.it.it.po
misc/unsafe_browser_warning.it.pt.po
misc/unsafe_browser_warning.pot
misc/unsafe_browser_warning.pt.html

So it seems like 08259afa44 didn't disable the PO plugin on the static HTML pages.


Related issues

Blocks Tails - Feature #13244: Core work 2017Q4: Foundations Team Confirmed 06/29/2017

Associated revisions

Revision 194fcfc2 (diff)
Added by intrigeri 4 days ago

Re-synchronize ikiwiki-cgi.setup wrt. recent changes made to ikiwiki.setup (refs: #14971).

Revision 527b2c37 (diff)
Added by intrigeri 4 days ago

Remove buggy "PO" files (refs: #14971)

The intent of the work done as part of #14962 was to create static,
pre-translated *.$LANG.html files, and to make them non-translatable
as far as ikiwiki's po plugin is concerned.

Revision c2ec0efc (diff)
Added by intrigeri 4 days ago

ikiwiki*.setup: mark misc/* as non-translatable (refs: #14971)

Otherwise useless and buggy PO files will keep reappearing, given these files
were not excluded as intended in
a02aafefe1c3850461d28a44befd2378fe527741).

History

#1 Updated by intrigeri 5 days ago

#2 Updated by intrigeri 5 days ago

  • Priority changed from Normal to Elevated

#3 Updated by intrigeri 5 days ago

  • Assignee changed from anonym to intrigeri

#4 Updated by intrigeri 4 days ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10

sajolida wrote:

So it seems like 08259afa44 didn't disable the PO plugin on the static HTML pages.

It did, but this change was not applied on our production website configuration (nor to ikiwiki-cgi.setup by the way) so once pushed there, ikiwiki in the production environment generated the missing PO files (37980b83fd96cb52f7c6ee47596671fa076b0592).

#5 Updated by intrigeri 4 days ago

Actually a02aafefe1c3850461d28a44befd2378fe527741 changed this again, reverting 08259afa44 and doing another change that was not conveyed to our production website config.

#6 Updated by intrigeri 4 days ago

  • % Done changed from 10 to 30

I think I'm done, pushed to master. I'm building an ISO from devel + master merged into it to ensure this still works.

I have no idea how this exclude directive still allows copying the files unmodified, whatever.

#7 Updated by intrigeri 4 days ago

  • Status changed from In Progress to Resolved
  • % Done changed from 30 to 100

Fixed, but again I don't understand why it works at all, so it'd better be temporary as the commit message says. When this gets reverted, please coordinate with me so the config of our production web site is kept in sync.

Also available in: Atom PDF