Project

General

Profile

Bug #14993

uBlock is broken in Tails 3.3

Added by beoing341 8 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
11/19/2017
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
bugfix/14993-fix-ublock
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Browser

Description

I noticed that Ublock is not working in Tails 3.3 and believe this might be because of the new API.

1.jpg First start of TB
2.jpg about:addons
3.jpg Ublock Dashboard accessed through URI
4.jpg Dashboard 3P-filter
5.jpg Uninstall and reinstall of current 1.14.18 Icon visible but still overall defunctional
6.jpg Uninstall and reinstall of current beta 1.14.19b7 seems functional but frooze slightly
7.jpg Dashboard Ublock 1.14.19b7
8.jpg Dasboard 3P-filter looks working but update defunctional with no tx rx and high cpu load trying

8.jpg View (30.2 KB) beoing341, 11/19/2017 09:18 AM

1.jpg View (7.41 KB) beoing341, 11/19/2017 09:18 AM

2.jpg View (20.1 KB) beoing341, 11/19/2017 09:18 AM

3.jpg View (30.5 KB) beoing341, 11/19/2017 09:19 AM

4.jpg View (15.4 KB) beoing341, 11/19/2017 09:19 AM

5.jpg View (13.8 KB) beoing341, 11/19/2017 09:19 AM

6.jpg View (20 KB) beoing341, 11/19/2017 09:20 AM

7.jpg View (25.2 KB) beoing341, 11/19/2017 09:20 AM


Related issues

Related to Tails - Bug #15616: devel branch FTBFS: xul-ext-ublock-origin is not installable Fix committed 05/23/2018
Duplicated by Tails - Bug #14968: ublock origin inaccessible in Tails 3.3 Duplicate 11/16/2017
Blocks Tails - Feature #13244: Core work 2017Q4: Foundations Team Resolved 06/29/2017

Associated revisions

Revision 536cc4ec (diff)
Added by intrigeri 7 months ago

Install xul-ext-ublock-origin from sid (refs: #14993)

Thanks to cacahuatl <> for the patch!

Revision 8078d6a6 (diff)
Added by intrigeri 7 months ago

Manual test suite: add regression test for uBlock (refs: #14993)

Revision 67757fbb
Added by anonym 7 months ago

Merge remote-tracking branch 'origin/bugfix/14993-fix-ublock' into stable

Fix-committed: #14993

History

#1 Updated by beoing341 8 months ago

#2 Updated by beoing341 8 months ago

#3 Updated by beoing341 8 months ago

#4 Updated by beoing341 8 months ago

#5 Updated by beoing341 8 months ago

#6 Updated by beoing341 8 months ago

#7 Updated by beoing341 8 months ago

#8 Updated by mercedes508 8 months ago

  • Status changed from New to Confirmed
  • Assignee set to anonym
  • Priority changed from Elevated to Normal

Assigning to anonym to check ublock status.
Many users reported that it doesn't work since Tails 3.3

#9 Updated by intrigeri 8 months ago

  • Duplicated by Bug #14968: ublock origin inaccessible in Tails 3.3 added

#10 Updated by intrigeri 8 months ago

See patch on #14968.

#11 Updated by intrigeri 8 months ago

#12 Updated by intrigeri 8 months ago

  • Priority changed from Normal to Elevated
  • Target version set to Tails_3.5

(Regression.)

#13 Updated by intrigeri 7 months ago

  • Assignee changed from anonym to intrigeri

#14 Updated by intrigeri 7 months ago

  • Priority changed from Elevated to High

This has been the 1st hot topic for help desk in November, raising priority.

#15 Updated by intrigeri 7 months ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to anonym
  • % Done changed from 0 to 30
  • QA Check set to Ready for QA
  • Feature Branch set to bugfix/14993-fix-ublock

Applied cacahuatl's patch (slightly modified to preserve lexical sorting) and pushed. Code review passes, not tested myself but cacahuatl has built and tested so I think this is ready for QA.

#16 Updated by anonym 7 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 30 to 100
  • QA Check changed from Ready for QA to Pass

Fixes the problem beautifully => merged!

#17 Updated by intrigeri 7 months ago

  • Subject changed from Incompatibility of Tor Browser and mozextension API to uBlock is broken in Tails 3.3

#18 Updated by intrigeri 6 months ago

  • Target version changed from Tails_3.5 to Tails_3.4

#19 Updated by anonym 6 months ago

  • Status changed from Fix committed to Resolved

#20 Updated by intrigeri about 2 months ago

  • Related to Bug #15616: devel branch FTBFS: xul-ext-ublock-origin is not installable added

Also available in: Atom PDF