Project

General

Profile

Bug #15024

Tor Browser cannot print to file

Added by anonym 6 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
12/08/2017
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
feature/15197-tor-browser-7.5
Type of work:
Wait
Blueprint:
Starter:
Affected tool:
Browser

Description

This regression was introduced in Tails 3.3 when that imports Tor Browser 7.0.10-build2.

When printing to file it looks like it succeeds (dialog's progress goes to 100%, no errors are shown) but the file is not created, and I can see this written to the journal:
Dec 08 13:49:50 amnesia firefox[12397]: /build/glib2.0-2.50.3/./gobject/gsignal.c:3492: signal name 'selection_changed' is invalid for instance '0x7dd7c1dc2740' of type 'MaiAtkType319'

Note:
  • the above journal error is not emitted when printing in Tor Browser in Tails 3.2,
  • but it is also emitted in Tails 3.3 when printing with a real printer too, and that works

Related issues

Related to Tails - Bug #13403: Can't print to file from Tor Browser when Tails session not in English Resolved 07/03/2017
Related to Tails - Bug #15336: "The persistent Tor Browser directory is usable" test suite scenario is fragile In Progress 02/20/2018
Duplicated by Tails - Bug #14978: Print to file doesn't work in Tails 3.3 Duplicate 11/17/2017
Duplicated by Tails - Bug #15066: Printing to PDF with Tor Browser does not work anymore Duplicate 12/14/2017
Blocks Tails - Feature #13245: Core work 2018Q1: Foundations Team Resolved 06/29/2017
Blocked by Tails - Feature #15197: Upgrade to Tor Browser 7.5 Resolved 01/18/2018

Associated revisions

Revision 15ff2632 (diff)
Added by intrigeri 6 months ago

Test suite: disable tests that are known broken due to a Tor Browser bug (refs: #15024)

Revision 3549705c (diff)
Added by anonym 4 months ago

Tor Browser: force a sane default print-to-file directory.

At least with Tor Browser 7.5 without this pref set the default
becomes "tor-browser" (which presumably is the executable's directory,
i.e. /usr/local/lib/tor-browser) that we do not have permissions to
write to.

Will-fix: #15024

Revision 00e426d2
Added by anonym 4 months ago

Merge remote-tracking branch 'origin/feature/15197-tor-browser-7.5' into stable

Fix-committed: #13403, #15024, #15064, #15197

Revision d7c363f1 (diff)
Added by intrigeri 3 months ago

Revert "Test suite: disable tests that are known broken due to a Tor Browser bug"

This reverts commit 15ff263293c612f69138e03f7fb2f9aedd006e23.

https://labs.riseup.net/code/issues/15024#note-6 was missed
when we closed #15024.

History

#1 Updated by anonym 6 months ago

#2 Updated by intrigeri 6 months ago

Looks like #13403 but worse. I think this is well tracked upstream already but I'll double check.

#3 Updated by intrigeri 6 months ago

  • Related to Bug #13403: Can't print to file from Tor Browser when Tails session not in English added

#4 Updated by intrigeri 6 months ago

Reproduced on Debian sid.

#5 Updated by intrigeri 6 months ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Type of work changed from Code to Wait

That's upstream bug https://trac.torproject.org/projects/tor/ticket/23970 which is on the Tor Browser team roadmap for December.

#6 Updated by intrigeri 6 months ago

To do when closing this ticket

Revert 15ff263293c612f69138e03f7fb2f9aedd006e23

#7 Updated by intrigeri 5 months ago

  • Duplicated by Bug #14978: Print to file doesn't work in Tails 3.3 added

#8 Updated by intrigeri 5 months ago

  • Duplicated by Bug #15066: Printing to PDF with Tor Browser does not work anymore added

#9 Updated by intrigeri 5 months ago

  • % Done changed from 10 to 20

Fixed in the Tor Browser tor-browser-52.5.2esr-7.5-2 branch => asked when the fix will make it into a stable Tor Browser release.

#10 Updated by intrigeri 5 months ago

  • Assignee changed from intrigeri to anonym

This should be fixed in the next Tor Browser stable release. anonym, please confirm when you'll import it :)

#11 Updated by intrigeri 5 months ago

  • % Done changed from 20 to 50

#12 Updated by intrigeri 5 months ago

#13 Updated by intrigeri 5 months ago

#14 Updated by intrigeri 4 months ago

#15 Updated by intrigeri 4 months ago

  • QA Check set to Ready for QA

#16 Updated by anonym 4 months ago

  • Feature Branch set to feature/15197-tor-browser-7.5

So, this works fine with Tor Browser 7.5, except that the default directory that is selected is tor-browser (which presumably is the executable's directory, i.e. /usr/local/lib/tor-browser). I set a pref (print.print_to_filename) to make ~/Tor Browser the default directory.

#17 Updated by anonym 4 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

#18 Updated by anonym 4 months ago

  • Status changed from Fix committed to Resolved

#19 Updated by anonym 3 months ago

  • Related to Bug #15336: "The persistent Tor Browser directory is usable" test suite scenario is fragile added

Also available in: Atom PDF