Project

General

Profile

Feature #15026

Publish Tested/Working Hardware Page

Added by huertanix 11 months ago. Updated 6 months ago.

Status:
In Progress
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
12/08/2017
Due date:
% Done:

0%

QA Check:
Feature Branch:
Type of work:
End-user documentation

Description

A documentation feature request: Page documenting which hardware (computers and USB drives) Tails releases have been tested with, preferably without previous modification (internal wifi card swapping, firmware flashing, etc).

The current Known Issues page (https://tails.boum.org/support/known_issues/) can be hard to find, sometimes outdated and a bit contradictory (Most tested PNY drives in my experience work, as do the Sandisk Cruzer Glides). Although that page still has its use, in my experience with trainings, most organizations are looking to purchase hardware for a specific operation that involves Tails, and they just need to know very quickly which laptops and USB drives they should shop for.


Related issues

Related to Tails - Feature #14536: Restructure the Known issues page Confirmed 08/30/2017

Associated revisions

Revision d66cba7a (diff)
Added by intrigeri 6 months ago

Create blueprint (refs: #15026)

History

#1 Updated by mercedes508 10 months ago

  • Assignee set to emmapeel

#2 Updated by emmapeel 9 months ago

  • Assignee changed from emmapeel to huertanix
  • QA Check set to Info Needed

The main obstacle for this decision is the lack of time to maintain that resource, and the lack of hardware to test.

Could you mantain such a list?

We could open a wikipage on our website if you want.

#3 Updated by u 9 months ago

FYI: I think we've previously discussed this and decided that such a list can never be complete and that we can't possibly maintain such a list ourselves.

#4 Updated by u 9 months ago

  • QA Check deleted (Info Needed)
  • Type of work changed from Website to End-user documentation

#5 Updated by u 9 months ago

#6 Updated by u 9 months ago

  • QA Check set to Info Needed

#7 Updated by goupille 7 months ago

  • Status changed from New to Rejected
  • QA Check deleted (Info Needed)

no news from the user so I'm closing this ticket

#8 Updated by goupille 7 months ago

  • Assignee deleted (huertanix)

#9 Updated by huertanix 7 months ago

  • Status changed from Rejected to In Progress
  • Assignee set to huertanix

I'll work on it once I get a free weekend later this month, but essentially this will be a page with:

  • A paragraph explaining why Tails can't practically be tested on every configuration of every machine.
  • Recommendations on how to find Linux-friendly computers (e.g. find other Linux users and ask).
  • A (very short starting with zero) FOSS-friendly vendors who test Tails, or at least the version of Debian Tails is based on, on their hardware.

Preferably, there should be someplace on the front page or in some steps of the setup wizard with a "Will my computer be able to run Tails?" link leading to the page.

#10 Updated by huertanix 7 months ago

I wasn't able to add a page to /blueprint so I'm pasting in the copy for the new page here:

<whatever heading is appropriate>Will my computer run TAILS?</heading>

Most computer vendors typically configure their offerings to run Windows or macOS. Since TAILS is based on a Linux operating system that your computer was likely not designed to run, some features you’re used to using in your computer may not function in Tails. The TAILS team cannot all releases of TAILS on all known computers and currently, no vendors configure their products to work with TAILS specifically. However, some vendors do offer computers that function well in similar variants of Debian, the Linux distribution that TAILS is based on or other similar Linux distributions.

Known Linux-friendly vendors:

Other hardware vendors may also have excellent Linux support but not advertise it. A few hours of <link: https://duckduckgo.com/?q=debian-friendly+laptop&t=hh&ia=web&gt;online searching</link> may help find a good candidate for a computer that will work well with a Debian-based operating system, such as TAILS. The best way to find out if your computer will run TAILS, however, is to <link: https://tails.boum.org/install/index.en.html&gt;download TAILS</link> and see for yourself!

#11 Updated by intrigeri 6 months ago

I wasn't able to add a page to /blueprint

I'll happily create one for you: just tell me what the desired URL is :)

#12 Updated by huertanix 6 months ago

intrigeri wrote:

I wasn't able to add a page to /blueprint

I'll happily create one for you: just tell me what the desired URL is :)

I was thinking /about/computer_compatibility if that sounds good.

#13 Updated by intrigeri 6 months ago

  • Blueprint set to https://tails.boum.org/blueprint/computer_compatibility

intrigeri wrote:

I wasn't able to add a page to /blueprint

I'll happily create one for you: just tell me what the desired URL is :)

I was thinking /about/computer_compatibility if that sounds good.

I was asking about the URL to the blueprint, not the URL where you think this page should go once it's ready (IMO it's a bit too early to discuss that).
I've created https://tails.boum.org/blueprint/computer_compatibility.

Also available in: Atom PDF