Project

General

Profile

Bug #15101

Feature #14548: Fix issues identified in the expert review done by jaster on our installation instructions

Add feedback when opening desktop launchers

Added by sajolida 9 months ago. Updated 18 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
12/25/2017
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
feature/15023-tor-browser-8
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Currently there's no feedback when opening the desktop launchers. Starting apps via the Applications menu is out of scope here, see #15738.

These can take quite some time to take action, for example several seconds to open the documentation, and lead people to believe that they haven't clicked correctly.

This was reported by huertanix when training journalists who are new to GNOME.

During the user testing of the Additional Software beta, I also saw 4 out of 5 participants open an application multiple times by mistake. All 5 participants were otherwise GNOME users so this issue is affecting quite frequently experienced users as well.

According to Florian Müllner there's a freedesktop specification to provide feedback when launching applications.


Related issues

Related to Tails - Bug #15528: Additional Software gets opened multiple times Confirmed 04/12/2018
Related to Tails - Feature #14544: Spend software developer time on smallish UX improvements In Progress 08/31/2018
Related to Tails - Bug #15738: Test feedback when opening applications from the Applications menu Confirmed 07/17/2018
Related to Tails - Feature #15546: Feedback needed when clicking on Persistence wizard → configure ASP gear button In Progress 04/18/2018
Blocked by Tails - Feature #15023: Upgrade to Tor Browser based on Firefox ESR60 Resolved 08/30/2017 08/09/2018

Associated revisions

Revision 5d4ecaef (diff)
Added by intrigeri 3 months ago

Provide feedback while Tor Browser is starting (refs: #15101).

Revision 14d5feb3 (diff)
Added by intrigeri 3 months ago

Provide feedback while starting "Tails documentation" or "Report an error" (refs: #15101).

This may work less reliably when offline as long as we use a custom
documentation browser in that situation, but it'll go away soon (#15612).

Revision 3e15d9c9 (diff)
Added by intrigeri 3 months ago

Fix Tor Browser being called "Tails documentation" in the top bar (refs: #15101).

Fix against 14d5feb398f8d7aad89829c627045422d44cfadc.

Now that there were multiple .desktop files that claim the "Tor Browser"
WM_CLASS, GNOME got confused and picked the wrong one. Apparently giving
tor-browser.desktop its own StartupWMClass is enough to fix that.

History

#1 Updated by denkxor 6 months ago

On debian 9 stretch with gnome 3 the cursor becomes a spinner if the application does not start immediately.

#2 Updated by sajolida 5 months ago

  • Description updated (diff)

#3 Updated by sajolida 5 months ago

  • Subject changed from No feedback when opening desktop launchers (especially documentation) to No feedback when opening an application

I'm making the scope of this ticket broader because there is not feedback either when opening an app from the Applications menu.

#4 Updated by emmapeel 5 months ago

  • Related to Bug #15528: Additional Software gets opened multiple times added

#5 Updated by sajolida 4 months ago

  • Subject changed from No feedback when opening an application to No feedback when opening some applications
  • Description updated (diff)
  • Assignee changed from cbrownstein to intrigeri
  • QA Check set to Info Needed
  • Type of work changed from Test to Research

I followed up on this on the GNOME bug tracker. While doing more tests I realized that some applications provide feedback while some other don't. See the video on https://gitlab.gnome.org/GNOME/mutter/issues/166.

intrigeri: Can you have a look at https://gitlab.gnome.org/GNOME/mutter/issues/166#note_174996 and tell me:

  • If I should close the upstream GNOME bug
  • What it would take to fix the launching of some of our applications. For example, the Tails documentation launcher on the desktop or the opening of Additional Software from the persistence settings.

#6 Updated by intrigeri 4 months ago

  • Assignee changed from intrigeri to sajolida
  • QA Check changed from Info Needed to Dev Needed
  • If I should close the upstream GNOME bug

Yes, this does not seem to be a bug in GNOME.

  • What it would take to fix the launching of some of our applications. For example, the Tails documentation launcher on the desktop or the opening of Additional Software from the persistence settings.

I'm no expert in this field but I think it may depend on the application. In many cases adding a (correct) StartupWMClass= field in the .desktop file should be enough (examples I bet the two examples you're providing fall into this category. To test this, use xprop to get the WM_CLASS of the main app window, set StartupWMClass= in the .desktop file to this value, and retry launching the app from the launcher.

In some rarer cases some coding may be needed.

#7 Updated by sajolida 4 months ago

  • Related to Feature #14544: Spend software developer time on smallish UX improvements added

#8 Updated by sajolida 4 months ago

  • Subject changed from No feedback when opening some applications to Add feedback when opening desktop launchers
  • Assignee deleted (sajolida)
  • QA Check deleted (Dev Needed)
  • Type of work changed from Research to Code

Thanks for the additional information!

Here is what I tried:

  • Edit ~/Desktop/tails-documentation.desktop
  • Changed Exec= to localc
  • Added StartupWMClass=libreoffice-calc as per the examples in codesearch.debian.org and the info I get from xprop

But I still get no spinner when clicking on "Tails documentation" on the desktop (unlike when I click "Home" or "Trash" on the desktop).

I don't want to dive into this deeper myself but I'm renaming this ticket to narrow its scope.

#9 Updated by intrigeri 3 months ago

On top of StartupWMClass= one must add StartupNotify=true to the .desktop file and then run gnome-shell --replace to invalidate the cache.

#10 Updated by intrigeri 3 months ago

  • Assignee set to sajolida
  • QA Check set to Info Needed

I felt the need to fix the startup notification for Tor Browser while working on #15023 (I believed it was a regression, and then noticed that even on Tails 3.8 there's no feedback when starting the browser, oh my) and while I was at it I've fixed it for the desktop launchers too. Now I'm not sure how to update the metadata here: I'm confused by the repeated changes of scope of this ticket. Is is on purpose that it's currently only about the desktop launchers?

#11 Updated by intrigeri 3 months ago

  • Status changed from Confirmed to In Progress

#12 Updated by sajolida 2 months ago

  • Assignee changed from sajolida to intrigeri

Yeap. Let's say that this ticket is only about the desktop launchers.

I created #15738 to test the stuff we have in the Applications menu.

#13 Updated by intrigeri about 2 months ago

  • Related to Bug #15738: Test feedback when opening applications from the Applications menu added

#14 Updated by intrigeri about 2 months ago

  • Description updated (diff)

#15 Updated by intrigeri about 2 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • Target version set to Tails_3.9
  • % Done changed from 0 to 100
  • Parent task changed from #14548 to #15023
  • QA Check deleted (Info Needed)

#16 Updated by intrigeri about 2 months ago

  • Blocks Feature #14548: Fix issues identified in the expert review done by jaster on our installation instructions added

#17 Updated by intrigeri about 2 months ago

  • Description updated (diff)

#18 Updated by intrigeri about 2 months ago

  • Blocks deleted (Feature #14548: Fix issues identified in the expert review done by jaster on our installation instructions)

#19 Updated by intrigeri about 2 months ago

  • Status changed from Resolved to In Progress
  • Assignee set to intrigeri
  • Parent task changed from #15023 to #14548
  • QA Check set to Pass

#20 Updated by intrigeri about 2 months ago

  • Blocked by Feature #15023: Upgrade to Tor Browser based on Firefox ESR60 added

#21 Updated by u about 2 months ago

  • Related to Feature #15546: Feedback needed when clicking on Persistence wizard → configure ASP gear button added

#22 Updated by intrigeri about 1 month ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)
  • Feature Branch set to feature/15023-tor-browser-8

#23 Updated by intrigeri 18 days ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF