Project

General

Profile

Bug #15406

Feature #10034: Translation web platform

Backup Weblate configuration

Added by u 7 months ago. Updated 16 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
03/13/2018
Due date:
% Done:

0%

QA Check:
Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

Before the Weblate update and even systematically we should backup the weblate configuration somehow. Maybe it can be saved to translate-server.git or anywhere sysadmin internally?


Related issues

Related to Tails - Bug #15651: Make sure we push Weblate's Git repo to https://git-tails.immerda.ch/weblate/tails/ once a day Rejected 06/12/2018

History

#1 Updated by u 7 months ago

/var/lib/weblate/config/settings.py parts of the config are here. For now I will simply backup this file in out git repo.

#2 Updated by u 7 months ago

  • Subject changed from Create a script to export Weblate configuration to Backup Weblate configuration
  • Assignee set to u

#3 Updated by bertagaz 5 months ago

  • Target version changed from Tails_3.7 to Tails_3.8

#4 Updated by u 4 months ago

  • Description updated (diff)
  • Assignee changed from u to groente

#5 Updated by u 4 months ago

At the meeting yesterday we also said

- we need to push Weblate's git repo to immerda.ch
- we need to backup the database because it contains the suggestions made by translators

before any update.

#6 Updated by u 4 months ago

  • Related to Bug #15651: Make sure we push Weblate's Git repo to https://git-tails.immerda.ch/weblate/tails/ once a day added

#7 Updated by intrigeri 4 months ago

  • Target version changed from Tails_3.8 to Tails_3.9

#8 Updated by groente 3 months ago

  • Status changed from Confirmed to Resolved

the settings.py file is now part of puppet-tails.
automysqlbackup is running on translate to ensure database backups.

#9 Updated by intrigeri 3 months ago

  • Status changed from Resolved to In Progress

the settings.py file is now part of puppet-tails.

Is it on purpose that this includes a password?

automysqlbackup is running on translate to ensure database backups.

We've had daily dumps of the DB (search for "backup" in tails::weblate) basically since it exists. Do you mean we now have a second set of local backups?

#10 Updated by groente 3 months ago

well, fuck. no. rolled back and password reset. thanks for the catch!

#11 Updated by intrigeri about 1 month ago

  • Target version changed from Tails_3.9 to Tails_3.10

#12 Updated by groente 21 days ago

  • Status changed from In Progress to Resolved

settings.py is now based on a puppet template and stored in git.

#13 Updated by intrigeri 16 days ago

  • Target version changed from Tails_3.10 to Tails_3.9.1

Also available in: Atom PDF