Project

General

Profile

Feature #5479

Bridge support

Added by Tails about 5 years ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Tor configuration
Target version:
-
Start date:
07/25/2013
Due date:
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Code
Starter:
No
Affected tool:

Subtasks

Feature #6192: bridge dialog at Vidalia startupDuplicate

Feature #5920: Tor bridges support: complete phase oneResolved

Feature #5287: tails-greeter: bridge optionResolved

Feature #5305: better bridges support in VidaliaRejected

Bug #6843: Write design documentation for Tor bridges supportResolved

Bug #6882: The Greeter's "more options" screen does not fit in a 600px height displayResolved

Bug #6885: Picking a non-English locale breaks bridge modeResolved

Bug #6934: Tor Launcher should not pretend we ship a default set of bridgesResolved

Bug #6935: The gray frame around the Greeter options needs inner marginResolved

Feature #6839: Tor bridges support: complete phase twoResolvedanonym

Feature #6305: Write tests for Tor bridgesResolved

Bug #6844: Hide Vidalia's Tor bridges settingsRejected

Feature #6840: Upstream our Tor Launcher changesResolved

Bug #7282: Tor Launcher: Don't relabel finish button when not owning Tor.Rejectedanonym

Bug #7283: Use upstream solution for Tor Launcher: Set ClientTransportPlugin according to the bridge entriesResolved

Feature #7620: Drop Tor Launcher patch that relabels the finish buttonResolved


Related issues

Related to Tails - Bug #6986: Repeated prompt for simple vs. complex Tor configuration Duplicate 03/29/2014
Related to Tails - Bug #6985: Allows configuring unworkable combination of outbound port filtering + obfsproxy Resolved 03/28/2014
Related to Tails - Bug #6893: Skip the first screen of Tor Launcher Confirmed 03/10/2014

History

#1 Updated by intrigeri about 5 years ago

  • Type of work set to Code

Type of work: Code

#2 Updated by intrigeri almost 5 years ago

  • Assignee set to anonym
  • Starter set to No

#3 Updated by intrigeri over 4 years ago

  • Related to Bug #6986: Repeated prompt for simple vs. complex Tor configuration added

#4 Updated by intrigeri over 4 years ago

  • Related to Bug #6985: Allows configuring unworkable combination of outbound port filtering + obfsproxy added

#5 Updated by intrigeri over 4 years ago

  • Related to Bug #6893: Skip the first screen of Tor Launcher added

#6 Updated by BitingBird over 4 years ago

  • Subject changed from bridge support to Bridge support
  • Status changed from Confirmed to In Progress

#7 Updated by anonym over 4 years ago

  • Target version changed from Tails_1.0 to Tails_1.1

#8 Updated by intrigeri over 4 years ago

  • Category set to Tor configuration

#9 Updated by anonym over 4 years ago

  • Target version deleted (Tails_1.1)

Dropping target version, #5920 is the goal of 1.1 w.r.t. bridges support.

#10 Updated by BitingBird about 3 years ago

  • Status changed from In Progress to Resolved

Marking as resolved, since all children tickets are. If it's wrong, please reopen and clarify the next thing to do :)

Also available in: Atom PDF