Project

General

Profile

Bug #5677

Tails Installer should not break emergency shutdown

Added by Tails almost 5 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Installation
Target version:
Start date:
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
bugfix/12354-drop-kexec-memory-wipe
Type of work:
Test
Blueprint:
Starter:
No
Affected tool:
Installer

Description

sajolida reports:

  • it seems to happen after using the liveusb-creator
  • it happened on both Tails 0.10.1 and Tails experimental
  • sometimes it happens while doing:
    • boot Tails experimental on a isohybrid
    • "Clone Tails" onto another stick
    • unplug the running Tails
  • sometimes the screen turns black with a cursor on the top-left corner and nothing else
  • sometimes the screen stays the same, the system is still somehow responsive but doesn't shutdown
  • once I couldn't even shutdown with the red button or by doing sudo halt in a terminal once I reached this weird state
  • once I checked and udev-watchdog was still running on the right device but the emergency shutdown still didn't work

intrigeri confirms: On VT1, when unplugging my boot USB stick, I see various lines about sdb3, sdb2 and sdb1 being removed, followed by "Bus error". Nothing more happens, and the udev watchdog process is not there anymore.

research


Related issues

Related to Tails - Feature #7194: Check the status of #5447 and #5677 and update /doc/first_steps/shutdown/ accordingly Resolved

History

#1 Updated by anonym almost 5 years ago

  • QA Check set to Info Needed
  • Starter set to No

For the record, I haven't been able to reproduce this for a year or so on any of my hardware. Is any one else still experiencing this?

#2 Updated by intrigeri almost 5 years ago

For the record, I haven't been able to reproduce this for a year or so on any of my
hardware. Is any one else still experiencing this?

Yes, I do.

#3 Updated by intrigeri almost 5 years ago

  • Tracker changed from Feature to Bug
  • QA Check changed from Info Needed to Dev Needed
  • Type of work changed from Research to Code

#4 Updated by intrigeri about 4 years ago

  • Related to Feature #7194: Check the status of #5447 and #5677 and update /doc/first_steps/shutdown/ accordingly added

#5 Updated by intrigeri about 4 years ago

Still reproducible, as reported on #7194, in a build very close to Tails 1.1~rc1.

#6 Updated by BitingBird about 4 years ago

  • Subject changed from liveusb-creator should not break emergency shutdown to Liveusb-creator should not break emergency shutdown

#7 Updated by BitingBird about 4 years ago

  • Subject changed from Liveusb-creator should not break emergency shutdown to liveusb-creator should not break emergency shutdown

#8 Updated by sajolida about 4 years ago

  • Category set to Installation

#9 Updated by BitingBird over 3 years ago

  • Affected tool set to Installer

#10 Updated by BitingBird over 3 years ago

  • QA Check deleted (Dev Needed)

#11 Updated by intrigeri over 2 years ago

  • Subject changed from liveusb-creator should not break emergency shutdown to Tails Installer should not break emergency shutdown

#12 Updated by BitingBird about 2 years ago

  • Type of work changed from Code to Test

Should be tested again with a 2.x

#13 Updated by intrigeri about 1 year ago

  • Status changed from Confirmed to In Progress
  • Assignee set to anonym
  • Target version set to Tails_3.0~rc1
  • QA Check set to Ready for QA
  • Feature Branch set to bugfix/12354-drop-kexec-memory-wipe

I can't reproduce this on my branch for #12354 (not tested on earlier 3.0~betaN though):

  1. start Tails from a USB stick installed with Tails Installer
  2. plug a 2nd USB stick
  3. Clone and Install to that 2nd USB stick
  4. unplug the boot device
  5. Tails successfully shuts down

#14 Updated by anonym about 1 year ago

  • % Done changed from 0 to 100

FYI I haven't been able to reproduce this for years on any of my systems (or in VMs).

See #12354 for the review (no blockers found). Please close when you merge!

#15 Updated by anonym about 1 year ago

  • Assignee changed from anonym to intrigeri
  • QA Check changed from Ready for QA to Pass

#16 Updated by intrigeri about 1 year ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)

#17 Updated by intrigeri about 1 year ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF