Project

General

Profile

Feature #5739

Support UEFI boot

Added by Tails over 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Hardware support
Target version:
Start date:
10/03/2013
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
feature/uefi
Type of work:
Code
Starter:
No
Affected tool:

Subtasks

Feature #6529: Add a Tails icon for rEFIndResolvedintrigeri

Feature #6561: Have initial UEFI support tested on a wide range of hardwareResolvedintrigeri

Feature #6577: Convert existing Tails devices to UEFI on full upgradeResolved

Feature #7059: Call for testing current UEFI experimental supportResolvedintrigeri

Feature #7160: Use the new logo in the rEFInd iconResolvedintrigeri

Feature #7230: Update the most important bits of documentation wrt. UEFI supportResolved

Feature #7084: Persistence support on MacResolved

Feature #6242: UEFI boot on Mac without rEFIndResolved

Feature #6331: Test how well Tails works after using hellais installation scripts for MacRejected

Feature #7280: Document that boot in older VirtualBox is broken in Tails 1.1Resolved


Related issues

Related to Tails - Feature #6563: Backport syslinux 6.x for Wheezy Rejected 01/02/2014
Related to Tails - Feature #7231: Test suite: UEFI boot Resolved 07/18/2014
Related to Tails - Feature #8471: Support 32-bit UEFI boot Resolved 07/07/2015
Blocked by Tails - Feature #5456: amd64 kernel Resolved
Blocks Tails - Feature #6560: UEFI Secure boot Confirmed 01/02/2014

History

#1 Updated by akuckartz about 5 years ago

"Now that The Linux Foundation is a member of the UEFI.org group, I’ve been working on the procedures for how to boot a self-signed Linux kernel on a platform so that you do not have to rely on any external signing authority.

"After digging through the documentation out there, it turns out to be relatively simple in the end, so here’s a recipe for how I did this, and how you can duplicate it yourself on your own machine."

Booting a Self-signed Linux Kernel
Greg Kroah-Hartman, 2013-09-03
http://www.kroah.com/log/blog/2013/09/02/booting-a-self-signed-linux-kernel/

#2 Updated by intrigeri about 5 years ago

"Now that The Linux Foundation is a member of the UEFI.org group, I’ve been working
on the procedures for how to boot a self-signed Linux kernel on a platform so that
you do not have to rely on any external signing authority.

"After digging through the documentation out there, it turns out to be relatively
simple in the end, so here’s a recipe for how I did this, and how you can duplicate
it yourself on your own machine."

Booting a Self-signed Linux Kernel
Greg Kroah-Hartman, 2013-09-03
http://www.kroah.com/log/blog/2013/09/02/booting-a-self-signed-linux-kernel/

Just so you know, this useful content would be better suited for the
blueprint. A wiki is more appropriate, to organize such input data,
than a pile of dozens of comments on a ticket. Thanks!

#3 Updated by akuckartz about 5 years ago

A wiki is more appropriate, to organize such input data,
than a pile of dozens of comments on a ticket.

That requires that the Wiki can be edited. Unfortunately I have not yet seen a reply to my mail to sent about a month ago regarding the broken password reset.

#4 Updated by intrigeri about 5 years ago

That requires that the Wiki can be edited.

We happily take pull requests.

Unfortunately I have not yet seen a reply to my mail to
sent about a month ago regarding the broken
password reset.

I'm sorry about that.

#5 Updated by intrigeri about 5 years ago

  • Category set to Hardware support
  • Starter set to No

#6 Updated by intrigeri almost 5 years ago

  • Feature Branch set to feature/uefi

#8 Updated by intrigeri over 4 years ago

  • Subject changed from UEFI to Support UEFI boot

#9 Updated by intrigeri over 4 years ago

  • Type of work changed from Upstream to Code

#10 Updated by intrigeri over 4 years ago

#11 Updated by intrigeri over 4 years ago

  • Target version changed from Sustainability_M1 to Tails_1.1

All subtasks were reorganized so that only the goals for 1.1 are tracked here.

#12 Updated by intrigeri over 4 years ago

  • Blocks deleted (Feature #6242: UEFI boot on Mac without rEFInd)

#13 Updated by intrigeri over 4 years ago

  • Assignee set to intrigeri

#14 Updated by intrigeri over 4 years ago

  • Status changed from Confirmed to In Progress

#15 Updated by intrigeri over 4 years ago

  • Assignee changed from intrigeri to sajolida
  • QA Check set to Ready for QA

#16 Updated by sajolida over 4 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (sajolida)
  • QA Check changed from Ready for QA to Pass

#17 Updated by BitingBird about 4 years ago

  • Status changed from Fix committed to Resolved

#18 Updated by intrigeri almost 4 years ago

Also available in: Atom PDF