Project

General

Profile

Feature #5959

Feature #5690: Test suite: anti-tests

better antitesting of memory erasure

Added by Tails over 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
test/5959-antitest-memory-erasure
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

code the anti-test of checking that, without erasing memory, we can retrieve the known pattern. Just as we do manually.


Related issues

Blocks Tails - Feature #6106: test suite: erase memory feature Resolved
Blocked by Tails - Feature #6399: Finish the Rjb migration Resolved 11/03/2013

History

#1 Updated by Tails over 5 years ago

  • Parent task set to #5690

#2 Updated by intrigeri about 5 years ago

  • Category set to Test suite
  • Starter set to No

#3 Updated by intrigeri almost 5 years ago

  • Status changed from Confirmed to In Progress
  • Assignee set to intrigeri
  • % Done changed from 0 to 10
  • Feature Branch set to test/5959-antitest-memory-erasure

#4 Updated by intrigeri almost 5 years ago

  • % Done changed from 10 to 50

#5 Updated by intrigeri almost 5 years ago

  • Assignee changed from intrigeri to bertagaz
  • QA Check set to Ready for QA

Done, works for me.

#6 Updated by intrigeri over 4 years ago

  • Target version set to Tails_0.23

#7 Updated by intrigeri over 4 years ago

Reassigning to the current RM.

#8 Updated by intrigeri over 4 years ago

  • Assignee changed from bertagaz to anonym

#9 Updated by anonym over 4 years ago

  • Assignee changed from anonym to intrigeri
  • QA Check changed from Ready for QA to Dev Needed
+  def reset
+    # ruby-libvirt 0.4 does not support the reset method.
+    # XXX: Once we use Jessie, use @domain.reset instead.
+    system("virsh reset " + @domain_name) if is_running?
+  end

For whatever reason, the TailsToaster domain isn't present for me (also checked with virsh list), so I get the following error in both anti-tests:

     When I fill the guest's memory with a known pattern without verifying # features/step_definitions/erase_memory.rb:78

error: failed to get domain 'TailsToaster'
error: An error occurred, but the cause is unknown

    And I reboot without wiping the verifying # features/step_definitions/erase_memory.rb:78

error: failed to get domain 'TailsToaster'
error: An error occurred, but the cause is unknown

    And I reboot without wiping the memory                                # features/step_definitions/erase_memory.rb:159

      FindFailed: can not find TailsBootSplashPostReset.png on the screen.
      Line ?, in File ? (RuntimeError)

If I switch back to sysrq-resetting (revert commit 443d2d9) it works memory # features/step_definitions/erase_memory.rb:159

FindFailed: can not find TailsBootSplashPostReset.png on the screen.
Line ?, in File ? (RuntimeError)

If I switch back to sysrq-resetting (revert commit 443d2d9) it works fine.

#10 Updated by intrigeri over 4 years ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 50 to 60
  • QA Check changed from Dev Needed to Ready for QA

Should be fixed by commit 0caac4a2.

#11 Updated by intrigeri over 4 years ago

  • Assignee changed from anonym to intrigeri

Testing and replying to other anonym's notes on this branch.

#12 Updated by intrigeri over 4 years ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 60 to 80

#13 Updated by anonym over 4 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 80 to 100
  • QA Check changed from Ready for QA to Pass

Merged!

#14 Updated by anonym over 4 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF