Feature #6275

Bug #5518: Make the system disk read-only

Bug #6172: Fix write access to boot medium via udisks

Automatically test write access to the boot block device via udisks

Added by intrigeri almost 4 years ago. Updated about 3 years ago.

Status:ResolvedStart date:09/11/2013
Priority:HighDue date:
Assignee:-% Done:

100%

Category:Test suite
Target version:Tails_1.1
QA Check:Pass Blueprint:
Feature Branch:test/6275-boot-device-write-access-via-udisks Easy:No
Type of work:Code Affected tool:

Description

Our automated test suite should make sure #6172 is indeed fixed.

History

#1 Updated by intrigeri almost 4 years ago

  • Category changed from Continuous Integration to Test suite

#2 Updated by intrigeri almost 4 years ago

  • Subject changed from Test write access to the boot block device via udisks to Automatically test write access to the boot block device via udisks

#3 Updated by intrigeri over 3 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 20

Something like this should do the trick (patch based on current test/rjb-migration branch):

--- a/features/step_definitions/usb.rb
+++ b/features/step_definitions/usb.rb
@@ -336,6 +336,10 @@ Then /^the boot device has safe access rights$/ do
              "owns boot device '#{dev}'")
     end
   end
+
+  info = @vm.execute("udisks --show-info #{super_boot_dev}").stdout
+  assert(info.match("^  system internal: +1$"),
+         "Boot device '#{super_boot_dev}' is not system internal for udisks")
 end

 Then /^persistent filesystems have safe access rights$/ do

#4 Updated by intrigeri over 3 years ago

  • Assignee set to intrigeri

#5 Updated by intrigeri over 3 years ago

  • % Done changed from 20 to 30
  • Feature Branch set to test/6275-boot-device-write-access-via-udisks

#6 Updated by intrigeri over 3 years ago

#7 Updated by intrigeri over 3 years ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 30 to 50
  • QA Check set to Ready for QA

Done, works for me. Based on the current state of test/6559-adapt-test-suite-for-Wheezy.

#8 Updated by intrigeri over 3 years ago

  • Blocked by deleted (Feature #6559: Adapt test suite for Wheezy)

#9 Updated by intrigeri over 3 years ago

  • Target version set to Tails_1.1

#10 Updated by anonym over 3 years ago

  • Assignee changed from anonym to intrigeri
  • QA Check changed from Ready for QA to Pass

The branch history has been rewritten. See "[review'n'merge:1.1] #6559, #7062, #6275: test/6559-adapt-test-suite-for-Wheezy" on tails-dev@.

Please tag as "Fix committed" when #6559's test/6559-adapt-test-suite-for-Wheezy (which has this branch merged) is merged into devel.

#11 Updated by intrigeri about 3 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)
  • % Done changed from 50 to 100

#12 Updated by BitingBird about 3 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF