Project

General

Profile

Feature #6342

Feature #6015: Tails based on Wheezy

Update Windows camouflage for GNOME3

Added by intrigeri about 4 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Camouflage
Target version:
Start date:
05/23/2014
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
feature/6342-update-camouflage-for-gnome3
Type of work:
Code
Easy:
No
Affected tool:

Description

See the blueprint for the research work on this.

tails-experimental-20140520.png View (241 KB) alant, 05/20/2014 07:50 AM

commit-c4e781a.png View - Tails' win8 theme as of commit c4e781a (68.3 KB) anonym, 05/21/2014 09:15 AM

tails-experimental-20140522.png View (135 KB) alant, 05/22/2014 01:48 PM

real-windows-8.1.png View (90.4 KB) anonym, 05/23/2014 05:46 AM

firefox-29.0.1-in-win-8.1.png View (68 KB) anonym, 05/27/2014 03:09 AM

win8.1-icons.png View - Icons: Start button, File explorer, Firefox, IE10, Mail, People, Office, Skype (9.33 KB) anonym, 05/27/2014 04:05 AM

iexplore.ico View (4.19 KB) anonym, 05/27/2014 04:12 AM

fileexplorer.ico View (4.19 KB) anonym, 05/27/2014 04:12 AM

office.ico View (4.19 KB) anonym, 05/27/2014 04:12 AM

commit-e8c147e.png View - Windows Camouflage as of commit e8c147e (262 KB) anonym, 05/27/2014 02:21 PM

commit-5d6d110.png View - Windows Camouflage as of commit 5d6d110 (252 KB) anonym, 05/27/2014 03:45 PM

Screenshot_tails-experimental_2014-06-10_14_12_38.cleaned.png View (81.9 KB) alant, 06/10/2014 05:17 AM

commit-6b4e790.png View (481 KB) anonym, 06/12/2014 03:47 PM


Subtasks

Feature #7273: Update greeter for windows 8 camouflageResolved

Feature #7274: Decide if torbrowser camouflage is still neededResolved

Feature #7275: Fix shutdown applet size in camouflage modeRejected

Feature #7276: Implement theme for windows camouflageResolved

Feature #7277: Port camouflage to Gnome 3 panelResolved

Feature #7312: Include window-picker-appletResolved

Feature #7364: Audit window-picker-appletResolvedalant

Bug #7325: Fix application icons in "task list" in Windows 8 camouflageResolved

Bug #7326: Fix systray icons in Windows 8 camouflageResolved

Bug #7328: Make clock applet font white again in Windows 8 camouflage.Resolved

Bug #7366: Windows Camouflage's toolbars are grey instead of whiteResolved

Feature #7367: Update web browser's Windows camouflage for Windows 8Resolved

Bug #7381: Remove launchers in camouflage modeResolved

Bug #7398: Fix battery systray icons in Windows 8 camouflageResolved

Bug #7407: Set at least icon theme before gnome-settings-daemon startResolved

Bug #7382: Customized icons are way too small in the applications menuResolved

Bug #7329: Adapt the Unsafe Browser for the Windows 8 camouflageResolved

Bug #7395: New visual indicator for Unsafe Browser in Windows 8 camouflage?Rejected

Bug #7401: Fix web browser's close tab buttons in Windows 8 camouflageResolved

Bug #7321: There should be a home launcher in camouflage modeRejectedalant


Related issues

Related to Tails - Feature #6055: Better imitated start menu in Windows camouflage mode Resolved
Related to Tails - Feature #7377: Improve Windows 8 camouflage Confirmed 04/24/2014
Duplicated by Tails - Feature #7222: Windows 7 Camouflage Skin Duplicate 05/12/2014
Duplicated by Tails - Feature #5896: Newer Windows theme Duplicate
Blocks Tails - Feature #7360: Update screenshot and documentation for Windows 8 camouflage Resolved 06/01/2014

History

#1 Updated by intrigeri over 3 years ago

  • Assignee set to alant

#2 Updated by intrigeri over 3 years ago

  • Target version set to Tails_1.1

#3 Updated by intrigeri over 3 years ago

  • Status changed from Confirmed to In Progress

#4 Updated by alant over 3 years ago

  • % Done changed from 0 to 20
  • Feature Branch set to feature/6342-update-camouflage-for-gnome3

#5 Updated by intrigeri over 3 years ago

  • Related to Feature #6055: Better imitated start menu in Windows camouflage mode added

#6 Updated by intrigeri over 3 years ago

#7 Updated by intrigeri over 3 years ago

  • QA Check set to Dev Needed

I have tested this branch. The freeze is coming fast, and there seems to be quite some work left on this task. Here's what seems to be wrong or missing:

  • the start menu has a Debian logo
  • there's a Logout button in the start menu, while we hide it (on purpose) in the regular GNOME session
  • the panel has a black background, which feels wrong (is it the same on Win8?)
  • there is no desktop notification displayed, and I cannot find the status icons
  • there is no application launcher
  • the GTK theme is ugly. Is it really the same in Win8?
  • there doesn't seem to be a IE theme applied to the web browser
  • is the window decoration theme that ugly in Win8?

I can create subtasks for each of these, if you confirm within 24h that they are actual problems.

#8 Updated by anonym over 3 years ago

Any update on this, alant? If needed I could perhaps help with parts of it, although I won't be able to promise too much due to my RM commitments.

#9 Updated by alant over 3 years ago

#10 Updated by alant over 3 years ago

the start menu has a Debian logo

The start menu has an ubuntu logo. That should be solved.

there's a Logout button in the start menu, while we hide it (on purpose) in the regular GNOME session

That should be solved.

the panel has a black background, which feels wrong (is it the same on Win8?)

That is solved.

there is no desktop notification displayed, and I cannot find the status icons

I can't reproduce this issue.

there is no application launcher

That is solved.

the GTK theme is ugly. Is it really the same in Win8?

That is solved.

there doesn't seem to be a IE theme applied to the web browser

That should be solved.

is the window decoration theme that ugly in Win8?

Yes.

Current status :

#11 Updated by alant over 3 years ago

The sources for the theme is at http://git.tails.boum.org/gnome-theme-windows8/.

#12 Updated by anonym over 3 years ago

See attachment for how a build from the current state (commit c4e781a) looks. Note that this is after I log out and in, otherwise some stuff is not applied (e.g. the start menu button isn't shown). However, the icon theme is still not applied, and a non-existent background is set (did you forget to git add the picture in commit c4e781a?). Also, the text color in the terminal is the same as the background color, black, so it's pretty much useless.

I notice an Ubuntu icon for the start menu in your screenshot, but I get the Debian swirl. Are you actually testing your script in Tails, or in Ubuntu?

#13 Updated by alant over 3 years ago

The basics looks OK.

Left to do:

- iceweasel/torbrowser theme?
- windows picker applet (https://github.com/lanoxx/window-picker-applet/)?
- shutdown applet size

#14 Updated by alant over 3 years ago

I merged the current state in experimental to ease testing and feedback.

#15 Updated by anonym over 3 years ago

#17 Updated by alant over 3 years ago

Some comments and suggestions about the panel (recieved on tails-dev):

  • The current icon for Iceweasel is the IE6/7 icon from XP, but it
    looks different in Windows 8. See my screenshot.
  • The icons for pidgin and claws should be changed to those of the
    People (or Skype) and Mail apps, respectively, like in my screenshot.
    Or they should be removed, which perhaps is the simplest.
  • The icons for KeyPassX and GNOME terminal should be removed. There
    are no immediate common applications corresponding to these.
  • Possibly we can add a launcher for the home directory, as the
    left-most one, which seems to be the default in Windows 8/8.1.
  • Can we remove the "separators" (or whatever those lightblue, "dotty"
    things are calleD) on the left and right of the tasks?
  • The shutdown applet is actually quite stealthy as it is (size and
    color), but it'd be better if it could be moved to between the system
    tray and the clock applet. On windows the clock seems to always be
    touching the right edge of the screen.
  • The clock applet's text should be white.
  • The Vidalia icon in the system tray has a weird grey rectangle
    beneath it. Can we remove it?
  • Can we make the icons in the system tray smaller? The size of
    Vidalia's and the shutdown applet icon are pretty good.

Also, about the desktop: it seems the only thing there by default is the
Recycle Bin, so we should remove everything else, IMHO.

#18 Updated by anonym over 3 years ago

#19 Updated by anonym over 3 years ago

Some proper icons, with transparency.

#20 Updated by alant over 3 years ago

  • Assignee changed from alant to anonym
  • QA Check changed from Dev Needed to Ready for QA
  • The current icon for Iceweasel is the IE6/7 icon from XP, but it
    looks different in Windows 8. See my screenshot.

Done.

  • The icons for pidgin and claws should be changed to those of the
    People (or Skype) and Mail apps, respectively, like in my
    screenshot. Or they should be removed, which perhaps is the simplest.

Done.

  • The icons for KeyPassX and GNOME terminal should be removed. There
    are no immediate common applications corresponding to these.

Done.

  • Possibly we can add a launcher for the home directory, as the
    left-most one, which seems to be the default in Windows 8/8.1.

Done, but it's not (yet) the exact right icon.

  • Can we remove the "separators" (or whatever those lightblue, "dotty"
    things are calleD) on the left and right of the tasks?

I fail to find how to theme or remove that (without patching
gnome-panel)

  • The shutdown applet is actually quite stealthy as it is (size and
    color), but it'd be better if it could be moved to between the
    system tray and the clock applet. On windows the clock seems to
    always be touching the right edge of the screen.

Done.

  • The clock applet's text should be white.

Done.

  • The Vidalia icon in the system tray has a weird grey rectangle
    beneath it. Can we remove it?

Not achieved.

  • Can we make the icons in the system tray smaller? The size of
    Vidalia's and the shutdown applet icon are pretty good.

There is a CSS property for that:

NaTrayApplet {
-NaTrayApplet-icon-size: 20px;
-NaTrayApplet-icon-padding: 1;
}

But it's unfortunately not applied in wheezy. I'm giving up.

Also, about the desktop: it seems the only thing there by default is
the Recycle Bin, so we should remove everything else, IMHO.

Done.

#21 Updated by anonym over 3 years ago

#22 Updated by anonym over 3 years ago

I've pushed two fixes:

  • f754d4c Install window-picker-applet.
  • 5d6d110 Set GNOME panel height after adding applets.

Attached is a screenshot of the current state of the branch.

#23 Updated by anonym over 3 years ago

  • QA Check changed from Ready for QA to Dev Needed

I've merged the current state of the branch for 1.1~beta1. See child tickets for why "Dev [is] Needed".

#24 Updated by anonym over 3 years ago

  • Assignee changed from anonym to alant

#25 Updated by anonym over 3 years ago

  • Blocked by Bug #7329: Adapt the Unsafe Browser for the Windows 8 camouflage added

#26 Updated by sajolida over 3 years ago

  • Blocks Feature #7360: Update screenshot and documentation for Windows 8 camouflage added

#27 Updated by alant over 3 years ago

Created #7377 to regroup camouflage tasks that sould be done after 1.1.

#28 Updated by intrigeri over 3 years ago

#29 Updated by BitingBird over 3 years ago

#30 Updated by BitingBird over 3 years ago

  • Related to Feature #5530: Don't display the splash screen for some applications in Windows Camouflage mode added

#31 Updated by BitingBird over 3 years ago

  • Related to Feature #5974: Reuse installed Windows wallpaper added

#32 Updated by BitingBird over 3 years ago

  • Related to Bug #7122: Desktop icons are not translated in Windows camouflage added

#33 Updated by alant over 3 years ago

I belive identified blockers are fixed and this is ready for QA again.

!Screenshot_tails-experimental_2014-06-10_14:12:38.cleaned.png!

#34 Updated by alant over 3 years ago

  • Related to deleted (Feature #5530: Don't display the splash screen for some applications in Windows Camouflage mode)

#35 Updated by alant over 3 years ago

  • Related to deleted (Feature #5974: Reuse installed Windows wallpaper)

#36 Updated by alant over 3 years ago

  • Related to deleted (Bug #7122: Desktop icons are not translated in Windows camouflage)

#37 Updated by anonym over 3 years ago

  • Category set to Camouflage

#38 Updated by anonym over 3 years ago

#39 Updated by intrigeri over 3 years ago

  • Blocked by deleted (Bug #7329: Adapt the Unsafe Browser for the Windows 8 camouflage)

#40 Updated by anonym over 3 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • QA Check changed from Ready for QA to Pass

Awesome work, alant! This is now merged! #7377 next! ;)

#41 Updated by BitingBird about 3 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF