Project

General

Profile

Bug #6432

WhisperBack launcher in the applications menu should give a hint about its function

Added by alant over 4 years ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
11/22/2013
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
whisperback:feature/update-description
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:
WhisperBack

Description

Current menu entry for WhisperBack is "WhisperBack" which is unclear. We should replace it by "Report a bug", "Send feedback", or something similar.

0001-Changed-name-in-menu-to-WhisperBack-Error-Reporting-.patch View (696 Bytes) sascha.markus@gmail.com, 05/29/2018 07:48 PM

Associated revisions

Revision c9c673aa (diff)
Added by intrigeri about 1 month ago

Update WhisperBack launcher name (refs: #6432).

History

#1 Updated by intrigeri over 4 years ago

Current menu entry for WhisperBack is "WhisperBack" which is unclear. We should
replace it by "Report a bug", "Send feedback", or something similar.

FWIW, I think the wording we've agreed upon is "Report an error" or
similar (see the desktop launcher).

#2 Updated by intrigeri over 4 years ago

  • Subject changed from WhisperBack lanucher should give a hint on its use to WhisperBack launcher should give a hint on its use

#3 Updated by intrigeri over 4 years ago

  • Type of work changed from User interface design to Code

I don't think this is really a UI _design_ task, merely a string to change somewhere in a .desktop file so that this menu entry is consistent with the desktop launcher, which I call a coding task.

#4 Updated by alant over 4 years ago

  • Category set to 174
  • Status changed from New to Confirmed
  • Assignee set to alant
  • % Done changed from 0 to 50
  • Feature Branch set to whisperback:feature/update-description

Implemented in whisperback:feature/update-description.

#5 Updated by sajolida over 4 years ago

Having a look at the entries we have in our menus:

  • 1. Few applications only appears with their names (KeePassX, I2P).
  • 2. Many applications show their name plus their function (Iceweasel Web Browser, Brasero Disc Burner)
  • 3. Some other applications don't show their name but only their function (File Browser, Disk Utility). This last kind of applications are often system tools or core GNOME applications, that don't need to be named even if they have a name.

Regarding WhisperBack, I feel that having only "Report an error" in the menu wouldn't work. Because we won't be able to say "please report an error using WhisperBack" anymore to people, if WhisperBack looses its name by not appearing in the menu, like Palimpsest did for example.

So if we want to menu entry to be more explicit, we should move it from case 1 to case 2 by adding a function: "WhisperBack Error Reporter"? That sounds ugly :)

#6 Updated by intrigeri almost 4 years ago

  • % Done changed from 50 to 20
  • Type of work changed from Code to User interface design

sajolida wrote:

Regarding WhisperBack, I feel that having only "Report an error" in the menu wouldn't work. Because we won't be able to say "please report an error using WhisperBack" anymore to people, if WhisperBack looses its name by not appearing in the menu, like Palimpsest did for example.

So if we want to menu entry to be more explicit, we should move it from case 1 to case 2 by adding a function: "WhisperBack Error Reporter"? That sounds ugly :)

OK... so this really needs user interface design, in the end. Alan, will you go ask for advice to experts? Otherwise, please unassign this ticket from you.

#7 Updated by intrigeri almost 4 years ago

  • Subject changed from WhisperBack launcher should give a hint on its use to WhisperBack launcher in the applications menu should give a hint about its function

#8 Updated by alant almost 4 years ago

  • Assignee deleted (alant)

#9 Updated by sajolida almost 4 years ago

So if we want to menu entry to be more explicit, we should move it from case 1 to case 2 by adding a function: "WhisperBack Error Reporter"? That sounds ugly :)

Actually, "WhisperBack Error Reporting" is less ugly...

#10 Updated by BitingBird over 3 years ago

Shall we discuss this at the next meeting? Ask on tails-ux ? Something else ?

#11 Updated by sajolida over 3 years ago

  • Type of work changed from User interface design to Discuss

I read that thread again, and I'm still in favor of "WhisperBack Error Reporting".

Marking this as Discuss and adding to the next meeting.

#12 Updated by alant over 3 years ago

I read that thread again, and I'm still in favor of "WhisperBack Error Reporting".

I agree with the proposal.

#13 Updated by intrigeri over 3 years ago

I agree we need both the application name (WhisperBack) and an indication about its function (reporting errors).

I can live with "WhisperBack Error Reporting". I would maybe prefer "Error Reporting with WhisperBack" or "Report an Error with WhisperBack. I'm unsure.

#14 Updated by sajolida over 3 years ago

I proposed it this way for more consistency with the other available menu entries from Debian. Those are always pure substantives, with no verb nor prepositions.

The ones break that rule as of now are Tails specific. Namely "Configure persistent volume" and "Delete persistent volume". Or "Search for files...".

I'm not saying that we shouldn't break this convention, but let's do it consciously at least.

#15 Updated by bertagaz over 3 years ago

  • % Done changed from 20 to 30
  • Type of work changed from Discuss to Code

We decided at the February meeting to name it "WhisperBack Error Reporting".

#16 Updated by sascha.markus@gmail.com about 2 months ago

Here is a patch to change the Name in the application menu.

#17 Updated by sascha.markus@gmail.com about 2 months ago

  • File deleted (Screenshot_6432.png)

#18 Updated by intrigeri about 2 months ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from sajolida to intrigeri
  • Target version set to Tails_3.9
  • QA Check set to Ready for QA

#19 Updated by intrigeri about 1 month ago

  • % Done changed from 30 to 50

Looks good to me. We'll need to update wiki/src/doc/first_steps/bug_reporting.mdwn in lockstep so I'll cut out a new WhisperBack release and will adjusts the doc accordingly on the stable branch.

BTW, your patch made me realize that #6486 is still open. Perhaps you would be interested in working on it? If so, please assign that ticket to you :)

#20 Updated by intrigeri about 1 month ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)
  • Target version changed from Tails_3.9 to Tails_3.8
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

intrigeri wrote:

Looks good to me. We'll need to update wiki/src/doc/first_steps/bug_reporting.mdwn in lockstep so I'll cut out a new WhisperBack release and will adjusts the doc accordingly on the stable branch.

Uploaded, doc adjusted in stable and devel.

#21 Updated by intrigeri about 1 month ago

  • Status changed from Fix committed to In Progress

#22 Updated by intrigeri about 1 month ago

  • Status changed from In Progress to Fix committed
  • Target version changed from Tails_3.8 to Tails_3.7.1

#23 Updated by intrigeri about 1 month ago

  • Assignee set to BitingBird

#24 Updated by intrigeri about 1 month ago

  • Assignee deleted (BitingBird)

#25 Updated by intrigeri about 1 month ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF