Project

General

Profile

Bug #6468

Disable WebRTC

Added by sajolida almost 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
12/08/2013
Due date:
% Done:

0%

QA Check:
Pass
Feature Branch:
bugfix/6468-disable-webrtc
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:
Browser

Description

Visiting http://net.ipcalf.com/ with Tails 0.22~rc1 displays the local IP address. Pretty scary...
TBB has disable that option at compile time and we should do the same.

https://trac.torproject.org/projects/tor/ticket/8178


Related issues

Related to Tails - Feature #6370: Migrate to Iceweasel 24 Resolved 10/16/2013
Related to Tails - Feature #6474: Also use TorBrowser's mozconfig Resolved 12/09/2013

Associated revisions

Revision 8df851d7 (diff)
Added by Tails almost 5 years ago

Disable WebRTC (Closes: #6468).

On the long run, we want to do this at build time, just like the TorBrowser.
However, fiddling with the build options two days before a Tails release seems
crazy, so let's disable this with a pref for now.

Successfully tested on http://mozilla.github.io/webrtc-landing/ and
http://net.ipcalf.com/.

Revision 69216352 (diff)
Added by Tails almost 5 years ago

Disable WebRTC (Closes: #6468).

On the long run, we want to do this at build time, just like the TorBrowser.
However, fiddling with the build options two days before a Tails release seems
crazy, so let's disable this with a pref for now.

Successfully tested on http://mozilla.github.io/webrtc-landing/ and
http://net.ipcalf.com/.

History

#1 Updated by intrigeri almost 5 years ago

  • Assignee set to intrigeri

#2 Updated by intrigeri almost 5 years ago

Setting media.peerconnection.enabled to false seems to be enough.

#3 Updated by intrigeri almost 5 years ago

  • Feature Branch set to bugfix/6468-disable-webrtc

#4 Updated by intrigeri almost 5 years ago

  • Assignee changed from intrigeri to bertagaz
  • QA Check set to Ready for QA

#5 Updated by intrigeri almost 5 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (bertagaz)
  • QA Check changed from Ready for QA to Pass

Was tested, and the diff looked at, as part of the 0.22 test suite.

Also available in: Atom PDF