Feature #6559

Feature #6015: Tails based on Wheezy

Adapt test suite for Wheezy

Added by intrigeri over 3 years ago. Updated about 3 years ago.

Status:ResolvedStart date:04/11/2014
Priority:ElevatedDue date:
Assignee:-% Done:

100%

Category:Test suite
Target version:Tails_1.1
QA Check:Pass Blueprint:
Feature Branch:test/6559-adapt-test-suite-for-Wheezy Easy:No
Type of work:Code Affected tool:

Description

Almost all of features/images/* needs to be updated due to style, theme and fonts changes.

Also, this effort will help detect regressions in our port to Wheezy.


Subtasks

Feature #7062: Adapt the test suite's check for a persistent volume for WheezyResolved


Related issues

Blocked by Tails - Bug #6903: The Upgrader cannot start Resolved 03/11/2014

History

#1 Updated by intrigeri over 3 years ago

  • Status changed from Confirmed to In Progress

#2 Updated by intrigeri over 3 years ago

  • Blocked by Bug #6903: The Upgrader cannot start added

#3 Updated by intrigeri over 3 years ago

  • Assignee changed from intrigeri to anonym

anonym wrote: "Count me in on this, starting next week." Unfortunately, we can't have two assignees, so reassigning to anonym, and I'll finish what's left, as for the rest of 1.1.

#4 Updated by intrigeri over 3 years ago

Note that #6275 requires me to adapt the USB installer feature to test my changes, and I'm not willing to wait, so I'm on it.

#5 Updated by intrigeri over 3 years ago

  • Feature Branch deleted (feature/wheezy)

#6 Updated by intrigeri over 3 years ago

  • Description updated (diff)

#7 Updated by intrigeri over 3 years ago

  • % Done changed from 0 to 10
  • Feature Branch set to test/6559-adapt-test-suite-for-Wheezy

#8 Updated by intrigeri over 3 years ago

  • Blocks Feature #6275: Automatically test write access to the boot block device via udisks added

#9 Updated by intrigeri over 3 years ago

  • Blocks deleted (Feature #6275: Automatically test write access to the boot block device via udisks)

#10 Updated by intrigeri over 3 years ago

I'm done with what I had to do on that front, so I'm releasing the lock. anonym, see the feature branch. I stopped a bit further than I really had, and was blocked by an interesting Couldn't open LUKS device '/dev/sda2' on drive 'current' (RuntimeError) in the "Booting Tails from a USB drive without a persistent partition and creating one" scenario, while in the next one ("Booting Tails from a USB drive with a disabled persistent partition"), the same step ("a Tails persistence partition with password "asdf" exists on USB drive "current"") passes just fine.

#11 Updated by anonym over 3 years ago

  • Assignee changed from anonym to intrigeri
  • % Done changed from 10 to 0
  • QA Check set to Info Needed

I have worked on this as well, so there's been some duplication of work, although not too much. I wasn't aware of the "lock". :)

For now I'll push my stuff into a different branch, called test/6559-adapt-test-suite-for-Wheezy-by-anonym. Since my branch covers everything yours does, I suppose mine can replace yours, although I'll wait for your confirmation for that (hence the "Info Needed" -- just reassign to me when you answer).

In my branch all but two features pass for me but I've had to add two workarounds for regressions introduced by Wheezy (e.g. the LUKS one you found). I created tickets:

  • #7055 (workaround is commit 4c7beba)
  • #7056 (workaround is commit cdbee93)

The obvious exception is the complete winxp.feature of course. What should we do with it? Perhaps we should just remove it and revert the commit once we have a Windows XP theme for GNOME 3?

The next failure is apt.feature, Scenario: Install packages using Synaptic. It fails by sikuli not finding SynapticCowsaySearchResult.png, and from looking at what happens, it seems the search window isn't opened at all. How that can happen without failing earlier (in the try_for) I don't understand at all.

Also sikuli randomly fails to find GnomeRunDialog.png in the I run ... step, which you have reported before if I'm not mistaken. I think I know why, and it's unrelated to Wheezy, so I opened #7060.

#12 Updated by intrigeri over 3 years ago

  • Assignee changed from intrigeri to anonym
  • QA Check changed from Info Needed to Dev Needed

anonym wrote:

I have worked on this as well, so there's been some duplication of work, although not too much.

I've no idea what I could have done better, to avoid wasting my time, than communicating that I was working on this on IRC + on this ticket. In the future, when working on something that has in essence 2 assignees, please communicate on what exactly, when you start working on it (note that a vague "next week" doesn't count :)

For now I'll push my stuff into a different branch, called test/6559-adapt-test-suite-for-Wheezy-by-anonym. Since my branch covers everything yours does, I suppose mine can replace yours, although I'll wait for your confirmation for that (hence the "Info Needed" -- just reassign to me when you answer).

I'm not overly excited at the idea of having to review work that's a duplicate of something I've already done and communicated about 3 days ago, but the reasonable thing to do is indeed what you're proposing, since it's a superset of what I've done. Please merge our two branches together, with -s ours if needed, so that the other one I've already asked for review'n'merge shares a common history will all that.

The obvious exception is the complete winxp.feature of course. What should we do with it? Perhaps we should just remove it and revert the commit once we have a Windows XP theme for GNOME 3?

The way we've proceeded in the last months was to add a "FIXME: #nnnn" marker on features or scenarios that are known to fail.

Great work!

#13 Updated by intrigeri over 3 years ago

Raised priority (by the way of sub-tasks), as the test suite update may find issues we have to fix, and it's hard to schedule one's time without knowing what has to be fixed.

#14 Updated by anonym over 3 years ago

  • Assignee changed from anonym to intrigeri
  • QA Check changed from Dev Needed to Ready for QA

The branch history has been rewritten. See "[review'n'merge:1.1] #6559, #7062, #6275: test/6559-adapt-test-suite-for-Wheezy" on tails-dev@.

#15 Updated by intrigeri over 3 years ago

  • Assignee changed from intrigeri to anonym
  • QA Check changed from Ready for QA to Dev Needed

FindFailed: can not find TailsBootSplash.png on the screen, as reported on tails-dev.

#16 Updated by intrigeri over 3 years ago

  • Assignee changed from anonym to intrigeri
  • QA Check changed from Dev Needed to Ready for QA

#17 Updated by intrigeri over 3 years ago

  • Assignee changed from intrigeri to anonym
  • QA Check changed from Ready for QA to Dev Needed

#18 Updated by intrigeri about 3 years ago

  • Assignee changed from anonym to intrigeri
  • QA Check changed from Dev Needed to Ready for QA

#19 Updated by intrigeri about 3 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

#20 Updated by BitingBird about 3 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF