Project

General

Profile

Bug #699

Head trauma on friendly_dates - this seems to only occure for some users.

Added by terraw over 8 years ago. Updated over 6 years ago.

Status:
Confirmed
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
04/21/2009
Due date:
% Done:

0%

Spent time:
QA Check:
Feature Branch:

Description

A lot of users can create account but get head trauma when they try to do anything.

Error logs say this is due to a problem with
Time.zone.today
where some libs do not seem to be loaded probably.

History

#1 Updated by terraw over 8 years ago

In same site, there are users getting same head trauma errors with everything they do, who don't have such characters in their user names ... Ashleigh is one of the users names

#2 Updated by azul over 8 years ago

  • Category changed from Profile to Membership Process
  • Priority changed from High to Urgent
  • Target version set to 0.5.0

Okay. So this does not seem to depend on the user name. I've been using test-both happily for quite some time now.

So something else seems to be going on here. But it sounds like it is only happening for some users - right? Could you paste the output of the trauma?

#3 Updated by azul over 8 years ago

There are a number of these errors in the logs:

Couldn't create cache directory: views/my.unite4climate.org/profile/edit/private?authenticity_token=b1107f880042e8eff0b6041ecd913148d474fe81&profile%5Bemail_addresses%5D%5B8632580233%5D%5Bemail_address%5D=aekolla%40gmail.com&profile%5Bemail_addresses%5D%5B8632580233%5D%5Bemail_type%5D=Home&profile%5Bfirst_name%5D=Ashleigh&profile%5Blast_name%5D=Kolla&profile%5Bmay_pester%5D=1&profile%5Bmay_request_contact%5D=1&profile%5Bmay_see%5D=1&profile%5Bmay_see_contacts%5D=0&profile%5Bmay_see_groups%5D=0&profile%5Bmiddle_name%5D=E&profile%5Borganization%5D=GoBEYOND&profile%5Bpeer%5D=0&profile%5Brole%5D=&save=Save+Changes&user_id=26&version=5 (File name too long - /usr/apps/crabgrass/tmp/cache/views/my.unite4climate.org/profile/edit/private.authenticity_token=b1107f880042e8eff0b6041ecd913148d474fe81&profile%5Bemail_addresses%5D%5B8632580233%5D%5Bemail_address%5D=aekolla%40gmail.com&profile%5Bemail_addresses%5D%5B8632580233%5D%5Bemail_type%5D=Home&profile%5Bfirst_name%5D=Ashleigh&profile%5Blast_name%5D=Kolla&profile%5Bmay_pester%5D=1&profile%5Bmay_request_contact%5D=1&profile%5Bmay_see%5D=1&profile%5Bmay_see_contacts%5D=0&profile%5Bmay_see_groups%5D=0&profile%5Bmiddle_name%5D=E&profile%5Borganization%5D=GoBEYOND&profile%5Bpeer%5D=0&profile%5Brole%5D=&save=Save+Changes&user_id=26&version=5.cache)

Looks like they are related.

#4 Updated by azul over 8 years ago

ActionView::TemplateError (uninitialized constant TZInfo::TimezoneTransitionInfo::RubyCoreSupport) on line #5 of app/views/activity/_list.html.erb:
2: <div class='activities'>
3: <ul class='plain'>
4: <% activities.each do |activity| ->
5: <li class="small_icon <%=activity.icon%>_16"><%= expand_links(activity.description({:current_user => (current_user if logged_in?)})) %> <%= BULLET + friendly_date(activity.created_at) %></li>
6: <
end -%>
7: </ul>
8: </div>

vendor/rails/activesupport/lib/active_support/dependencies.rb:492:in `const_missing'
/usr/lib/ruby/1.8/tzinfo/timezone_transition_info.rb:73:in `at'
/usr/lib/ruby/1.8/tzinfo/data_timezone_info.rb:113:in `period_for_utc'
/usr/lib/ruby/1.8/tzinfo/data_timezone_info.rb:112:in `downto'
/usr/lib/ruby/1.8/tzinfo/data_timezone_info.rb:112:in `period_for_utc'
vendor/rails/activesupport/lib/active_support/vendor/tzinfo-0.3.8/tzinfo/data_timezone.rb:36:in `period_for_utc'
vendor/rails/activesupport/lib/active_support/vendor/tzinfo-0.3.8/tzinfo/timezone.rb:375:in `utc_to_local'
vendor/rails/activesupport/lib/active_support/vendor/tzinfo-0.3.8/tzinfo/time_or_datetime.rb:276:in `wrap'
vendor/rails/activesupport/lib/active_support/vendor/tzinfo-0.3.8/tzinfo/timezone.rb:374:in `utc_to_local'
vendor/rails/activesupport/lib/active_support/vendor/tzinfo-0.3.8/tzinfo/timezone.rb:426:in `now'
vendor/rails/activesupport/lib/active_support/values/time_zone.rb:258:in `today'
app/helpers/time_helper.rb:17:in `friendly_date'
app/views/activity/_list.html.erb:5:in `_run_erb_47app47views47activity47_list46html46erb'
app/views/activity/_list.html.erb:4:in `each'
app/views/activity/_list.html.erb:4:in `_run_erb_47app47views47activity47_list46html46erb'
vendor/rails/actionpack/lib/action_view/base.rb:338:in `send'
vendor/rails/actionpack/lib/action_view/base.rb:338:in `execute'
vendor/rails/actionpack/lib/action_view/template_handlers/compilable.rb:29:in `send'
vendor/rails/actionpack/lib/action_view/template_handlers/compilable.rb:29:in `render'
vendor/rails/actionpack/lib/action_view/partial_template.rb:20:in `render'
vendor/rails/actionpack/lib/action_controller/benchmarking.rb:30:in `benchmark'
vendor/rails/actionpack/lib/action_view/partial_template.rb:19:in `render'
vendor/rails/actionpack/lib/action_view/template.rb:22:in `render_template'
vendor/rails/actionpack/lib/action_view/partials.rb:110:in `render_partial'
vendor/rails/actionpack/lib/action_view/base.rb:273:in `render_without_haml'
/usr/lib/ruby/1.8/haml/helpers/action_view_mods.rb:14:in `render'
app/views/me/dashboard/_info_box.html.erb:7:in `_run_erb_47app47views47me47dashboard47_info_box46html46erb'
vendor/rails/actionpack/lib/action_view/base.rb:338:in `send'
vendor/rails/actionpack/lib/action_view/base.rb:338:in `execute'
vendor/rails/actionpack/lib/action_view/template_handlers/compilable.rb:29:in `send'
vendor/rails/actionpack/lib/action_view/template_handlers/compilable.rb:29:in `render'
vendor/rails/actionpack/lib/action_view/partial_template.rb:20:in `render'
vendor/rails/actionpack/lib/action_controller/benchmarking.rb:30:in `benchmark'
vendor/rails/actionpack/lib/action_view/partial_template.rb:19:in `render'
vendor/rails/actionpack/lib/action_view/template.rb:22:in `render_template'
vendor/rails/actionpack/lib/action_view/partials.rb:110:in `render_partial'
vendor/rails/actionpack/lib/action_view/base.rb:273:in `render_without_haml'
/usr/lib/ruby/1.8/haml/helpers/action_view_mods.rb:14:in `render'
app/views/me/dashboard/index.html.erb:11:in `_run_erb_47app47views47me47dashboard47index46html46erb'
vendor/rails/actionpack/lib/action_view/helpers/capture_helper.rb:141:in `call'
vendor/rails/actionpack/lib/action_view/helpers/capture_helper.rb:141:in `capture_erb_with_buffer_without_haml'
/usr/lib/ruby/1.8/haml/helpers/action_view_mods.rb:68:in `capture_erb_with_buffer'
vendor/rails/actionpack/lib/action_view/helpers/capture_helper.rb:44:in `capture_without_haml'
/usr/lib/ruby/1.8/haml/helpers/action_view_mods.rb:58:in `capture'
app/views/me/dashboard/index.html.erb:10:in `_run_erb_47app47views47me47dashboard47index46html46erb'
vendor/rails/actionpack/lib/action_view/base.rb:338:in `send'
vendor/rails/actionpack/lib/action_view/base.rb:338:in `execute'
vendor/rails/actionpack/lib/action_view/template_handlers/compilable.rb:29:in `send'
vendor/rails/actionpack/lib/action_view/template_handlers/compilable.rb:29:in `render'
vendor/rails/actionpack/lib/action_view/template.rb:35:in `render'
vendor/rails/actionpack/lib/action_view/template.rb:22:in `render_template'
vendor/rails/actionpack/lib/action_view/base.rb:245:in `render_file'
vendor/rails/actionpack/lib/action_controller/base.rb:1108:in `render_for_file'
vendor/rails/actionpack/lib/action_controller/base.rb:841:in `render_with_no_layout'
vendor/rails/actionpack/lib/action_controller/layout.rb:251:in `render_without_benchmark'
vendor/rails/actionpack/lib/action_controller/benchmarking.rb:51:in `render'
vendor/rails/activesupport/lib/active_support/core_ext/benchmark.rb:8:in `realtime'
vendor/rails/actionpack/lib/action_controller/benchmarking.rb:51:in `render'
vendor/rails/actionpack/lib/action_controller/base.rb:1157:in `default_render'
vendor/rails/actionpack/lib/action_controller/base.rb:1163:in `perform_action_without_filters'
vendor/rails/actionpack/lib/action_controller/filters.rb:580:in `call_filters'
vendor/rails/actionpack/lib/action_controller/filters.rb:601:in `run_before_filters'
app/controllers/application.rb:151:in `rescue_authentication_errors'
vendor/rails/activesupport/lib/active_support/callbacks.rb:173:in `send'
vendor/rails/activesupport/lib/active_support/callbacks.rb:173:in `evaluate_method'
vendor/rails/actionpack/lib/action_controller/filters.rb:395:in `call'
vendor/rails/actionpack/lib/action_controller/filters.rb:598:in `run_before_filters'
vendor/rails/actionpack/lib/action_controller/filters.rb:578:in `call_filters'
vendor/rails/actionpack/lib/action_controller/filters.rb:601:in `run_before_filters'
app/controllers/application.rb:179:in `set_language'
vendor/plugins/gibberish/lib/gibberish/localize.rb:34:in `use_language'
app/controllers/application.rb:179:in `set_language'
vendor/rails/activesupport/lib/active_support/callbacks.rb:173:in `send'
vendor/rails/activesupport/lib/active_support/callbacks.rb:173:in `evaluate_method'
vendor/rails/actionpack/lib/action_controller/filters.rb:395:in `call'
vendor/rails/actionpack/lib/action_controller/filters.rb:598:in `run_before_filters'
vendor/rails/actionpack/lib/action_controller/filters.rb:578:in `call_filters'
vendor/rails/actionpack/lib/action_controller/filters.rb:573:in `perform_action_without_benchmark'
vendor/rails/actionpack/lib/action_controller/benchmarking.rb:68:in `perform_action_without_rescue'
/usr/lib/ruby/1.8/benchmark.rb:293:in `measure'
vendor/rails/actionpack/lib/action_controller/benchmarking.rb:68:in `perform_action_without_rescue'
vendor/rails/actionpack/lib/action_controller/rescue.rb:201:in `perform_action_without_caching'
vendor/rails/actionpack/lib/action_controller/caching/sql_cache.rb:13:in `passenger_orig_perform_action'
vendor/rails/activerecord/lib/active_record/connection_adapters/abstract/query_cache.rb:33:in `cache'
vendor/rails/activerecord/lib/active_record/query_cache.rb:8:in `cache'
vendor/rails/actionpack/lib/action_controller/caching/sql_cache.rb:12:in `passenger_orig_perform_action'
/usr/lib/ruby/1.8/passenger/railz/request_handler.rb:53:in `perform_action'
vendor/rails/actionpack/lib/action_controller/base.rb:529:in `send'
vendor/rails/actionpack/lib/action_controller/base.rb:529:in `process_without_filters'
vendor/rails/actionpack/lib/action_controller/filters.rb:569:in `process_without_session_management_support'
vendor/rails/actionpack/lib/action_controller/session_management.rb:130:in `process'
vendor/rails/actionpack/lib/action_controller/base.rb:389:in `process'
vendor/rails/actionpack/lib/action_controller/dispatcher.rb:149:in `handle_request'
vendor/rails/actionpack/lib/action_controller/dispatcher.rb:107:in `dispatch'
vendor/rails/actionpack/lib/action_controller/dispatcher.rb:104:in `synchronize'
vendor/rails/actionpack/lib/action_controller/dispatcher.rb:104:in `dispatch'
vendor/rails/actionpack/lib/action_controller/dispatcher.rb:120:in `dispatch_cgi'
vendor/rails/actionpack/lib/action_controller/dispatcher.rb:35:in `dispatch'
/usr/lib/ruby/1.8/passenger/railz/request_handler.rb:38:in `process_request'
/usr/lib/ruby/1.8/passenger/abstract_request_handler.rb:165:in `main_loop'
/usr/lib/ruby/1.8/passenger/railz/application_spawner.rb:321:in `start_request_handler'
/usr/lib/ruby/1.8/passenger/railz/application_spawner.rb:282:in `handle_spawn_application'
/usr/lib/ruby/1.8/passenger/utils.rb:163:in `safe_fork'
/usr/lib/ruby/1.8/passenger/utils.rb:161:in `fork'
/usr/lib/ruby/1.8/passenger/utils.rb:161:in `safe_fork'
/usr/lib/ruby/1.8/passenger/railz/application_spawner.rb:280:in `handle_spawn_application'
/usr/lib/ruby/1.8/passenger/utils.rb:163:in `safe_fork'
/usr/lib/ruby/1.8/passenger/utils.rb:161:in `fork'
/usr/lib/ruby/1.8/passenger/utils.rb:161:in `safe_fork'
/usr/lib/ruby/1.8/passenger/railz/application_spawner.rb:279:in `handle_spawn_application'
/usr/lib/ruby/1.8/passenger/abstract_server.rb:317:in `__send__'
/usr/lib/ruby/1.8/passenger/abstract_server.rb:317:in `main_loop'
/usr/lib/ruby/1.8/passenger/abstract_server.rb:168:in `start_synchronously'
/usr/lib/ruby/1.8/passenger/abstract_server.rb:135:in `start'
/usr/lib/ruby/1.8/passenger/abstract_server.rb:112:in `fork'
/usr/lib/ruby/1.8/passenger/abstract_server.rb:112:in `start'
/usr/lib/ruby/1.8/passenger/railz/application_spawner.rb:179:in `start'
/usr/lib/ruby/1.8/passenger/spawn_manager.rb:222:in `spawn_rails_application'
/usr/lib/ruby/1.8/passenger/spawn_manager.rb:217:in `synchronize'
/usr/lib/ruby/1.8/passenger/spawn_manager.rb:217:in `spawn_rails_application'
/usr/lib/ruby/1.8/passenger/spawn_manager.rb:126:in `spawn_application'
/usr/lib/ruby/1.8/passenger/spawn_manager.rb:251:in `handle_spawn_application'
/usr/lib/ruby/1.8/passenger/abstract_server.rb:317:in `__send__'
/usr/lib/ruby/1.8/passenger/abstract_server.rb:317:in `main_loop'
/usr/lib/ruby/1.8/passenger/abstract_server.rb:168:in `start_synchronously'
/usr/lib/passenger/passenger-spawn-server:46

#5 Updated by azul over 8 years ago

  • Subject changed from When user names have a -(dash) or _(underline) they can create account but get head trauma when they try to do anything to Head trauma on friendly dates, caching wrong pages, Problems loading extensions

updated the bug description. The user name thing was confusing.

My impression is that there are problems loading some extension or so. I ran into the User_Extension::Cache problem before when SuperAdmin mod was not loading properly.

The strangest thing is that it seems to be working now again...

#6 Updated by azul over 8 years ago

  • Subject changed from Head trauma on friendly dates, caching wrong pages, Problems loading extensions to Head trauma on friendly_dates - this seems to only occure for some users.

Looks like the main problem actually is with Time.zone.today - the funny thing is that it works quite regularly. No idea why id does not seem to work for some.

#7 Updated by mcnair over 8 years ago

  • Status changed from New to Resolved

#8 Updated by kclair almost 8 years ago

  • Status changed from Resolved to Confirmed
  • Target version changed from 0.4.0 to 0.5.0

this is caused by setting an invalid time zone. example: Saskatchewan

#9 Updated by mcnair almost 8 years ago

  • Priority changed from Urgent to Elevated
  • Target version changed from 0.5.0 to z. Backlog B

sporadic issue, very important, but will have to wait till 0.5.1

#10 Updated by mcnair almost 8 years ago

  • Priority changed from Elevated to High

#11 Updated by mcnair over 7 years ago

  • Priority changed from High to Elevated

#12 Updated by kclair over 7 years ago

  • Status changed from Confirmed to In Progress
  • Assignee set to kclair

#13 Updated by mcnair over 7 years ago

  • Target version changed from z. Backlog B to z. Backlog A

#14 Updated by mcnair over 7 years ago

  • Target version changed from z. Backlog A to On Deck

#15 Updated by mcnair over 7 years ago

  • Project changed from Crabgrass to 41
  • Category deleted (Membership Process)

#16 Updated by mcnair over 7 years ago

  • Project changed from 41 to Crabgrass

#17 Updated by kclair over 7 years ago

  • Status changed from In Progress to Confirmed
  • Target version changed from On Deck to z. Backlog A

#18 Updated by mcnair over 6 years ago

  • Assignee deleted (kclair)
  • Target version changed from z. Backlog A to z. Backlog B

Also available in: Atom PDF