Feature #7061

Random hostname option needed on startup

Added by redline about 3 years ago. Updated over 2 years ago.

Status:RejectedStart date:04/11/2014
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
QA Check: Blueprint:
Feature Branch: Easy:No
Type of work:Discuss Affected tool:

Description

In advanced options users should have the option to check a box "Random hostname" or "Random computer name" and get a randomly assigned hostname.

Reason being that the "amnesia" hostname Tails currently assigns is a big red flag in certain environments. Some people would prefer to fly under the radar and not call attention to themselves by system administrators.

It could be a simple function where if the box is checked on startup a random number 1-50,000 is assinged as the computers hostname.


Related issues

Related to Tails - Feature #5655: Share username and hostname amongst all anonymity distributions Confirmed 03/17/2016

History

#1 Updated by sajolida about 3 years ago

I check on my local network, and at least in the DHCP leases, the hostname "amnesia" is not leaked. So, can you precise where do you see the current hostname being leaked?

#2 Updated by sajolida about 3 years ago

  • Related to Feature #5655: Share username and hostname amongst all anonymity distributions added

#3 Updated by techfx about 3 years ago

I strongly agree, having the hostname show amnesia is a big flag to system administrators and other personal monitoring their local network.

Instead of having it say something like amnesia or anonos or anything that might indicate the user is using an incognito distro it could be something very generic that lots of users use:

1. "host"

2. "pc"

3. "hostname"

4. "network"

Of course a random hostname would be best but that would take far more time to implement, for the time being Tails developers can simply change amnesia to something generic. Why annonce to the system admins that we are using a incognito disto? Just makes no sense to have the hostname as "amnesia". Any system admin or it person worth their salt will know they are using Tails and investigate the matter further. If a generic hostname is user then they would have to use more advanced methods to detect Tails users on their network.

Hopefully by Tails 1.0 the default hostname can change from "amnesia" to someting generic like "pc" or if possible maybe blank.

#4 Updated by sajolida about 3 years ago

I strongly agree, having the hostname show amnesia is a big flag to
system administrators and other personal monitoring their local
network.

Can you explain us more in details where this hostname appears on the
local network? It is not revealed by DHCP queries. Is there anything
else you are worried about?

Instead of having it say something like amnesia or anonos or anything
that might indicate the user is using an incognito distro it could be
something very generic that lots of users use:

1. "host"
2. "pc"
3. "hostname"
4. "network"

See also the related issue #5655. Any bit of help in that direction is
welcome.

#5 Updated by t3x about 3 years ago

There seems to be a lot of confusion around identifying a Tails user using the hostname "amnesia".

Can someone a little more knowledgable please answer the following question:

If a system administrator is looking at the users on their network, can they easily spot Tails users by looking for the "amneisa" hostname?

In other words, if I use Tails what does my computer hostname (aka computer name) look like to someone monitoring the network like a system administrator? Do they see it as "amnesia" or does Tails not show anything for the hostname and it's simply blank.

For example at the moment when I use my laptop and I login to my linksys router admin page it shows that laptop as "MynameMacbookPro" and the IP. Curious what Tails shows up as.

#6 Updated by sajolida about 3 years ago

There seems to be a lot of confusion around identifying a Tails user
using the hostname "amnesia".

Can someone a little more knowledgable please answer the following
question:

If a system administrator is looking at the users on their network,
can they easily spot Tails users by looking for the "amneisa"
hostname?

In other words, if I use Tails what does my computer hostname (aka
computer name) look like to someone monitoring the network like a
system administrator? Do they see it as "amnesia" or does Tails not
show anything for the hostname and it's simply blank.

For example at the moment when I use my laptop and I login to my
linksys router admin page it shows that laptop as "MynameMacbookPro"
and the IP. Curious what Tails shows up as.

That information is usually given through DHCP, and Tails is preventing
that leak already. So this one is out of the way.

In comment #1, I already asked for more information about other possible
leaks of the hostname and nobody came up with more scenarios...

#7 Updated by intrigeri about 3 years ago

For example at the moment when I use my laptop and I login to my linksys router admin
page it shows that laptop as "MynameMacbookPro" and the IP. Curious what Tails shows
up as.

It would be useful if you actually tried, and reported your findings :)

#8 Updated by BitingBird almost 3 years ago

  • Type of work changed from Discuss to Research

#9 Updated by sajolida almost 3 years ago

  • Status changed from New to Confirmed
  • Type of work changed from Research to Discuss

This needs discussion because it could conflict with #5655 and break that anonymity set. I guess that a quick discussion in a monthly meeting would settle our opinion.

#10 Updated by aguelier@ruggedinbox.com over 2 years ago

Hostname can also leak out when sending email and who knows what other regressions might show up in the future. The hostname shouldn't be random from the set of all possible hostnames (which risks uniquely fingerprinting the user session), but random from the set of common host names (such as Windows/Mac/Debian defaults), similar to how the Tails Pidgin client randomly selects a normal looking username for IRC chat.

#11 Updated by intrigeri over 2 years ago

Hostname can also leak out when sending email

Note that this is something we test before each release of Tails: https://tails.boum.org/contribute/release_process/test/#index7h1

#12 Updated by u over 2 years ago

During our last meeting we have come to the conclusion that anything but the single and shared username+hostname seems actively harmful and considerably reduce the anonymity set.

This ticket's cause was that the hostname "amnesia" is too targettable. Further discussion should thus happen here: https://labs.riseup.net/code/issues/5655 Share username and hostname amongst all anonymity distributions.

#13 Updated by u over 2 years ago

Should I close this ticket?

#14 Updated by BitingBird over 2 years ago

  • Status changed from Confirmed to Rejected

Also available in: Atom PDF