Project

General

Profile

Feature #7368

Feature #8416: Document MAT

Point to documentation about metadata from doc/sensitive_documents/graphics

Added by intrigeri over 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
06/03/2014
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
doc/7368-warning_metadata
Type of work:
End-user documentation
Blueprint:
Starter:
No
Affected tool:

Description

It would be good if our documentation about creating documents (especially, graphic ones) pointed to the one (if it exists already) about risks of metadata in such files, and (either directly, or transitively) to the MAT documentation.

Associated revisions

Revision ed01e8ab
Added by sajolida over 3 years ago

Merge branch 'doc/7368-warning_metadata' (Closes: #7368)

History

#1 Updated by intrigeri over 4 years ago

  • Related to Feature #5542: Help MAT upstream to write documentation added

#2 Updated by sajolida over 4 years ago

  • Status: Confirmed

#3 Updated by BitingBird over 4 years ago

  • Status changed from New to Confirmed

I confirm it, since sajolida's command doesn't work

#4 Updated by sajolida over 4 years ago

  • Status changed from Confirmed to New

#5 Updated by sajolida over 4 years ago

  • Status changed from New to Confirmed

#6 Updated by BitingBird almost 4 years ago

  • Status changed from Confirmed to In Progress
  • QA Check set to Ready for QA

#7 Updated by BitingBird almost 4 years ago

  • Assignee set to sajolida
  • Target version set to Tails_1.2.2
  • Feature Branch set to bitingbird:doc/7368-warning_metadata

#8 Updated by sajolida almost 4 years ago

  • Related to deleted (Feature #5542: Help MAT upstream to write documentation )

#9 Updated by sajolida almost 4 years ago

  • Assignee changed from sajolida to BitingBird
  • Parent task set to #5542
  • QA Check changed from Ready for QA to Info Needed

Thanks for the patch. This made me realize that many other things can be fixed regarding MAT in our documentation, so I made this a subtask of #8416.

Do you think that should merge this as such or rather work a bit of the other subtasks of #8416 before?

#10 Updated by sajolida almost 4 years ago

  • Parent task deleted (#5542)

#11 Updated by sajolida almost 4 years ago

  • Parent task set to #8416

#12 Updated by sajolida almost 4 years ago

Ah, and I had the same Git problems as with #7118. So please do reset your branch in the same way.

#13 Updated by sajolida almost 4 years ago

  • Feature Branch changed from bitingbird:doc/7368-warning_metadata to doc/7368-warning_metadata

#14 Updated by anonym almost 4 years ago

  • Target version changed from Tails_1.2.2 to Tails_1.2.3

#15 Updated by BitingBird almost 4 years ago

  • Target version changed from Tails_1.2.3 to Tails_1.3

#16 Updated by BitingBird almost 4 years ago

  • Assignee changed from BitingBird to sajolida
  • QA Check changed from Info Needed to Ready for QA
  • Feature Branch changed from doc/7368-warning_metadata to bitingbird:doc/7368-warning_metadata

I think this can be merged already, I don't really know where to start to document MAT and the warning is useful as-is, although more complete documentation would be better :)

#17 Updated by intrigeri almost 4 years ago

  • Feature Branch changed from bitingbird:doc/7368-warning_metadata to doc/7368-warning_metadata

Rebased on master.

#18 Updated by BitingBird over 3 years ago

Added a commit to fix bad links, otherwise it looks good :)

#19 Updated by intrigeri over 3 years ago

  • % Done changed from 0 to 50

Cherry-picked your commit, added two more on top, pushed.

#20 Updated by BitingBird over 3 years ago

  • Priority changed from Normal to Elevated

The review has already half been done, I think it's quick.

#21 Updated by sajolida over 3 years ago

  • Assignee changed from sajolida to BitingBird
  • QA Check changed from Ready for QA to Dev Needed

Ok, to include this inline right now, and not wait for the MAT documentation. Still, I have a few concerns with your doc:

  • Did you build the wiki? Because all the links are broken for me :)
  • The Wikipedia page is quite rough. I try to be cautious about the relevance of our external links and the intro of this page is quite obscure don't you think? The MAT website has a short introduction which is quite better actually. Or maybe we can find something somewhere else? Probably Tactical Tech has some explanation about metadata somewhere... Could check this out?
  • Can you try to avoid hyphen or dashes to structure sentences? I'm sure this one could have a simpler structure either broken in two or restructured to merge its two parts.
  • Did you have a good reason to not add a .mdwn extension to your file?
  • I usually use a naming scheme in three parts for file dedicated to inlined sections, to make them easier to identify when I browse through the file system. See for example ./first_steps/persistence.caution.mdwn. Shall we do that here as well?

#22 Updated by BitingBird over 3 years ago

  • Target version changed from Tails_1.3 to Tails_1.3.2

#23 Updated by BitingBird over 3 years ago

  • Assignee changed from BitingBird to sajolida
  • QA Check changed from Dev Needed to Info Needed
  • Feature Branch changed from doc/7368-warning_metadata to bitingbird:doc/7368-warning_metadata

sajolida wrote:

Ok, to include this inline right now, and not wait for the MAT documentation. Still, I have a few concerns with your doc:

  • Did you build the wiki? Because all the links are broken for me :)

I didn't, sorry. Done now :)

  • The Wikipedia page is quite rough. I try to be cautious about the relevance of our external links and the intro of this page is quite obscure don't you think? The MAT website has a short introduction which is quite better actually. Or maybe we can find something somewhere else? Probably Tactical Tech has some explanation about metadata somewhere... Could check this out?

We already link to MAT in the next line, and tactical tech has a page about metadata cleaning, but it doesn't mention MAT although it mentions many other tools (I sent them a message to suggest it), so I'm afraid it would be confusing for the users to be sent to a page explaining other tools. Should I remove the link altogether and consider that users will get the metadata explanation from the MAT link? Leave the wikipedia link? Something else?

  • Can you try to avoid hyphen or dashes to structure sentences? I'm sure this one could have a simpler structure either broken in two or restructured to merge its two parts.

I put a :

  • Did you have a good reason to not add a .mdwn extension to your file?

I was confused because the inline doesn't include the extension, but it's fixed.

  • I usually use a naming scheme in three parts for file dedicated to inlined sections, to make them easier to identify when I browse through the file system. See for example ./first_steps/persistence.caution.mdwn. Shall we do that here as well?

The persistence.mdwn that is included in the same page is not named in three, but I don't mind renaming. Would documents.metadata.mdwn be ok?

#24 Updated by sajolida over 3 years ago

  • Assignee changed from sajolida to BitingBird
  • QA Check changed from Info Needed to Dev Needed

What about trying to write a very short sentence that explain metadata
in a very simplistic form? I feel weird about using that jargon in the
doc without explaining, even very minimalistically, what this is about.
Then, yes the link to MAT should be enough.

The persistence.mdwn that is included in the same page is not named
in three, but I don't mind renaming.

Hmm, that's right! Then I guess you can leave metadata.mdwn like this :)

#25 Updated by BitingBird over 3 years ago

  • Assignee changed from BitingBird to sajolida
  • QA Check changed from Dev Needed to Ready for QA

Added a commit to explain metadata, explanations are stolen from MAT. Please review :)

#26 Updated by sajolida over 3 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100

#27 Updated by sajolida over 3 years ago

  • Assignee deleted (sajolida)
  • QA Check changed from Ready for QA to Pass
  • Feature Branch changed from bitingbird:doc/7368-warning_metadata to doc/7368-warning_metadata

#28 Updated by BitingBird over 3 years ago

Youhou, thanks :)

#29 Updated by BitingBird over 3 years ago

  • Target version changed from Tails_1.3.2 to Tails_1.3.1

Also available in: Atom PDF