Project

General

Profile

Bug #7898

Feature #7561: Update the Greeter for Jessie

Fix keyboard layout in GNOME session

Added by alant about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
Start date:
09/14/2014
Due date:
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Keyboard layout in not set in GNOME session as it should be by tails-configure-keyboard


Related issues

Related to Tails - Bug #7997: English layout listed twice in the GNOME Shell keyboard selector widget Resolved 10/02/2014
Related to Tails - Bug #8065: No more keyboard switching applet in Jessie Resolved 10/11/2014
Blocked by Tails - Feature #7311: Investigate using GNOME Shell for Jessie Resolved 06/11/2014

Associated revisions

Revision 738b1629 (diff)
Added by Tails about 4 years ago

Fix keyboard layout setting under GNOME

Closes #7898

Revision 62e49c2e (diff)
Added by Tails about 4 years ago

Fix keyboard layout setting under GNOME

Closes #7898

History

#1 Updated by alant about 4 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 10

gnome-control-center sets locale through DBus on the system bus: org.freedesktop.locale1 /org/freedesktop/locale1 SetX11Keyboard.

#2 Updated by alant about 4 years ago

  • Assignee set to alant
  • % Done changed from 10 to 20

It should be fixed in feature/jessie. To be tested.

#3 Updated by intrigeri about 4 years ago

Please quote variables in shell scripts. Otherwise, it all looks black magic to me, but not too scary, and I'm happy if it works :)

#4 Updated by alant about 4 years ago

Please quote variables in shell scripts.

Done.

Otherwise, it all looks black magic to me, but not too scary, and I'm happy if it works :)

See documentation of DBus schema /org/gnome/desktop/input-sources/sources if interested.

#5 Updated by intrigeri about 4 years ago

  • % Done changed from 20 to 50

alant wrote:

It should be fixed in feature/jessie. To be tested.

It works for me (English, French, German), but there's no applet to switch between the chosen layout and the US one, while the US one is properly configured as the second layout in the GNOME preferences. Is it a limitation of GNOME Flashback, or missing bits / misconfiguration on our side? Maybe we need to install the gkbd-capplet package (long shot at random)?

#6 Updated by intrigeri about 4 years ago

  • Target version set to Tails_2.0

#7 Updated by intrigeri about 4 years ago

  • Priority changed from Normal to High

(Like parent ticket.)

#8 Updated by alant about 4 years ago

It works for me (English, French, German), but there's no applet to switch between the chosen layout and the US one, while the US one is properly configured as the second layout in the GNOME preferences. Is it a limitation of GNOME Flashback, or missing bits / misconfiguration on our side? Maybe we need to install the gkbd-capplet package (long shot at random)?

I think that's another issue that we shouldn't try to fix before being sure wether we use gnome-shell or flashback.

#9 Updated by intrigeri about 4 years ago

  • Blocked by Feature #7311: Investigate using GNOME Shell for Jessie added

#10 Updated by intrigeri about 4 years ago

alant wrote:

I think that's another issue that we shouldn't try to fix before being sure wether we use gnome-shell or flashback.

Indeed, with GNOME Classic it works fine.

#11 Updated by intrigeri about 4 years ago

  • Related to Bug #7997: English layout listed twice in the GNOME Shell keyboard selector widget added

#12 Updated by intrigeri about 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100

With GNOME Shell, the correct layout is applied, and one can easily switch (once in the session) between the US layout and the one chosen in the Greeter, so calling this fixed. What's left to fix (a regression that was possibly introduced when fixing this very bug) is #7997.

#13 Updated by sajolida about 4 years ago

  • Related to Bug #8065: No more keyboard switching applet in Jessie added

Also available in: Atom PDF