Bug #8443

Adding a new printer requires administration password

Added by matsa over 2 years ago. Updated almost 2 years ago.

Status:ResolvedStart date:12/15/2014
Priority:ElevatedDue date:
Assignee:-% Done:

100%

Category:Hardware support
Target version:Tails_2.0
QA Check: Blueprint:
Feature Branch:feature/jessie Easy:
Type of work:Code Affected tool:

Description

When trying to add a new printer with Application > System > Administration > Printers, I'm now asked for the root password. IIRC, this is not the normal behavior with Tails.


Related issues

Related to Tails - Bug #7636: Impossible to configure printers from GNOME control center Resolved 08/11/2014
Related to Tails - Bug #8505: Jessie: there is an unclear and useless Sundry category in Applications menu Resolved 12/31/2014 10/15/2015
Related to Tails - Bug #10965: Some printers cannot be added via GNOME Resolved 01/18/2016

Associated revisions

Revision e421171e
Added by intrigeri almost 2 years ago

Allow the amnesia user, when active, to use all CUPS actions needed by the GNOME printing setup dialog.

These rules override those shipped by cups-pk-helper 0.2.5-2+b1 in
/usr/share/polkit-1/actions/org.opensuse.cupspkhelper.mechanism.policy

Closes: #8443

History

#1 Updated by sajolida over 2 years ago

  • Status changed from New to Confirmed
  • Priority changed from Normal to Elevated

Weird enough, the appeared between Tails 1.1 and 1.1.1. Making as Elevated since that's a regression.

All this with Applications → System Tools → Administration → Printing → Add.

#2 Updated by intrigeri over 2 years ago

Weird enough, the appeared between Tails 1.1 and 1.1.1.

In Tails 1.1.1, we've installed cups-pk-helper to fix #7636. Before, one could simply not add a new printer with Applications → System Tools → Preferences → System Settings → Printers.

Does "Applications -> System Tools -> Administration -> Printing" still work? (It was apparently working in 1.1.) If it does, then I propose we either try to get rid of "Applications → System Tools → Preferences → System Settings → Printers", or document the existing workaround.

#3 Updated by sajolida over 2 years ago

Sorry for not being precise in my previous comment, but I only tried Applications → System Tools → Administration → Printing → Add.

In 1.2.2 is asks for a password "Privileges are required to get list of available devices."

#4 Updated by intrigeri over 2 years ago

Sorry for not being precise in my previous comment, but I only tried Applications → System Tools → Administration → Printing → Add.

In 1.2.2 is asks for a password "Privileges are required to get list of available devices."

Argh. Is it fixed after de-installing cups-pk-helper?

#5 Updated by BitingBird over 2 years ago

  • QA Check set to Info Needed

#6 Updated by sajolida over 2 years ago

Yes, if I remove cups-pk-helper, then I am not prompted for an administration password anymore.

#7 Updated by BitingBird over 2 years ago

  • QA Check changed from Info Needed to Dev Needed

#8 Updated by intrigeri over 2 years ago

  • Subject changed from Adding a new printer requires administration password to Adding a new printer with system-config-printer requires administration password

#9 Updated by intrigeri over 2 years ago

  • Subject changed from Adding a new printer with system-config-printer requires administration password to Adding a new printer requires administration password
  • QA Check deleted (Dev Needed)
  • Type of work changed from Code to Discuss

Actually, in Tails 1.2.2, a password is asked both with system-config-printer (administration -> printing) and from the default GNOME printer settings (system settings -> printers).

I think we should:

  • Remove system-config-printer: it's been there since the first commit, mostly because back in the years, it was the only decent CUPS GUI available; nowadays, GNOME's one is good enough; we explicitly document that one should use the latter anyway, and as shown by this ticket, even us are confused by (or reporting confusing information about) the fact that we ship 2 GUIs for the same task.
  • Tweak the policykit permissions so that the active user is allowed to configure CUPS from the GNOME printing settings.

Thoughts?

#10 Updated by intrigeri over 2 years ago

  • Related to Bug #7636: Impossible to configure printers from GNOME control center added

#11 Updated by intrigeri over 2 years ago

  • Category set to Hardware support
  • Target version set to Tails_1.3

Seems too heavy changes for a point-release, and the workaround isn't too hard, hence flagging for 1.3.

#12 Updated by alant over 2 years ago

  • Related to Bug #8505: Jessie: there is an unclear and useless Sundry category in Applications menu added

#13 Updated by alant over 2 years ago

I think we should:

  • Remove system-config-printer: it's been there since the first commit, mostly because back in the years, it was the only decent CUPS GUI available; nowadays, GNOME's one is good enough; we explicitly document that one should use the latter anyway, and as shown by this ticket, even us are confused by (or reporting confusing information about) the fact that we ship 2 GUIs for the same task.
  • Tweak the policykit permissions so that the active user is allowed to configure CUPS from the GNOME printing settings.

Thoughts?

I agree.

#14 Updated by sajolida over 2 years ago

  • Assignee set to Dr_Whax

#15 Updated by sajolida over 2 years ago

  • Type of work changed from Discuss to Code

During the January meeting, we said that:

  • We acknowledged the proposal from comment 9.
  • DrWhax will try to do it for 1.3.

https://tails.boum.org/contribute/meetings/201501/

#16 Updated by intrigeri over 2 years ago

DrWhax, the freeze is in 2 days. If you don't think you'll be able to complete this in time, please postpone to the next release or unassign this ticket from you.

#17 Updated by Dr_Whax over 2 years ago

  • Target version changed from Tails_1.3 to Tails_1.3.2

#18 Updated by Dr_Whax over 2 years ago

  • Target version changed from Tails_1.3.2 to Tails_1.4

I read this would be too heavy for a previous point-release. Will go to 1.4.

#19 Updated by intrigeri about 2 years ago

intrigeri wrote:

DrWhax, the freeze is in 2 days. If you don't think you'll be able to complete this in time, please postpone to the next release or unassign this ticket from you.

Do you still plan to work on this on the short-term, or should we try and find someone else to take care of this problem?

#20 Updated by intrigeri about 2 years ago

Postponing again. No news from DrWhax, so de-assigning. I think I've read on IRC that adamb wanted to give it a try. Worst case, this ticket will make it into the summary of release goals without any assignee, and perhaps it'll find someone to take care of it :)

#21 Updated by intrigeri about 2 years ago

  • Target version changed from Tails_1.4 to Tails_1.5

(hrm, trying again -- indeed Redmine is picky.)

#22 Updated by BitingBird about 2 years ago

  • Assignee deleted (Dr_Whax)

#23 Updated by BitingBird almost 2 years ago

  • Target version changed from Tails_1.5 to Hole in the Roof

No assignee for this milestone -> hole in the roof

#24 Updated by intrigeri almost 2 years ago

No assignee for this milestone -> hole in the roof

(As per monthly meeting.)

#25 Updated by intrigeri almost 2 years ago

GNOME control center's printer config panel actually uses cups-pk-helper's rules: #8505#note-19. So we should probably just patch/override these rules to not require any auth from the active user.

#26 Updated by intrigeri almost 2 years ago

  • Status changed from Confirmed to In Progress
  • Assignee set to intrigeri
  • % Done changed from 0 to 10
  • Feature Branch set to feature/jessie

#8505 prompted me to work on this one while I had the problem space in mind and the setup needed to test. I'll be doing it in feature/jessie as I don't want to bother having to rebase the rule overrides on top of Jessie's cups-pk-helper in a couple months.

#27 Updated by intrigeri almost 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 10 to 100

#28 Updated by intrigeri almost 2 years ago

  • Assignee deleted (intrigeri)
  • Target version changed from Hole in the Roof to Tails_2.0

One less hole in the roof, one!

#29 Updated by intrigeri about 1 year ago

  • Related to Bug #10965: Some printers cannot be added via GNOME added

Also available in: Atom PDF