Project

General

Profile

Feature #8635

Bug #7161: Support more than 24 HTTP mirrors

Make each mirror provide a unique virtualhost name

Added by intrigeri over 3 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
02/04/2016
Due date:
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Communicate
Blueprint:
Starter:
Affected tool:

Description

... in addition to dl.amnesia.b.o (that we need to ease the transition).

What we need is unique vhost names among our pool of mirrors, so our JS code can pick one for each user.

  1. allocate a unique virtual hostname to each current mirror
    1. check how we allocate those names
    2. #10294
  2. update contribute/how/mirror documentation with examples for the web servers we support
  3. ask all mirror operators to implement this, or whatever unique virtualhost name they prefer
  4. wait for most mirrors to implement it, and at some point remove from the pool the ones who did not

Subtasks

Feature #11054: Update contribute/how/mirror documentation with examples for the web servers we supportResolved

Bug #11055: Ask all mirror operators to implement new virtual hostnameResolved

Bug #11056: Wait for most mirrors to implement new virtual hostnameResolved

Feature #11334: Document how HTTP mirrors get a unique virtualhost nameResolved

Feature #11335: Set up the process and tools to allocate unique *.dl.amnesia.boum.org hostnamesResolved


Related issues

Blocked by Tails - Feature #10294: Define format for per-mirror hostname Resolved 09/28/2015

History

#2 Updated by intrigeri almost 3 years ago

  • Target version changed from Sustainability_M1 to Tails_2.3

#3 Updated by intrigeri over 2 years ago

  • Due date set to 04/15/2016

#4 Updated by u over 2 years ago

  • Description updated (diff)

#5 Updated by u over 2 years ago

  • Description updated (diff)

#6 Updated by intrigeri over 2 years ago

  • Description updated (diff)

#7 Updated by intrigeri over 2 years ago

  • Blocked by Feature #10294: Define format for per-mirror hostname added

#8 Updated by intrigeri over 2 years ago

  • Subject changed from Have each mirror operator configure a unique VirtualHost to Have each mirror work with *.dl.amnesia.boum.org
  • Description updated (diff)

#9 Updated by intrigeri over 2 years ago

  • Blocks Feature #8642: Enable the mirror pool dispatcher on all website pages that need it added

#10 Updated by intrigeri over 2 years ago

  • Subject changed from Have each mirror work with *.dl.amnesia.boum.org to Make each mirror work with *.dl.amnesia.boum.org

#11 Updated by sajolida over 2 years ago

I might have not understand the reasoning behind this fully, but wouldn't this be the right time to change *.dl.amnesia.boum.org into *.dl.tails.boum.org? And maybe dl.amnesia.boum.org into dl.tails.boum.org?

#12 Updated by intrigeri over 2 years ago

I might have not understand the reasoning behind this fully, but wouldn't this be the right time to change *.dl.amnesia.boum.org into *.dl.tails.boum.org? And maybe dl.amnesia.boum.org into dl.tails.boum.org?

Replied already in the other place where basically the same question has been asked.

#13 Updated by intrigeri about 2 years ago

  • Subject changed from Make each mirror work with *.dl.amnesia.boum.org to Make each mirror provide a unique virtualhost name
  • Description updated (diff)

#14 Updated by intrigeri about 2 years ago

  • Blocks deleted (Feature #8642: Enable the mirror pool dispatcher on all website pages that need it)

#15 Updated by intrigeri about 2 years ago

  • Blocks Feature #8642: Enable the mirror pool dispatcher on all website pages that need it added

#16 Updated by intrigeri about 2 years ago

  • Target version changed from Tails_2.3 to Tails_2.4

I don't think this can be completed within 12 days.

#18 Updated by intrigeri about 2 years ago

  • Blocks Feature #11109: Have DAVE build the ISO URL using our mirrors pool configuration added

#19 Updated by intrigeri almost 2 years ago

  • Status changed from Confirmed to In Progress

#20 Updated by intrigeri almost 2 years ago

  • Blocks deleted (Feature #8642: Enable the mirror pool dispatcher on all website pages that need it)

#21 Updated by intrigeri almost 2 years ago

  • Blocks deleted (Feature #11109: Have DAVE build the ISO URL using our mirrors pool configuration)

#22 Updated by intrigeri almost 2 years ago

(As explained on #11056#note-5, we have made enough progress here so this does not block anything anymore :)

#23 Updated by intrigeri almost 2 years ago

  • Assignee changed from u to intrigeri

(Same rationale as for the remaining subtask.)

#24 Updated by intrigeri almost 2 years ago

  • Status changed from In Progress to Resolved

We're fully done here :)

#25 Updated by intrigeri almost 2 years ago

  • Assignee deleted (intrigeri)

Also available in: Atom PDF