Bug #8659

HiDPI displays are not perfectly supported

Added by bluewater over 2 years ago. Updated over 1 year ago.

Status:ResolvedStart date:03/19/2015
Priority:LowDue date:
Assignee:-% Done:

100%

Category:Hardware support
Target version:Tails_2.0
QA Check: Blueprint:
Feature Branch: Easy:
Type of work:Code Affected tool:

Description

TAILS' display on MacBook Pro with retina display is too small, to the point of making it unusable. Please see screenshots.

Screenshot 1.png (3.27 MB) bluewater, 01/09/2015 10:51 PM

Screenshot 2.png (3.28 MB) bluewater, 01/09/2015 10:51 PM

Screenshot 3.png (3.07 MB) bluewater, 01/09/2015 10:52 PM

Screenshot from 2015-02-27 21_33_14.png - Jessie Tails screenshot on MBP Retina (11,1) (416 KB) garrettr, 02/27/2015 09:55 PM


Subtasks

Bug #9077: Tor Browser UI is too small on HiDPI displaysResolved


Related issues

Blocked by Tails - Feature #6171: Tails based on Jessie Resolved 07/19/2013

History

#1 Updated by intrigeri over 2 years ago

  • Subject changed from TAILS's display is too small on MacBook Pro with retina display to Display is too small on MacBook Pro with retina display
  • Category set to Hardware support
  • Assignee set to bluewater
  • Priority changed from High to Normal
  • QA Check set to Info Needed
  • Type of work changed from Graphics to Research

It's no surprise that the Debian Wheezy X.Org stack and GNOME have no good support for high DPI displays, that simply didn't exist yet back when Wheezy was frozen.

Can you reproduce this issue with the latest experimental ISO image based on Jessie? --> http://nightly.tails.boum.org/build_Tails_ISO_feature-jessie/

#2 Updated by bluewater over 2 years ago

Can you reproduce this issue with the latest experimental ISO image based on Jessie? --> http://nightly.tails.boum.org/build_Tails_ISO_feature-jessie/

I will try and report back. Thank you.

#3 Updated by bluewater over 2 years ago

intrigeri wrote:

Can you reproduce this issue with the latest experimental ISO image based on Jessie? --> http://nightly.tails.boum.org/build_Tails_ISO_feature-jessie/

I've been trying since yesterday to download the latest.iso jessie based TAILS, but unfortunately my connection keeps getting interrupted (from my side) and I have to start all over again downloading the 1GB file, so I think I'll have to donwload it as a torrent. Does it exist as a torrent?

#4 Updated by intrigeri over 2 years ago

I've been trying since yesterday to download the latest.iso jessie based TAILS, but
unfortunately my connection keeps getting interrupted (from my side) and I have to
start all over again downloading the 1GB file,

I suggest you try:

wget -c http://nightly.tails.boum.org/build_Tails_ISO_feature-jessie/latest.iso{,.shasum,.shasum.asc}

Does it exist as a torrent?

Our nightly builds are only available over HTTP.

#5 Updated by sajolida over 2 years ago

The '-c' option stands for 'continue' and will continue getting a partially-downloaded file if the initial download failed.

#6 Updated by bluewater over 2 years ago

Thank you so much, I'm currently downloading the iso using the command you gave me. I'll try it and report back ASAP.

#7 Updated by intrigeri about 2 years ago

Any news?

#8 Updated by garrettr about 2 years ago

I just tried testing this on a mid-2014 Retina Macbook Pro. I downloaded the nightly and verified the checksum as specified in Comment #4 (23030fe82de7d645ca8ba9ca7b0dffc208447d38bd5c35152df5f864dd744960d61ba3ad3196a3eecbdec14df50fb030be3f028ae5810e5058f83bb332200276 tails-i386-feature_jessie-1.3-20150223T0511Z-9375b40.iso, for reference). I run isohybrid.pl on the .iso and dd'ed it onto a USB stick.

Unfortunately I was unable to successfully boot the USB stick. Tails started booting, but after showing a progress indicator and a message about the Modem Manager, it went to an error screen with a message like "Sorry, something went wrong". It had a picture of a frowning face and a "Log out" button.

Please let me know if there is anything I can do to help debug this issue (either the failure of the Nightly/Jessie image to boot on Mac, or the screen resolution issue in general)! I train a lot of journalists to use Tails, and since Macs are so common in the publishing field many of them have newer Mac laptops with Retina screens. Unfortunately, this means using Tails is extremely difficult for them due to this issue. Additionally, it is worth noting that other laptop manufacturers are following Apple's lead and producing laptops with high-DPI displays. These laptops also do not work well with Tails, again because of this issue.

#9 Updated by u about 2 years ago

Unfortunately I was unable to successfully boot the USB stick. Tails started booting, but after showing a
progress indicator and a message about the Modem Manager, it went to an error screen with a message like
"Sorry, something went wrong". It had a picture of a frowning face and a "Log out" button.

I have the same problem booting the latest ISO into Virtualbox.

A previous ISO (from 2 weeks ago approx.) booted successfully, with a much too large display though. Using virtualbox on an older thinkpad).

#10 Updated by BitingBird about 2 years ago

  • Status changed from New to Confirmed

#11 Updated by intrigeri about 2 years ago

I just tried testing this on a mid-2014 Retina Macbook Pro. I downloaded the nightly
and verified the checksum as specified in Comment #4
(23030fe82de7d645ca8ba9ca7b0dffc208447d38bd5c35152df5f864dd744960d61ba3ad3196a3eecbdec14df50fb030be3f028ae5810e5058f83bb332200276
tails-i386-feature_jessie-1.3-20150223T0511Z-9375b40.iso
, for reference). I run
isohybrid.pl on the .iso and dd'ed it onto a USB stick.

Unfortunately I was unable to successfully boot the USB stick. Tails started booting,
but after showing a progress indicator and a message about the Modem Manager, it went
to an error screen with a message like "Sorry, something went wrong". It had
a picture of a frowning face and a "Log out" button.

Sorry about that. This problem is a recurring one that happens each time Tails Greeter is updated on our devel branch => the Jessie ISOs get it instead of the Jessie-specific working one. I've fixed that, and (hopefully) made it so the problem doesn't happen anymore in the future. The next Tails/Jessie nightly built ISO, that should be available online in ~20 minutes, will boot just fine.

#12 Updated by intrigeri about 2 years ago

  • Subject changed from Display is too small on MacBook Pro with retina display to HiDPI displays are not supported

#13 Updated by intrigeri about 2 years ago

  • Status changed from Confirmed to New
  • Target version set to Tails_2.0

This won't be fixed in Tails/Wheezy, so flagging for Tails/Jessie (4.0). And, given it's not been confirmed to affect Tails/Jessie yet, back to New status.

#14 Updated by garrettr about 2 years ago

intrigeri wrote:

The next Tails/Jessie nightly built ISO, that should be available online in ~20 minutes, will boot just fine.

I have confirmed that the latest iso (tails-i386-feature_jessie-1.4-20150227T0510Z-6e49989.iso) boots successfully on Mac. Further, the Retina issue appears to be mostly fixed! Here are some notes:

  1. The initial boot "loading" animation is correctly sized. It momentarily flashes to a much smaller version of itself, which seems like a return to this bug. It also prints some messages at this point, which are very tiny, including one about the Modem manager. However, once the greeter appears, it is correctly sized.
  2. Most of the Tails UI looks great and is correctly sized on a Macbook Pro with Retina (11,1 to be specific).
  3. Some applications do not display correctly, or display only partially correctly, at the moment. See attached screenshot:
    1. everything in Tor Browser is way too small
    2. the icons in KeePassX are too small but other parts (the menus) look OK
    3. the Terminal looks good.

I am not sure if these are issues that Tails-specific, or if they will be worked out as Jessie and its constituent parts approach release.

Since this looks so good, my big question is: when will it be released? There does not appear to be a firm date for Debian Jessie. Do you expect to transition the mainline Tails release to be based on Jessie soon after Jessie is released, or will there will be some delay?

#15 Updated by BitingBird about 2 years ago

There will be some months between Debian Jessie and Tails Jessie, the exact delay depends on many things: Debian release date, our disponibilities etc. We're working on porting Tails to Jessie, that's the milestone 4.0 if you want to look at the status, we have made good progress but we're not there yet. Help is welcome, of course :)

#16 Updated by intrigeri about 2 years ago

Further, the Retina issue appears to be mostly fixed!

Woohoo! I had read that GNOME has been really pretty hard on the HiDPI front, but I did not expect the result to be this good in Jessie yet.

  1. The initial boot "loading" animation is correctly sized. It momentarily flashes to a much smaller version of itself, which seems like a return to this bug. It also prints some messages at this point, which are very tiny, including one about the Modem manager. However, once the greeter appears, it is correctly sized.

That's kind of expected. It also happens on many systems with Tails/Wheezy. In a nutshell, the boot splash screen (handled by the Plymouth I/O multiplexer) is set up before the KMS driver has set the optimal screen resolution. If you're interested in looking into that deeper, please file a dedicated ticket about it. And I guess it makes sense to work on this directly on the feature/jessie branch.

  1. Some applications do not display correctly, or display only partially correctly, at the moment. See attached screenshot:
    1. everything in Tor Browser is way too small
    2. the icons in KeePassX are too small but other parts (the menus) look OK

Maybe file a subtask of this very ticket about each such bug you can find?

I am not sure if these are issues that Tails-specific, or if they will be worked out as Jessie and its constituent parts approach release.

I doubt these issues are Tails specific. I also doubt they qualify as release-critical and have much chance to be fixed in Debian Jessie.

There does not appear to be a firm date for Debian Jessie.

My current best bet is: by the end of April.

Do you expect to transition the mainline Tails release to be based on Jessie soon after Jessie is released, or will there will be some delay?

In the current state of our resources, even if we get all the funding we've asked for, there are very slight chances that we get Tails/Jessie out before October -- and early 2016 seems more realistic. Now, as BitingBird suggested, if we get substantial help I'm not accounting for yet, who knows what better timeline we can aim for :)

#17 Updated by Kuklinski about 2 years ago

I have the same problem but use an asus notebook with 3k screen. Can anyone post a direct link to a working iso of "tails jessie" please?
The "latest.iso" don't works to me. I've burned it on a DVD but this disk is not able to boot...
Many thanks!

#18 Updated by Kuklinski about 2 years ago

Now I got it. It boots. Sorry it was my mistake. About the high DPI screen: For the eye it looks fine now. Almost finished I would say.
The Tor browser toolbar must be bigger, the addon Zoom Menu Elements helps.
A really big problem for now is that the persistent volume dont mount after creating and restart. No asking about the password for it. And for many things the admin password is required although it was not set.
Is there a better version avalable already? :-)

#19 Updated by intrigeri about 2 years ago

Thanks for reporting back! And glad you're bringing good news.

The Tor browser toolbar must be bigger, the addon Zoom Menu Elements helps.

As stated earlier on this ticket: "Maybe file a subtask of this very ticket about each such bug you can find?"
Done in the #9077 subtask for this one.

A really big problem for now is that the persistent volume dont mount after creating and restart. No asking about the password for it. And for many things the admin password is required although it was not set.

These problems are off-topic on this ticket. Please file dedicated tickets about it, thanks! :)

#20 Updated by intrigeri about 2 years ago

  • Subject changed from HiDPI displays are not supported to HiDPI displays are not perfectly supported
  • Status changed from New to Confirmed
  • Assignee deleted (bluewater)
  • QA Check deleted (Info Needed)
  • Type of work changed from Research to Code

#21 Updated by intrigeri over 1 year ago

  • Target version deleted (Tails_2.0)

#22 Updated by intrigeri over 1 year ago

#23 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to Fix committed
  • Target version set to Tails_2.0

#24 Updated by anonym over 1 year ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF