Project

General

Profile

Bug #8897

Feature #14548: Fix issues identified in the expert review done by jaster on our installation instructions

The link to persistence documentation in tails-persistence-setup doesn't trigger any user-visible action

Added by intrigeri over 3 years ago. Updated 19 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Persistence
Target version:
Start date:
02/12/2015
Due date:
% Done:

50%

QA Check:
Pass
Feature Branch:
feature/14594-asp-gui,t-p-s:feature/14594-asp-gui
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Additional Software Packages

Description

Tails 1.2.3, logged in with French locales. The link turns from blue to purple, though.

tps-without-link.png View (53 KB) intrigeri, 06/06/2018 07:33 AM


Related issues

Related to Tails - Bug #5466: Link to documentation in Tails Installer does not open the documentation because it points to an old URL which is not properly redirected in Tails Resolved
Related to Tails - Bug #7989: Jessie: raw HTML is displayed in desktop notifications Resolved 10/02/2014 10/15/2015
Duplicated by Tails - Bug #15579: Link to documentation is broken in persistent storage configuration Duplicate 05/05/2018
Duplicated by Tails - Feature #15119: Link to documentation from persistence assistant Duplicate 12/27/2017

Associated revisions

Revision c7229944 (diff)
Added by intrigeri 4 months ago

Update tails-persistence-setup to its current feature/14594-asp-gui branch (refs: #8897).

… at commit 5ded2e80f1bfc7c641def7a56b0d9d522c7ea514.

History

#1 Updated by intrigeri over 3 years ago

  • Related to Bug #5466: Link to documentation in Tails Installer does not open the documentation because it points to an old URL which is not properly redirected in Tails added

#2 Updated by intrigeri over 3 years ago

t-p-s runs as its dedicated user. No big surprise it doesn't manage to run the system's default web browser (Tor Browser, defined in /etc/gnome/defaults.list, and in the x-www-browser and gnome-www-browser alternatives).

So far, our options seem to be:

  • switch back to using Yelp as the documentation viewer: needs to fix lots of bugs in it first
  • allow t-p-s to run some web browser (probably with a weird config and behaviour) as it own user
  • create a secure enough facility in Tails, to allow an application running as some user to open a URL in a web browser running as another user; in this case, t-p-s would open the link in the Tor Browser, or in the Unsafe Browser, running as the amnesia user; maybe there's prior work in this area; maybe we'll need something like this at some point; maybe it could "simply" be implemented with polkit rules + pkexec
  • anything else?

#3 Updated by intrigeri over 3 years ago

  • Target version changed from Tails_1.3.2 to Tails_1.4

#4 Updated by intrigeri over 3 years ago

  • Target version changed from Tails_1.4 to Hole in the Roof

This has been broken for too long, and I doubt I'll have time to fix it in time for 1.4 => calling it a Hole in the Roof.

#5 Updated by intrigeri over 3 years ago

  • Related to Bug #7989: Jessie: raw HTML is displayed in desktop notifications added

#6 Updated by BitingBird almost 3 years ago

Still the case in Tails Jessie.

#7 Updated by segfault over 2 years ago

I think the link this ticket is about has been removed. I can't see any link in the tails-persistence-setup GUI.

Also, I just tried to start the tor-browser as the tails-persistence-setup user. It gave an error about not being permitted to create "/home/tails-persistence-setup". After creating the home directory, I was able to start the Tor Browser as this user. This only seems to work while the tails-persistence-setup GUI is running.

So maybe we could just create the home directory and put the link back in?

Edit: The Tor Browser run as tails-persistence-setup can't connect to Tor. This (and other problems the different user will cause) might be confusing for users, since the browser window does not look any different than the normal Tor Browser. Maybe we should just leave the link out.

#8 Updated by intrigeri over 2 years ago

segfault wrote:

I think the link this ticket is about has been removed. I can't see any link in the tails-persistence-setup GUI.

There is definitely one when one starts persistence-setup and no persistent volume exists yet: <b>Beware!</b> Using persistence has consequences that must be well understood. Tails can't help you if you use it wrong! See <a href='file:///usr/share/doc/tails/website/doc/first_steps/persistence.en.html'>Tails documentation about persistence</a> to learn more. <- just tested and confirmed.

Also, I just tried to start the tor-browser as the tails-persistence-setup user. It gave an error about not being permitted to create "/home/tails-persistence-setup". After creating the home directory, I was able to start the Tor Browser as this user. This only seems to work while the tails-persistence-setup GUI is running.

So maybe we could just create the home directory and put the link back in?

Edit: The Tor Browser run as tails-persistence-setup can't connect to Tor. This (and other problems the different user will cause) might be confusing for users, since the browser window does not look any different than the normal Tor Browser. Maybe we should just leave the link out.

FTR the link points to file:///, so we don't care if it uses Tor or not. But yeah, firing up a browser (be it the Tor or Unsafe one) as the tails-persistence-setup user is bound to be confusing for users, let's not do that.

#9 Updated by intrigeri 9 months ago

  • Target version deleted (Hole in the Roof)

For #15142 it's very likely that the GUI will have to run as the amnesia user, and then this bug will be magically fixed. This bug has been around forever, so I don't think it's worth working on a temporary solution until then.

#10 Updated by intrigeri 9 months ago

  • Blocked by Feature #15142: Make tails-persistence-setup compatible with Wayland added

#11 Updated by intrigeri 4 months ago

  • Target version set to Tails_3.8

sajolida says that probably no link is better than a broken link. I'll do that for now.

#12 Updated by intrigeri 4 months ago

  • Parent task set to #14568

#13 Updated by intrigeri 4 months ago

  • Blocked by deleted (Feature #15142: Make tails-persistence-setup compatible with Wayland)

#14 Updated by intrigeri 4 months ago

(For now we'll simply remove the link. Once #15142 is done, if the lack of a link to the doc proves to be a problem, we can open a new ticket about re-adding such a link.)

#15 Updated by intrigeri 4 months ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • QA Check set to Ready for QA
  • Feature Branch set to feature/14594-asp-gui,t-p-s:feature/14594-asp-gui

Pushed something, let's see how it goes.

#16 Updated by sajolida 4 months ago

  • Parent task changed from #14568 to #15567

#17 Updated by sajolida 4 months ago

  • Affected tool set to Additional Software Packages

#18 Updated by intrigeri 4 months ago

The new string (with no link) renders as expected, see attached screenshot.

#19 Updated by sajolida 3 months ago

  • Status changed from In Progress to Resolved
  • Assignee changed from sajolida to intrigeri

Cool! Did you do the merge already?

#20 Updated by sajolida 3 months ago

  • QA Check changed from Ready for QA to Pass

#21 Updated by intrigeri 3 months ago

sajolida wrote:

Cool! Did you do the merge already?

I did this work on the ASP topic branches (see the "Feature Branch" field). They'll be merged into devel whenever those branches are ready, i.e. in principle in time for 3.9 (the initial goal was to merge by the end of June but we're not there yet I think).

#22 Updated by sajolida 2 months ago

  • Duplicated by Bug #15579: Link to documentation is broken in persistent storage configuration added

#23 Updated by sajolida 2 months ago

  • Duplicated by Feature #15119: Link to documentation from persistence assistant added

#24 Updated by sajolida 2 months ago

  • Parent task changed from #15567 to #14548

This belongs more to #14548 than to #15567. Sorry for the mess...

#25 Updated by sajolida 2 months ago

  • Status changed from Resolved to Fix committed
  • Target version changed from Tails_3.8 to Tails_3.9

This is not solved in 3.8 but will be merged with Additional Sofware into 3.9.

#26 Updated by intrigeri 2 months ago

  • Assignee deleted (intrigeri)

#27 Updated by intrigeri 19 days ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF