Project

General

Profile

Feature #9151

Add MAT's "Clean metadata" item to Nautilus context menu

Added by IvanBliminse over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
04/01/2015
Due date:
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Easily to fix with the debian package "nautilus-python".


Related issues

Related to Tails - Bug #10881: MAT is not offered as an option when right-clicking an image on Nautilus Rejected 01/08/2016

Associated revisions

Revision 4481f769 (diff)
Added by intrigeri over 3 years ago

Install python-nautilus, that enables MAT's context menu item in Nautilus.

Will-fix: #9151

Revision a53c0b8b (diff)
Added by intrigeri over 3 years ago

Install python-nautilus, that enables MAT's context menu item in Nautilus.

Will-fix: #9151

History

#1 Updated by intrigeri over 3 years ago

My understanding, after a quick look at the code, is that installing gir1.2-nautilus-3.0 might be enough to enable the existing MAT's Nautilus extension.

#2 Updated by IvanBliminse over 3 years ago

sry python-nautilus is the right debian package

#3 Updated by IvanBliminse over 3 years ago

intrigeri wrote:

My understanding, after a quick look at the code, is that installing gir1.2-nautilus-3.0 might be enough to enable the existing MAT's Nautilus extension.

no, python-nautilus adds an lib-file in /usr/lib/nautilus/extensions which is necessary.

#4 Updated by BitingBird over 3 years ago

  • Status changed from New to Confirmed
  • Type of work changed from Discuss to Test

Someone should test if it's possible.

#5 Updated by intrigeri over 3 years ago

  • Status changed from Confirmed to In Progress
  • Assignee set to intrigeri
  • % Done changed from 0 to 10

Indeed, installing python-nautilus seems to be needed. It pulls gir1.2-nautilus-3.0 in as well, and fetches 281 kB of .deb's in total.

After restarting the GNOME session, I still don't see the new menu entry, and .xsession-errors reads:

* (nautilus:6480): CRITICAL **: nautilus_menu_provider_get_background_items: assertion `NAUTILUS_IS_MENU_PROVIDER (provider)' failed

... now building an ISO image to see if installing the needed packages in there fixes this problem. If it doesn't, then I guess the MAT's Nautilus extension might be incompatible with Wheezy, and thus may have to wait for Tails/Jessie.

#6 Updated by intrigeri over 3 years ago

#7 Updated by intrigeri over 3 years ago

  • Subject changed from Add "clean-metadata" item to nautilus right click context menu to Add MAT's "Clean metadata" item to Nautilus context menu

#8 Updated by intrigeri over 3 years ago

intrigeri wrote:

... now building an ISO image to see if installing the needed packages in there fixes this problem. If it doesn't, then I guess the MAT's Nautilus extension might be incompatible with Wheezy, and thus may have to wait for Tails/Jessie.

Same error in Tails/Wheezy, and Nautilus even crashed. Retrying in Tails/Jessie.

#9 Updated by intrigeri over 3 years ago

#10 Updated by intrigeri over 3 years ago

  • Status changed from In Progress to Resolved
  • Target version changed from Tails_1.4 to Tails_2.0
  • % Done changed from 10 to 100
  • Type of work changed from Test to Code

Works fine in Tails/Jessie with the right dependencies installed.

#11 Updated by intrigeri over 2 years ago

  • Related to Bug #10881: MAT is not offered as an option when right-clicking an image on Nautilus added

Also available in: Atom PDF