Project

General

Profile

Bug #9260

Feature #14522: Make Tails usable for blind users

Orca reads neither Tor Browser nor Thunderbird if started after it

Added by sajolida over 2 years ago. Updated 29 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Accessibility
Target version:
Start date:
04/18/2015
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
bugfix/14752-a11y-enabled-after-tor-browser-is-started
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Browser

Description

To reproduce on Tails 1.3.2:

1. Start Tails without networking.
2. Start Tor Browser.
3. Start Orca (Applications → Universal Access → Orca) and click Ok to enable default options.
4. Double-click on some text on the Tor Browser error page.
5. Nothing is read.

If you invert steps 2 and 3, the text in step 5 is read.


Related issues

Related to Tails - Bug #9051: Tor Launcher is not accessible In Progress 03/14/2015
Related to Tails - Bug #14752: On-screen keyboard works neither in Tor Browser nor in Thunderbird if started after it Resolved 09/30/2017
Blocked by Tails - Bug #14735: stable branch FTBFS since the 3.2 release Resolved 09/29/2017

Associated revisions

Revision a3346a75 (diff)
Added by intrigeri 3 months ago

Force Tor Browser to enable accessibility support even if no a11y feature is enabled in GNOME yet (refs: #14752, #9260).

My understanding of the code in accessible/atk/Platform.cpp is: if this envvar
is not set, Firefox will check via D-Bus at startup if accessibility is enabled
in the Desktop, and if it's not it'll permanently disable accessibility,
which breaks use cases like starting the screen keyboard or screen reader
after Tor Browser.

Revision 289c3bf3 (diff)
Added by intrigeri 2 months ago

Force Thunderbird to enable accessibility support even if no a11y feature is enabled in GNOME yet (refs: #14752, #9260).

I did not check the source, but the reasoning from
a3346a75d957d4dfdda91b5e79ed29baca4c92e7 probably applies here as well.

In any case, the symptoms are the same, and the same fix works.

Revision 0b085774
Added by anonym 2 months ago

Merge remote-tracking branch 'origin/bugfix/14752-a11y-enabled-after-tor-browser-is-started' into stable

Fix-committed: #9260, #14752

History

#1 Updated by sajolida over 2 years ago

  • Related to Bug #7502: Chrooted browsers are not accessible added

#2 Updated by sajolida over 2 years ago

  • Related to Bug #9261: Tor Browser crashes on key press when read by Orca added

#3 Updated by intrigeri over 2 years ago

I can reproduce this. I see no corresponding AppArmor log messages, so I think it's unrelated. Now, I'm inclined to flag this as low priority, if not rejected: a user who needs Orca will have it started first... otherwise they'll simply be unable to start Tor Browser.

#4 Updated by intrigeri over 2 years ago

  • Type of work changed from Code to Discuss

#5 Updated by intrigeri over 2 years ago

  • Related to deleted (Bug #9261: Tor Browser crashes on key press when read by Orca)

#6 Updated by sajolida over 2 years ago

  • Assignee set to pzajda
  • Priority changed from Normal to Low
  • QA Check set to Info Needed

pzajda, can you confirm our analysis and otherwise bring this back to
"Normal" priority?

#7 Updated by intrigeri 9 months ago

  • Related to Bug #9051: Tor Launcher is not accessible added

#8 Updated by sajolida 8 months ago

  • Subject changed from Orca doesn't read Tor Browser if started after Tor Browser to Orca doesn't read Tor Browser if Orca is started after Tor Browser

#9 Updated by u 6 months ago

ping @pzajda, can you still reproduce this on current Tails?

#10 Updated by pzajda 5 months ago

I've just checked and this issue still occurs with Tail 3.0.1.

#11 Updated by intrigeri 5 months ago

  • Assignee deleted (pzajda)
  • Priority changed from Low to Normal
  • QA Check deleted (Info Needed)
  • Type of work changed from Discuss to Code

#12 Updated by intrigeri 3 months ago

  • Parent task set to #14522

#13 Updated by intrigeri 3 months ago

  • Blocked by Bug #12384: Forward Greeter accessibility settings to the GNOME session added

#14 Updated by intrigeri 3 months ago

I believe #12384 will fix this, by ensuring Orca is started early after login whenever it was enabled in the Greeter.

#15 Updated by intrigeri 3 months ago

  • Blocked by deleted (Bug #12384: Forward Greeter accessibility settings to the GNOME session)

#16 Updated by intrigeri 3 months ago

  • Blocked by Bug #12384: Forward Greeter accessibility settings to the GNOME session added

#17 Updated by intrigeri 3 months ago

  • Related to deleted (Bug #9051: Tor Launcher is not accessible)

#18 Updated by intrigeri 3 months ago

  • Related to Bug #9051: Tor Launcher is not accessible added

#19 Updated by intrigeri 3 months ago

  • Related to deleted (Bug #7502: Chrooted browsers are not accessible)

#20 Updated by intrigeri 3 months ago

  • Subject changed from Orca doesn't read Tor Browser if Orca is started after Tor Browser to Orca doesn't read Tor Browser if started after it

#21 Updated by intrigeri 3 months ago

  • Related to Bug #14752: On-screen keyboard works neither in Tor Browser nor in Thunderbird if started after it added

#22 Updated by intrigeri 3 months ago

  • Blocked by Bug #14735: stable branch FTBFS since the 3.2 release added

#23 Updated by intrigeri 3 months ago

  • Status changed from Confirmed to In Progress
  • Assignee set to intrigeri
  • Target version set to Tails_3.3
  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/14752-a11y-enabled-after-tor-browser-is-started

#24 Updated by intrigeri 2 months ago

  • Subject changed from Orca doesn't read Tor Browser if started after it to Orca reads neither Tor Browser nor Thunderbird if started after it

#25 Updated by intrigeri 2 months ago

  • % Done changed from 10 to 30

Fixed for Thunderbird as well. Another full test suite run and I think it'll be ready for QA :)

#26 Updated by intrigeri 2 months ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 30 to 50
  • QA Check set to Ready for QA

Full test suite, including @fragile, passed.

#27 Updated by anonym 2 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

#28 Updated by anonym 29 days ago

  • Blocked by deleted (Bug #12384: Forward Greeter accessibility settings to the GNOME session)

#29 Updated by anonym 29 days ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF