Project

General

Profile

Feature #9520

Feature #9519: Make the test suite more deterministic through network simulation

Investigate the Shadow network simulator for use in our test suite

Added by anonym over 2 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
-
Start date:
06/02/2015
Due date:
% Done:

0%

QA Check:
Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

We may want to use Shadow to simulate the Tor network and complete Internet for increased determinism in our test suite.


Related issues

Related to Tails - Bug #9478: How to deal with transient network errors in the test suite? Resolved 05/27/2015
Related to Tails - Feature #9521: Use the chutney Tor network simulator in our test suite Resolved 04/15/2016
Related to Tails - Feature #9087: Write tests for connecting to hosts on a LAN via SSH Resolved 03/21/2015

History

#1 Updated by anonym over 2 years ago

  • Related to Bug #9478: How to deal with transient network errors in the test suite? added

#2 Updated by anonym over 2 years ago

  • Related to Feature #9521: Use the chutney Tor network simulator in our test suite added

#3 Updated by anonym over 2 years ago

Mostly copy-pasted from #9478:

Some problems with using Shadow:
  • It's not packaged in Debian, and building it seems a bit painful (it depends on both the gcc and clang/llvm toolchains, for instance).
  • When using the Tor Network simulator, Tor needs to be built against patched openssl and libevent libraries. Hopefully that only applies to the network nodes, and not the client so we have to hot-patch the Tor inside Tails => more deviation from "real" Tails, more pain since we need to keep this patched Tor client strictly up-to-date with the Tor client version expected in the branch we are testing (urgh!).

#4 Updated by anonym over 2 years ago

  • Related to Feature #9087: Write tests for connecting to hosts on a LAN via SSH added

#5 Updated by intrigeri over 1 year ago

Maybe we should close this ticket, now that we have settled on chutney?

#6 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to Rejected
  • Assignee deleted (anonym)

intrigeri wrote:

Maybe we should close this ticket, now that we have settled on chutney?

Doing that now.

Also available in: Atom PDF