Project

General

Profile

Bug #9965

Adapt our documentation to the deprecation of SD cards

Added by sajolida over 2 years ago. Updated 4 months ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Category:
Hardware support
Target version:
-
Start date:
07/22/2015
Due date:
% Done:

0%

QA Check:
Feature Branch:
doc/9965
Type of work:
End-user documentation
Blueprint:
Easy:
Affected tool:
Installation Assistant


Subtasks

Bug #9790: FAQ: Document that most computers won't boot from SDCardConfirmed


Related issues

Related to Tails - Feature #9884: Rewrite explanation of benefits and drawbacks of different supports Rejected 08/01/2015
Blocks Tails - Feature #13423: Core work 2017Q3: Technical writing Resolved 07/05/2017

History

#1 Updated by sajolida over 2 years ago

  • Related to Feature #9884: Rewrite explanation of benefits and drawbacks of different supports added

#2 Updated by mercedes508 about 2 years ago

  • Assignee set to mercedes508

#3 Updated by mercedes508 about 2 years ago

  • Feature Branch set to doc/9965

#4 Updated by mercedes508 about 2 years ago

  • Assignee changed from mercedes508 to sajolida

I think the changes of the doc are ready to be reviewed.

#5 Updated by intrigeri about 2 years ago

  • QA Check set to Ready for QA

I think the changes of the doc are ready to be reviewed.

Adjusting ticket metadata accordingly.

#6 Updated by sajolida about 2 years ago

  • Assignee changed from sajolida to mercedes508

Thanks for working on this. I went a bit futher and also replaced almost all occurences of "Tails device" to be more precise with either "USB stick" or, more rarely, "USB stick or DVD".

And since we are breaking many translated strings already with that, I also adjusted a few prepositions and other nitpicking. Tell me if you think I went too far.

So please review 7517eb7...75b53e3 carefully. This ended up being much longer than I expected and I'm pushing this quite late in the evening, so I'm tired and I'm not sure that all the sentences are correct now.

Then I'll merge it and translators are going to hate us.

#7 Updated by bertagaz about 2 years ago

  • Assignee changed from mercedes508 to sajolida
  • QA Check changed from Ready for QA to Dev Needed

As far as Jenkins knows, this branch is breaking the build since the last commits on the Oct 11th. It's bit too much behind stable it seems, it's not even 1.6. So some important changes in the build system are missing. But the merge is easy!

When you come back on a branch (specially in this Jenkins/build moving moments), it's good to have something updated enough. Please first merge its config/base_branch back in. At some point it will be impossible to mark something as RfQA without Jenkins doing what I'm doing now, and the last author (and maybe Redmine ticket watchers too) having at least an email each day. Probably even people won't care to build and merge something if Jenkins complains. :)

Someone will have to do this merge, but maybe you don't care for that kind of branches to have the Jenkins feedbacks? If so, please raise the issue in the thread about the automated specs design on the tails-dev mailing list.

#8 Updated by sajolida about 2 years ago

Thanks for the useful methodology tips. I pretty much figured this out
already but I surely lack a bit behind implementation and probably have
several broken builds. I'll also try to pass the word to the other
fellow doc writers as time goes by.

So I merged stable into this branch so this one should be fixed now.

Regarding the implication of automated builds on documentation branches
like this one, I reckon that I should probably have taken a more active
role in the discussion. Still, I remained mostly silent on purpose. I
thought you would be already busy enough figuring out what to do with
code branches and that doc writers website could just wait and see what
gets implemented and ask for special treatments afterwards if really
needed. This discussion would probably also have been quite painful for
us to follow closely and we're busy with other stuff.

Now my responsibility is to adjust to these new tools and processes and
I'll feedback to you how it goes.

#9 Updated by sajolida about 2 years ago

  • Assignee changed from sajolida to mercedes508
  • QA Check changed from Dev Needed to Ready for QA

I merged origin/stable into doc/9965 without trouble (2e90474). So I'm reassigning this to mercedes for review.

#10 Updated by mercedes508 about 2 years ago

  • Assignee changed from mercedes508 to sajolida
  • QA Check changed from Ready for QA to Pass

Thanks for working on this. I went a bit futher and also replaced almost all occurences of "Tails device" to be more precise with either "USB stick" or, more rarely, "USB stick or DVD".

OK.

And since we are breaking many translated strings already with that, I also adjusted a few prepositions and other nitpicking. Tell me if you think I went too far.

Actually I don't see what both 5272a4d & 38235ca have to do with that ticket, so I'd rather see those separated from that ticket and not imply those changes in the merge request.

Then I'll merge it and translators are going to hate us.

Done.

#11 Updated by sajolida about 2 years ago

Actually I don't see what both 5272a4d & 38235ca have to do with that ticket, so I'd rather see those separated from that ticket and not imply those changes in the merge request.

What they have to do with this ticket is that 95% of the strings
affected by these are also affected by the work on this ticket (expect
some in virt-manager.mdwn and known_issues.mdwn). That's a change in
terminology that I wanted to do for a while but I didn't want to break
the translations just for that.

Now that we are changing the terminology around the device itself and
breaking these strings anyway, I thought it was the right time to also
improve the preposition between the device and the action.

With this in mind I'm asking for your kindness and tolerate mixing up
thing a bit here :)

#12 Updated by sajolida about 2 years ago

Now I see that you marked this as passed, so consider merging this straight away!

#13 Updated by sajolida about 2 years ago

  • Assignee changed from sajolida to mercedes508
  • QA Check changed from Pass to Info Needed

Actually, I compiled the updated PO files locally and this branch breaks 361 translated strings! Given that we're going to break most of them again when merging the Installation Assistant at the end of the year, maybe I'd rather not merge this branch now and instead integrate this work as part of the release of the Installation Assistant. What do you think?

If you agree with me, please mark this ticket as:

  • Assignee: sajolida
  • Targer version: 1.8
  • Subtask of #9323
  • QA Check: Dev Needed

Here are the translation statistics before and after the merge:

Before

All website PO files ====================

- de: 25% (1738) strings translated, 1% strings fuzzy, 21% words translated
- fr: 48% (3343) strings translated, 2% strings fuzzy, 44% words translated
- pt: 26% (1823) strings translated, 4% strings fuzzy, 23% words translated

Core PO files =============

- de: 86% (1160) strings translated, 2% strings fuzzy, 85% words translated
- fr: 90% (1206) strings translated, 5% strings fuzzy, 87% words translated
- pt: 81% (1085) strings translated, 11% strings fuzzy, 79% words translated

After

All website PO files ====================

- de: 23% (1650) strings translated, 2% strings fuzzy, 20% words translated
- fr: 46% (3199) strings translated, 4% strings fuzzy, 41% words translated
- pt: 24% (1720) strings translated, 5% strings fuzzy, 21% words translated

Core PO files =============

- de: 80% (1073) strings translated, 9% strings fuzzy, 78% words translated
- fr: 83% (1112) strings translated, 11% strings fuzzy, 78% words translated
- pt: 74% (1002) strings translated, 17% strings fuzzy, 72% words translated

#14 Updated by intrigeri about 2 years ago

Actually, I compiled the updated PO files locally and this branch breaks 361 translated strings! Given that we're going to break most of them again when merging the Installation Assistant at the end of the year, maybe I'd rather not merge this
branch now and instead integrate this work as part of the release of the Installation Assistant.

FWIW: full ACK!

#15 Updated by sajolida almost 2 years ago

  • Target version set to 246
  • Parent task set to #8592
  • Affected tool set to Installation Assistant

We should do that as part of the final release of the installation assistant

#16 Updated by sajolida almost 2 years ago

  • Target version changed from 246 to Tails_2.0

#17 Updated by sajolida almost 2 years ago

  • Assignee changed from mercedes508 to sajolida
  • Parent task deleted (#8592)
  • QA Check changed from Info Needed to Dev Needed

#18 Updated by sajolida almost 2 years ago

  • Target version changed from Tails_2.0 to Tails_2.2

This can wait.

#19 Updated by sajolida over 1 year ago

  • Target version deleted (Tails_2.2)

#20 Updated by sajolida 8 months ago

#21 Updated by sajolida 5 months ago

#22 Updated by sajolida 5 months ago

#23 Updated by sajolida 4 months ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Dev Needed)

I merged this at last! Since we published the Installation Assistant I was scared that this would be a nightmare to merge but in the end it wasn't; too bad it took me so long.

I also get rid of almost all occurrences of "device" in 919e5ea2cc.

Also available in: Atom PDF