Bug #9990

Totem freezes when trying to disable visual effects

Added by mercedes508 almost 2 years ago. Updated over 1 year ago.

Status:ResolvedStart date:08/13/2015
Priority:LowDue date:
Assignee:-% Done:

100%

Category:-
Target version:Tails_2.0
QA Check: Blueprint:
Feature Branch: Easy:
Type of work:Code Affected tool:

Description

When doing the following Totem freezes and has to be killed:

  • Play a mp3 file
  • Pause mp3 file
  • Go to Edit -> Preferences -> Display
  • Uncheck option to Display Visualization

Related issues

Related to Tails - Bug #10455: Totem cannot access DVD readers Resolved 10/29/2015

Associated revisions

Revision 05680a8d
Added by intrigeri over 1 year ago

Install apparmor-profiles-extra from jessie-backports, that grants Totem access to DVD readers (refs: #10455), and fixes a freeze when trying to disable visual effects (refs: #9990).

Revision dac5cce1
Added by intrigeri over 1 year ago

Merge branch 'bugfix/10455-aa-p-e-1.6' into feature/jessie

Closes: #10455, #9990

History

#1 Updated by sajolida almost 2 years ago

  • Assignee set to mercedes508
  • QA Check set to Info Needed

Oh, yes. I can reproduce that. But is this specific to Tails Wheezy? Can you try on Debian Wheezy? Tails Jessie?

#2 Updated by intrigeri almost 2 years ago

Perhaps, first check if there is any AppArmor -related message in the logs. I'd be interested in the output of:

sudo dmesg | grep -i apparmor | grep -E 'totem|gstreamer'

#3 Updated by sajolida almost 2 years ago

Here is it:

[   28.374646] audit: type=1400 audit(1439548366.024:11): apparmor="STATUS" operation="profile_load" name="/usr/bin/totem" pid=3455 comm="apparmor_parser" 
[   32.529052] audit: type=1400 audit(1439548370.180:18): apparmor="STATUS" operation="profile_load" name="/usr/bin/totem-audio-preview" pid=3456 comm="apparmor_parser" 
[   32.529773] audit: type=1400 audit(1439548370.180:19): apparmor="STATUS" operation="profile_load" name="/usr/bin/totem-video-thumbnailer" pid=3456 comm="apparmor_parser" 
[ 1727.070968] audit: type=1400 audit(1439550160.626:26): apparmor="DENIED" operation="open" profile="/usr/bin/totem" name="/etc/dconf/profile/user" pid=32471 comm="totem" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0
[ 1768.173008] audit: type=1400 audit(1439550201.730:27): apparmor="DENIED" operation="open" profile="/usr/bin/totem" name="/etc/dconf/profile/user" pid=32490 comm="totem" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0
[ 1896.176384] audit: type=1400 audit(1439550329.735:28): apparmor="DENIED" operation="open" profile="/usr/bin/totem" name="/etc/dconf/profile/user" pid=32538 comm="totem" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0

But note that:

  • I tried to reproduce the error once more after seeing this and the error didn't trigger a new line.
  • The error only happens when the file is paused. Not if the file is playing.

#4 Updated by mercedes508 almost 2 years ago

  • Type of work changed from Research to Debian

It reproduced it on Debian Wheezy and I found that pretty old bug, where someone seems to already decsribe what we are talking about:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=512565#20

#5 Updated by intrigeri almost 2 years ago

Here is it:

Thanks!

[ 1727.070968] audit: type=1400 audit(1439550160.626:26): apparmor="DENIED" 
operation="open" profile="/usr/bin/totem" name="/etc/dconf/profile/user" pid=32471
comm="totem" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0
[ 1768.173008] audit: type=1400 audit(1439550201.730:27): apparmor="DENIED" 
operation="open" profile="/usr/bin/totem" name="/etc/dconf/profile/user" pid=32490
comm="totem" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0
[ 1896.176384] audit: type=1400 audit(1439550329.735:28): apparmor="DENIED" 
operation="open" profile="/usr/bin/totem" name="/etc/dconf/profile/user" pid=32538
comm="totem" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0

Seems like it's a bug in the dconf AppArmor abstraction.

#6 Updated by intrigeri almost 2 years ago

  • Assignee changed from mercedes508 to intrigeri
  • Type of work changed from Debian to Code

It reproduced it on Debian Wheezy and I found that pretty old bug, where someone seems to already decsribe what we are talking about:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=512565#20

This seems to be a bug in xine-lib, which is not part of Tails. And AppArmor was not supported in Debian back then, so I don't think it's related.

Closing the ticket as it's not in our plate.

Reopening as there's currently no ticket anywhere else that tracks the specific problem that's been reported here, and the info provided by sajolida points quite clearly (for me :) to the missing bits. I'll take care of it upstream.

Thanks everyone!

#7 Updated by intrigeri almost 2 years ago

  • Target version set to Tails_1.6
  • QA Check deleted (Info Needed)

Actually, I've fixed that upstream last month: https://code.launchpad.net/~intrigeri/apparmor/etc-dconf/+merge/265208. Next step is to backport this change to the dconf rules that are inlined in the totem profile. This could be done either as a Jessie stable update of the apparmor-profile-extras package, or rather via jessie-backports. Better wait for the 1.5 upload of this package, though.

#8 Updated by intrigeri almost 2 years ago

  • Target version changed from Tails_1.6 to Tails_1.7

intrigeri wrote:

This could be done either as a Jessie stable update of the apparmor-profile-extras package, or rather via jessie-backports. Better wait for the 1.5 upload of this package, though.

1.5 now is in testing.

#9 Updated by intrigeri over 1 year ago

  • Target version changed from Tails_1.7 to 246

No chance I work on that soon. I'd love to do that for Tails 2.0, but if not, no big deal (that's a corner case).

#10 Updated by sajolida over 1 year ago

  • Target version changed from 246 to Tails_2.0

#11 Updated by intrigeri over 1 year ago

  • Related to Bug #10455: Totem cannot access DVD readers added

#12 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 30

Uploaded 1.6~bpo8+1 to jessie-backports.

#13 Updated by intrigeri over 1 year ago

  • Status changed from In Progress to Resolved
  • % Done changed from 30 to 100

#14 Updated by intrigeri over 1 year ago

  • Assignee deleted (intrigeri)

OK, so we have the AppArmor profile fix in, but anyway on Jessie I don't see that option to disable visual effects.

Also available in: Atom PDF